summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-06-25 11:36:09 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-06-25 11:36:09 +0000
commit48f0dab18dc32cf557443bdd355b223362b83585 (patch)
treeca1422c205d73f5097037ac1fb53356ff92ebd84 /net-mail
parentset no-strict-aliasing under py2.7, revise sed statement, correct doc locatio... (diff)
downloadgentoo-2-48f0dab18dc32cf557443bdd355b223362b83585.tar.gz
gentoo-2-48f0dab18dc32cf557443bdd355b223362b83585.tar.bz2
gentoo-2-48f0dab18dc32cf557443bdd355b223362b83585.zip
Version bump.
NEWS ~~~~ This is a bug fix and portability release. Build System ------------ Make emacs install robust against the non-existence of emacs Put notmuch lib directory first in RPATH Fix handling of html_static_path in sphinx Test Suite ---------- Use --quick when starting emacs (avoids a hang in the T160-json tests) Allow pending break points in atomicity script Command-Line Interface ---------------------- To improve portability use fsync instead of fdatasync in `notmuch-dump`. There should be no functional difference. Library changes --------------- Resurrect support for single-message mbox files Fix for phrase indexing Emacs Interface --------------- Make sure tagging on an empty query is harmless (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/notmuch/ChangeLog42
-rw-r--r--net-mail/notmuch/notmuch-0.18.1.ebuild181
2 files changed, 222 insertions, 1 deletions
diff --git a/net-mail/notmuch/ChangeLog b/net-mail/notmuch/ChangeLog
index e04a4bd5a8c2..846b3645afca 100644
--- a/net-mail/notmuch/ChangeLog
+++ b/net-mail/notmuch/ChangeLog
@@ -1,6 +1,46 @@
# ChangeLog for net-mail/notmuch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.93 2014/05/20 13:03:35 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/ChangeLog,v 1.94 2014/06/25 11:36:09 aidecoe Exp $
+
+*notmuch-0.18.1 (25 Jun 2014)
+
+ 25 Jun 2014; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +notmuch-0.18.1.ebuild:
+ Version bump.
+
+ NEWS
+ ~~~~
+ This is a bug fix and portability release.
+
+ Build System
+ ------------
+
+ Make emacs install robust against the non-existence of emacs
+ Put notmuch lib directory first in RPATH
+ Fix handling of html_static_path in sphinx
+
+ Test Suite
+ ----------
+
+ Use --quick when starting emacs (avoids a hang in the T160-json tests)
+ Allow pending break points in atomicity script
+
+ Command-Line Interface
+ ----------------------
+
+ To improve portability use fsync instead of fdatasync in
+ `notmuch-dump`. There should be no functional difference.
+
+ Library changes
+ ---------------
+
+ Resurrect support for single-message mbox files
+ Fix for phrase indexing
+
+ Emacs Interface
+ ---------------
+
+ Make sure tagging on an empty query is harmless
20 May 2014; Amadeusz Żołnowski <aidecoe@gentoo.org> -notmuch-0.18.ebuild:
Removed old revision of 0.18.
diff --git a/net-mail/notmuch/notmuch-0.18.1.ebuild b/net-mail/notmuch/notmuch-0.18.1.ebuild
new file mode 100644
index 000000000000..e93eff0e97a0
--- /dev/null
+++ b/net-mail/notmuch/notmuch-0.18.1.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/notmuch/notmuch-0.18.1.ebuild,v 1.1 2014/06/25 11:36:09 aidecoe Exp $
+
+EAPI=5
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit elisp-common eutils pax-utils distutils-r1 toolchain-funcs
+
+DESCRIPTION="Thread-based e-mail indexer, supporting quick search and tagging"
+HOMEPAGE="http://notmuchmail.org/"
+SRC_URI="${HOMEPAGE%/}/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( crypt emacs python )
+ "
+IUSE="bash-completion crypt debug doc emacs mutt nmbug python test
+ zsh-completion"
+
+CDEPEND="
+ >=dev-libs/glib-2.22
+ >=dev-libs/gmime-2.6.7
+ !=dev-libs/gmime-2.6.19
+ <dev-libs/xapian-1.3
+ >=sys-libs/zlib-1.2.5.2
+ sys-libs/talloc
+ debug? ( dev-util/valgrind )
+ emacs? ( >=virtual/emacs-23 )
+ python? ( ${PYTHON_DEPS} )
+ x86? ( >=dev-libs/xapian-1.2.7-r2 )
+ "
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( python? ( dev-python/sphinx[${PYTHON_USEDEP}] ) )
+ test? ( app-misc/dtach || ( >=app-editors/emacs-23[libxml2]
+ >=app-editors/emacs-vcs-23[libxml2] ) sys-devel/gdb )
+ "
+RDEPEND="${CDEPEND}
+ bash-completion? ( >=app-shells/bash-completion-1.9 )
+ crypt? ( app-crypt/gnupg )
+ nmbug? ( dev-vcs/git virtual/perl-File-Temp virtual/perl-PodParser )
+ mutt? ( dev-perl/File-Which dev-perl/Mail-Box dev-perl/MailTools
+ dev-perl/String-ShellQuote dev-perl/Term-ReadLine-Gnu
+ virtual/perl-Digest-SHA virtual/perl-File-Path virtual/perl-Getopt-Long
+ virtual/perl-PodParser
+ )
+ zsh-completion? ( app-shells/zsh )
+ "
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+MY_LD_LIBRARY_PATH="${WORKDIR}/${P}/lib"
+MY_PATCHES=( )
+
+bindings() {
+ local ret=0
+
+ if use $1; then
+ pushd bindings/$1 || die
+ shift
+ "$@"
+ ret=$?
+ popd || die
+ fi
+
+ return $ret
+}
+
+pkg_pretend() {
+ if has_version '<net-mail/notmuch-0.18'; then
+ ewarn
+ ewarn "Notmuch 0.18 comes with few not backward compatible changes."
+ ewarn "See NEWS file for details before first use!"
+ ewarn
+ fi
+}
+
+pkg_setup() {
+ if use emacs; then
+ elisp-need-emacs 23 || die "Emacs version too low"
+ fi
+}
+
+src_prepare() {
+ [[ "${MY_PATCHES[@]}" ]] && epatch "${MY_PATCHES[@]}"
+
+ default
+ bindings python distutils-r1_src_prepare
+ bindings python mv README README-python || die
+ mv contrib/notmuch-mutt/README contrib/notmuch-mutt/README-mutt || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bashcompletiondir="${ROOT}/usr/share/bash-completion"
+ --emacslispdir="${ROOT}/${SITELISP}/${PN}"
+ --emacsetcdir="${ROOT}/${SITEETC}/${PN}"
+ --with-gmime-version=2.6
+ --zshcompletiondir="${ROOT}/usr/share/zsh/site-functions"
+ $(use_with bash-completion)
+ $(use_with emacs)
+ $(use_with zsh-completion)
+ )
+ tc-export CC CXX
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ V=1 default
+ bindings python distutils-r1_src_compile
+
+ if use mutt; then
+ pushd contrib/notmuch-mutt || die
+ emake notmuch-mutt.1
+ popd || die
+ fi
+
+ if use doc; then
+ pydocs() {
+ pushd docs || die
+ emake html
+ mv html ../python || die
+ popd || die
+ }
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" bindings python pydocs
+ fi
+}
+
+src_test() {
+ pax-mark -m notmuch
+ LD_LIBRARY_PATH="${MY_LD_LIBRARY_PATH}" default
+ pax-mark -ze notmuch
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use nmbug; then
+ dobin devel/nmbug/nmbug
+ dobin devel/nmbug/nmbug-status
+ fi
+
+ if use mutt; then
+ [[ -e /etc/mutt/notmuch-mutt.rc ]] && NOTMUCH_MUTT_RC_EXISTS=1
+ pushd contrib/notmuch-mutt || die
+ dobin notmuch-mutt
+ doman notmuch-mutt.1
+ insinto /etc/mutt
+ doins notmuch-mutt.rc
+ dodoc README-mutt
+ popd || die
+ fi
+
+ DOCS="" bindings python distutils-r1_src_install
+ use doc && bindings python dohtml -r python
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ if use mutt && [[ ! ${NOTMUCH_MUTT_RC_EXISTS} ]]; then
+ elog "To enable notmuch support in mutt, add the following line into"
+ elog "your mutt config file, please:"
+ elog ""
+ elog " source /etc/mutt/notmuch-mutt.rc"
+ fi
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}