summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-02 15:09:47 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-02 15:09:47 +0000
commit49703d6598ada802b209e7f31bb26a7411471c02 (patch)
tree33c298037c958cc92c68e75bf4bded6a89b5b1d0 /net-mail
parentAdded a patch which fixes a gcc-3.3 multi-line string issue; Closes Bug #30137 (diff)
downloadgentoo-2-49703d6598ada802b209e7f31bb26a7411471c02.tar.gz
gentoo-2-49703d6598ada802b209e7f31bb26a7411471c02.tar.bz2
gentoo-2-49703d6598ada802b209e7f31bb26a7411471c02.zip
Added a patch which fixes a gcc-3.3 multi-line string issue; Closes Bug #30137
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/qmail-autoresponder/ChangeLog8
-rw-r--r--net-mail/qmail-autoresponder/Manifest4
-rw-r--r--net-mail/qmail-autoresponder/files/qmail-autoresponder-0.96.1-gcc33-multiline-string-fix.patch35
-rw-r--r--net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild10
4 files changed, 53 insertions, 4 deletions
diff --git a/net-mail/qmail-autoresponder/ChangeLog b/net-mail/qmail-autoresponder/ChangeLog
index 5eb2c58e47de..53fe71e60d10 100644
--- a/net-mail/qmail-autoresponder/ChangeLog
+++ b/net-mail/qmail-autoresponder/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for net-mail/qmail-autoresponder
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/ChangeLog,v 1.7 2003/05/09 18:14:20 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/ChangeLog,v 1.8 2003/10/02 15:09:45 kumba Exp $
+
*qmail-autoresponder-0.96.1 (09 May 2003)
+ 02 Oct 2003; Joshua Kinard <kumba@gentoo.org>
+ qmail-autoresponder-0.96.1.ebuild:
+ Added a patch which fixes a gcc-3.3 multi-line string issue
+ Closes Bug #30137
+
09 May 2003; Martin Holzer <mholzer@gentoo.org>
qmail-autoresponder-0.96.1.ebuild:
Version bumped.
diff --git a/net-mail/qmail-autoresponder/Manifest b/net-mail/qmail-autoresponder/Manifest
index 222974995a1c..569cec10d3dd 100644
--- a/net-mail/qmail-autoresponder/Manifest
+++ b/net-mail/qmail-autoresponder/Manifest
@@ -1,7 +1,7 @@
-MD5 e4a88ad8d0b245f4a60f6990b43aad76 ChangeLog 1194
+MD5 57297694e324918ca822a1b502ed20a8 ChangeLog 1192
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 8f300da8dcf41d374da29e3baff1416f qmail-autoresponder-0.95.ebuild 1277
-MD5 cead6c4dedbdfafb59c1f7a86d0cdc61 qmail-autoresponder-0.96.1.ebuild 1554
+MD5 22cada58cc441f132dc54c9a2a3f20e7 qmail-autoresponder-0.96.1.ebuild 1551
MD5 90b5670299663d9218e1d8e32476ddd9 files/digest-qmail-autoresponder-0.95 75
MD5 9f8689f8a0b50c22c0a351a281d6c77f files/digest-qmail-autoresponder-0.96.1 77
MD5 6afa2313932bc099d5d9fce81ad915a6 files/qmail-autoresponder-0.96.1-gcc33-multiline-string-fix.patch 1579
diff --git a/net-mail/qmail-autoresponder/files/qmail-autoresponder-0.96.1-gcc33-multiline-string-fix.patch b/net-mail/qmail-autoresponder/files/qmail-autoresponder-0.96.1-gcc33-multiline-string-fix.patch
new file mode 100644
index 000000000000..4f96e81ed6cb
--- /dev/null
+++ b/net-mail/qmail-autoresponder/files/qmail-autoresponder-0.96.1-gcc33-multiline-string-fix.patch
@@ -0,0 +1,35 @@
+diff -ur qmail-autoresponder-0.96.1/main.c qmail-autoresponder-0.96.1-gentoo/main.c
+--- qmail-autoresponder-0.96.1/main.c 2003-10-02 17:56:40.000000000 +1200
++++ qmail-autoresponder-0.96.1-gentoo/main.c 2003-10-02 17:58:48.000000000 +1200
+@@ -244,18 +244,18 @@
+ }
+
+ static const char* usage_str =
+-"usage: %s [-cqDNT] [-n NUM] [-s STR] [-t TIME] %s
+- -c Copy message into response
+- -n NUM Set the maximum number of replies (defaults to 1)
+- -s STR Add the subject to the autoresponse, prefixed by STR
+- -t TIME Set the time interval, in seconds (defaults to 1 hour)
+- -q Don't show error messages
+- -D Don't remove old response records
+- -N Don't send, just send autoresponse to standard output
+- If more than NUM messages are received from the same sender
+- within TIME seconds of each other, no response is sent.
+- This program must be run by qmail.
+-%s";
++"usage: %s [-cqDNT] [-n NUM] [-s STR] [-t TIME] %s\n"
++" -c Copy message into response\n"
++" -n NUM Set the maximum number of replies (defaults to 1)\n"
++" -s STR Add the subject to the autoresponse, prefixed by STR\n"
++" -t TIME Set the time interval, in seconds (defaults to 1 hour)\n"
++" -q Don't show error messages\n"
++" -D Don't remove old response records\n"
++" -N Don't send, just send autoresponse to standard output\n"
++" If more than NUM messages are received from the same sender\n"
++" within TIME seconds of each other, no response is sent.\n"
++" This program must be run by qmail.\n"
++"%s";
+
+ void usage(const char* msg)
+ {
+
diff --git a/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild b/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild
index f7e555444344..40818dee906f 100644
--- a/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild
+++ b/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild,v 1.3 2003/09/05 09:06:05 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmail-autoresponder/qmail-autoresponder-0.96.1.ebuild,v 1.4 2003/10/02 15:09:45 kumba Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Rate-limited autoresponder for qmail."
@@ -15,6 +15,14 @@ DEPEND="virtual/glibc
dev-libs/bglibs"
RDEPEND=">=net-mail/qmail-1.03-r7"
+src_unpack() {
+ unpack ${A}
+
+ # This patch fixes a multi-line string issue with gcc-3.3
+ # Closes Bug #30137
+ epatch ${FILESDIR}/${P}-gcc33-multiline-string-fix.patch
+}
+
src_compile() {
cd ${S}
echo "/usr/lib/bglibs/include" > conf-bgincs