summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-06-21 16:15:30 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-06-21 16:15:30 +0000
commit73d80aa899671744214b805bc903f6a6c0e7f98c (patch)
tree538ccd501b64e6e650dcd254c39970632c3baf38 /net-mail
parentNew version (diff)
downloadgentoo-2-73d80aa899671744214b805bc903f6a6c0e7f98c.tar.gz
gentoo-2-73d80aa899671744214b805bc903f6a6c0e7f98c.tar.bz2
gentoo-2-73d80aa899671744214b805bc903f6a6c0e7f98c.zip
New patched version (fixes buffer overflow, plus other things).
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/fetchmail-5.8.8.ebuild41
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-5.8.81
2 files changed, 42 insertions, 0 deletions
diff --git a/net-mail/fetchmail/fetchmail-5.8.8.ebuild b/net-mail/fetchmail/fetchmail-5.8.8.ebuild
new file mode 100644
index 000000000000..cbed5235fec1
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-5.8.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.8.8.ebuild,v 1.1 2001/06/21 16:15:30 g2boojum Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="fetchmail"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/"${A}
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ if [ "`use ssl`" ] ; then
+ export CFLAGS="$CFLAGS -I/usr/include/openssl"
+ myconf="--with-ssl"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --enable-RPA --enable-NTLN \
+ --enable-SDPS $myconf
+ try make
+}
+
+
+src_install() {
+ try make DESTDIR=${D} install
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README README.NTLM \
+ TODO COPYING MANIFEST
+ docinto html
+ dodoc *.html
+ docinto contrib
+ dodoc contrib/*
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-5.8.8 b/net-mail/fetchmail/files/digest-fetchmail-5.8.8
new file mode 100644
index 000000000000..6902d1904171
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-5.8.8
@@ -0,0 +1 @@
+MD5 53a7b427787206d5b2e5d4bd60362905 fetchmail-5.8.8.tar.gz