summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-29 17:28:19 +0000
commitaa6a19ea25bbed130cef956ef1bd6005cd95bd7e (patch)
tree22f7a92ee079fc4d76db2128cc7ee5a31a028184 /net-mail
parentUpdate (diff)
downloadgentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.gz
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.tar.bz2
gentoo-2-aa6a19ea25bbed130cef956ef1bd6005cd95bd7e.zip
dependencie, fhs and use fixes
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/exim/exim-3.22-r1.ebuild36
-rw-r--r--net-mail/maildrop/maildrop-1.2.2-r3.ebuild13
-rw-r--r--net-mail/procmail/procmail-3.15.1.ebuild6
3 files changed, 42 insertions, 13 deletions
diff --git a/net-mail/exim/exim-3.22-r1.ebuild b/net-mail/exim/exim-3.22-r1.ebuild
index 9e2ac79d1d28..c9758a86b79d 100644
--- a/net-mail/exim/exim-3.22-r1.ebuild
+++ b/net-mail/exim/exim-3.22-r1.ebuild
@@ -9,11 +9,12 @@ DESCRIPTION="A highly configurable, drop-in replacement for sendmail"
SRC_URI="ftp://ftp.exim.org/pub/exim/${A}"
HOMEPAGE="http://www.exim.org/"
-DEPEND=">=net-mail/mailbase-0.00
- >=sys-libs/glibc-2.1.3
- >=sys-devel/perl-5.6.0"
-RDEPEND="!virtual/mta"
+DEPEND="virtual/glibc
+ perl? ( >=sys-devel/perl-5.6.0 )
+ pam? ( >=sys-libs/pam-0.75 )
+ >=sys-libs/db-3.2"
+
TLS_DEP=">=dev-libs/openssl-0.9.6"
LDAP_DEP=">=net-nds/openldap-2.0.7"
@@ -30,6 +31,10 @@ fi
if [ -n "`use mta-mysql`" ]; then
DEPEND="${DEPEND} ${MYSQL_DEP}"
fi
+RDEPEND="$DEPEND !virtual/mta >=net-mail/mailbase-0.00"
+
+DEPEND="$DEPEND tcpd? ( sys-apps/tcp-wrappers )"
+
PROVIDE="virtual/mta"
@@ -51,8 +56,27 @@ src_unpack() {
-e "s:# PID_FILE_PATH=/var/lock/exim%s.pid:PID_FILE_PATH=/var/run/exim%s.pid:" \
-e "s:# SPOOL_DIRECTORY=/var/spool/exim:SPOOL_DIRECTORY=/var/spool/exim:" \
-e "s:# SUPPORT_MAILDIR=yes:SUPPORT_MAILDIR=yes:" \
- -e "s:# SUPPORT_PAM=yes:SUPPORT_PAM=yes:" \
- -e "s:# USE_TCP_WRAPPERS=yes:USE_TCP_WRAPPERS=yes\n\EXTRALIBS=-lpam -lwrap:" src/EDITME > Local/Makefile
+ src/EDITME > Local/Makefile
+
+ cd Local
+ local myconf
+ if [ "`use pam`" ] ; then
+ cp Makefile Makefile.orig
+ sed -e "s:# SUPPORT_PAM=yes:SUPPORT_PAM=yes:" \
+ Makefile.orig > Makefile
+ myconf="-lpam"
+ fi
+ if [ "`use tcpd`" ] ; then
+ cp Makefile Makefile.orig
+ sed -e "s:# USE_TCP_WRAPPERS=yes:USE_TCP_WRAPPERS=yes:" \
+ Makefile.orig > Makefile
+ myconf="$myconf -lwrap"
+ fi
+ if [ "$myconf" ] ; then
+ echo "EXTRALIBS=$myconf" >> Makefile
+ fi
+
+ cd ..
try make
if [ -n "`use mta-tls`" ]; then
diff --git a/net-mail/maildrop/maildrop-1.2.2-r3.ebuild b/net-mail/maildrop/maildrop-1.2.2-r3.ebuild
index ab128081d5fb..558c1ebbd852 100644
--- a/net-mail/maildrop/maildrop-1.2.2-r3.ebuild
+++ b/net-mail/maildrop/maildrop-1.2.2-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/maildrop/maildrop-1.2.2-r3.ebuild,v 1.1 2000/12/15 09:17:19 jerry Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/maildrop/maildrop-1.2.2-r3.ebuild,v 1.2 2001/05/29 17:28:19 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,9 +9,14 @@ DESCRIPTION="Mail delivery agent/filter"
SRC_URI="http://download.sourceforge.net/courier/${A}"
HOMEPAGE="http://www.flounder.net/~mrsam/maildrop/index.html"
-DEPEND=">=sys-libs/gdbm-1.8.0
- >=sys-libs/glibc-2.1.3
- virtual/mta"
+DEPEND="virtual/glibc
+ >=sys-libs/gdbm-1.8.0
+ virtual/mta
+ sys-devel/perl"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/gdbm-1.8.0
+ virtual/mta"
src_compile() {
cd ${S}
diff --git a/net-mail/procmail/procmail-3.15.1.ebuild b/net-mail/procmail/procmail-3.15.1.ebuild
index 9301ffbf727a..16fbadec3537 100644
--- a/net-mail/procmail/procmail-3.15.1.ebuild
+++ b/net-mail/procmail/procmail-3.15.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/procmail-3.15.1.ebuild,v 1.1 2001/04/19 07:14:58 jerry Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/procmail/procmail-3.15.1.ebuild,v 1.2 2001/05/29 17:28:19 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,11 +9,11 @@ DESCRIPTION="Mail delivery agent/filter"
SRC_URI="http://www.procmail.org/${A}"
HOMEPAGE="http://www.procmail.org/"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/glibc
virtual/mta"
src_compile() {
- cd ${S}
+
cp Makefile Makefile.orig
sed -e "s:CFLAGS0 = -O:CFLAGS0 = ${CFLAGS}:" \
-e "s:LOCKINGTEST=__defaults__:#LOCKINGTEST=__defaults__:" \