summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2002-11-16 20:24:22 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2002-11-16 20:24:22 +0000
commitc760199a355e9aab355ef29537b300bbddd99734 (patch)
tree274ea7fb53617946491af70e706d2990ebdb13e5 /net-mail
parentadd ChangeLog for pcsc-lite (diff)
downloadgentoo-2-c760199a355e9aab355ef29537b300bbddd99734.tar.gz
gentoo-2-c760199a355e9aab355ef29537b300bbddd99734.tar.bz2
gentoo-2-c760199a355e9aab355ef29537b300bbddd99734.zip
new revision
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed/ChangeLog10
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.8.5-r11
-rw-r--r--net-mail/sylpheed/sylpheed-0.8.5-r1.ebuild64
3 files changed, 73 insertions, 2 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index cd764a7d43fc..7ae02f566236 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.16 2002/10/04 02:30:29 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.17 2002/11/16 20:24:22 leonardop Exp $
+
+*sylpheed-0.8.5-r1 (16 Nov 2002)
+
+ 16 Nov 2002; L. Boshell <leonardop@gentoo.org> : Use econf and einstall.
+ Implement the `ipv6' USE var. Install .desktop and .png files when the
+ `gnome' USE var is present.
*sylpheed-0.8.5 (03 Oct 2002)
-03 Oct 2002; Brad Cowan <bcowan@gentoo.org> sylpheed-0.8.5.ebuild,
+ 03 Oct 2002; Brad Cowan <bcowan@gentoo.org> sylpheed-0.8.5.ebuild,
files/digest-sylpheed-0.8.5 :
Version bump, bugfixes.
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.8.5-r1 b/net-mail/sylpheed/files/digest-sylpheed-0.8.5-r1
new file mode 100644
index 000000000000..1bf21cec4f21
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.8.5-r1
@@ -0,0 +1 @@
+MD5 e603c1c48c2932d595b775354b550c2e sylpheed-0.8.5.tar.bz2 1891572
diff --git a/net-mail/sylpheed/sylpheed-0.8.5-r1.ebuild b/net-mail/sylpheed/sylpheed-0.8.5-r1.ebuild
new file mode 100644
index 000000000000..dbeafb9c5a65
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.8.5-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.8.5-r1.ebuild,v 1.1 2002/11/16 20:24:22 leonardop Exp $
+
+IUSE="ssl nls gnome ldap crypt pda ipv6"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/compface-1.4
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+ local myconf=""
+
+ use gnome || myconf="--disable-gdk-pixbuf --disable-imlib"
+ use nls || myconf="$myconf --disable-nls"
+ use ssl && myconf="$myconf --enable-ssl"
+ use crypt && myconf="$myconf --enable-gpgme"
+ use pda && myconf="$myconf --enable-jpilot"
+ use ldap && myconf="$myconf --enable-ldap"
+ use ipv6 && myconf="$myconf --enable-ipv6"
+
+ econf $myconf || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install () {
+ einstall \
+ manualdir=${D}/usr/share/doc/${PF}/html || die
+
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/pixmaps
+ doins sylpheed.png
+
+ insinto /usr/share/gnome/apps/Internet
+ doins sylpheed.desktop
+ fi
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}