summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-11 22:43:59 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-11 22:43:59 +0000
commitcff9e16e2fec1e364afdbdc0c1bfcaa6807f6d1c (patch)
treeb58eee6035bec0e5139ed8f8f777696db9150e2a /net-mail
parentnew version (diff)
downloadgentoo-2-cff9e16e2fec1e364afdbdc0c1bfcaa6807f6d1c.tar.gz
gentoo-2-cff9e16e2fec1e364afdbdc0c1bfcaa6807f6d1c.tar.bz2
gentoo-2-cff9e16e2fec1e364afdbdc0c1bfcaa6807f6d1c.zip
fix install
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/balsa/ChangeLog6
-rw-r--r--net-mail/balsa/balsa-1.3.5-r1.ebuild61
-rw-r--r--net-mail/balsa/balsa-1.3.5.ebuild4
-rw-r--r--net-mail/balsa/files/balsa-1.3.5-r1.diff12
-rw-r--r--net-mail/balsa/files/digest-balsa-1.3.5-r11
5 files changed, 81 insertions, 3 deletions
diff --git a/net-mail/balsa/ChangeLog b/net-mail/balsa/ChangeLog
index 8056a8e6b0d3..6fac740770ce 100644
--- a/net-mail/balsa/ChangeLog
+++ b/net-mail/balsa/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-mail/balsa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.5 2002/04/30 12:10:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/ChangeLog,v 1.6 2002/05/11 22:43:59 spider Exp $
+balsa-1.3.5-r1 (11 May 2002)
+ 11 May 2002; Spider <spider@gentoo.org> balsa-1.3.5-r1.ebuild :
+ fix bug with forgotten "install" in src_install stage
+
*balsa-1.3.5 (30 Apr 2002)
30 Apr 2002; Seemant Kulleen <seemant@gentoo.org> balsa-1.3.5.ebuild
diff --git a/net-mail/balsa/balsa-1.3.5-r1.ebuild b/net-mail/balsa/balsa-1.3.5-r1.ebuild
new file mode 100644
index 000000000000..1fa65451f110
--- /dev/null
+++ b/net-mail/balsa/balsa-1.3.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke (blocke@shivan.org)
+# Modified by Riccardo Persichetti (ricpersi@libero.it)
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-1.3.5-r1.ebuild,v 1.1 2002/05/11 22:43:59 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Balsa: email client for GNOME"
+SRC_URI="http://www.theochem.kth.se/~pawsa/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.balsa.net"
+
+DEPEND="=dev-libs/glib-1.2*
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ >=gnome-base/gnome-libs-1.4.1.4
+ >=gnome-base/ORBit-0.5.10-r1
+ >=media-libs/gdk-pixbuf-0.13.0
+ >=net-libs/libesmtp-0.8.11
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ cups? ( >=gnome-base/gnome-print-0.30 )
+ perl? ( >=dev-libs/libpcre-3.4 )
+ spell? ( >=app-text/pspell-0.11.2 )
+ gtkhtml? ( >=gnome-extra/gtkhtml-0.16.1 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ # this patch is from Riccardo Persichetti
+ # (ricpersi@libero.it) to make balsa compile
+ patch -p0 < ${FILESDIR}/${P}.diff
+}
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl && myconf="${myconf} --with-ssl"
+ use gtkhtml && myconf="${myconf} --with-gtkhtml"
+ use perl && myconf="${myconf} --enable-pcre"
+ use spell && myconf="${myconf} --enable-all"
+
+ libmutt/configure --prefix=/usr \
+ --host=${CHOST} \
+ --with-mailpath=/var/mail || die "configure libmutt failed"
+
+ myconf="${myconf} --enable-threads"
+
+ econf ${myconf} || die "configure balsa failed"
+ emake || die "emake failed"
+}
+
+
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ gnomedatadir=${D}/usr/share install || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
+ docinto docs
+ dodoc docs/*
+}
diff --git a/net-mail/balsa/balsa-1.3.5.ebuild b/net-mail/balsa/balsa-1.3.5.ebuild
index 7869f6151688..3579fdcc95c7 100644
--- a/net-mail/balsa/balsa-1.3.5.ebuild
+++ b/net-mail/balsa/balsa-1.3.5.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Bruce A. Locke (blocke@shivan.org)
# Modified by Riccardo Persichetti (ricpersi@libero.it)
-# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-1.3.5.ebuild,v 1.1 2002/04/30 12:10:59 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-1.3.5.ebuild,v 1.2 2002/05/11 22:43:59 spider Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Balsa: email client for GNOME"
@@ -54,7 +54,7 @@ src_install () {
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \
- gnomedatadir=${D}/usr/share || die "make install failed"
+ gnomedatadir=${D}/usr/share install || die "make install failed"
dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO
docinto docs
dodoc docs/*
diff --git a/net-mail/balsa/files/balsa-1.3.5-r1.diff b/net-mail/balsa/files/balsa-1.3.5-r1.diff
new file mode 100644
index 000000000000..92be45444dbe
--- /dev/null
+++ b/net-mail/balsa/files/balsa-1.3.5-r1.diff
@@ -0,0 +1,12 @@
+--- balsa-1.3.5-orig/configure Mon Mar 25 00:34:33 2002
++++ balsa-1.3.5/configure Tue Apr 23 02:15:35 2002
+@@ -6629,7 +6629,7 @@
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpspell $LIBS"
++ LIBS="-lpspell -lstdc++ $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+
diff --git a/net-mail/balsa/files/digest-balsa-1.3.5-r1 b/net-mail/balsa/files/digest-balsa-1.3.5-r1
new file mode 100644
index 000000000000..d68850cc74ed
--- /dev/null
+++ b/net-mail/balsa/files/digest-balsa-1.3.5-r1
@@ -0,0 +1 @@
+MD5 ba83f7054bb31d35c2f7d8d35a9029e3 balsa-1.3.5.tar.bz2 2223158