summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-03 22:29:10 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-03 22:29:10 +0000
commitf782e601bcef9cc49b8998d71ba2fcd0b3ce77cd (patch)
tree3475107655c77c5ba64ce27d06cb9383d1d0acea /net-mail
parentAdded missing digest. Fixes bug #2408. (diff)
downloadgentoo-2-f782e601bcef9cc49b8998d71ba2fcd0b3ce77cd.tar.gz
gentoo-2-f782e601bcef9cc49b8998d71ba2fcd0b3ce77cd.tar.bz2
gentoo-2-f782e601bcef9cc49b8998d71ba2fcd0b3ce77cd.zip
security update
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/evolution/ChangeLog11
-rw-r--r--net-mail/evolution/evolution-1.0.3-r7.ebuild184
-rw-r--r--net-mail/evolution/files/digest-evolution-1.0.3-r72
-rw-r--r--net-mail/evolution/files/evolution-1.0.3-24140.patch11
4 files changed, 207 insertions, 1 deletions
diff --git a/net-mail/evolution/ChangeLog b/net-mail/evolution/ChangeLog
index 015d52d74d48..efe64800b94c 100644
--- a/net-mail/evolution/ChangeLog
+++ b/net-mail/evolution/ChangeLog
@@ -1,7 +1,16 @@
# ChangeLog for net-mail/evolution
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.13 2002/04/29 19:50:28 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/ChangeLog,v 1.14 2002/05/03 22:29:10 spider Exp $
+
+*evolution-1.0.3-r7 (03 May 2002)
+ 03 May 2002; Spider <spider@gentoo.org> evolution-1.0.3-r7.ebuild
+ Adding an important security fix
+
+ as reported on the mailing list yesterday, Evolution 1.0.3 has a serious
+ bug that can make it eat all the memory on your system and then crash
+ when downloading certain messages with invalid headers.
+
29 Apr 2002; Martin Schlemmer <azarah@gentoo.org> evolution-1.0.3-r6.ebuild :
Replaced the "perl" use flag with "doc".
diff --git a/net-mail/evolution/evolution-1.0.3-r7.ebuild b/net-mail/evolution/evolution-1.0.3-r7.ebuild
new file mode 100644
index 000000000000..bcae5d41b0df
--- /dev/null
+++ b/net-mail/evolution/evolution-1.0.3-r7.ebuild
@@ -0,0 +1,184 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Mikael Hallendal <hallski@gentoo.org>, Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/evolution/evolution-1.0.3-r7.ebuild,v 1.1 2002/05/03 22:29:10 spider Exp $
+
+#provide Xmake and Xemake
+. /usr/portage/eclass/inherit.eclass
+inherit virtualx
+
+DB3=db-3.1.17
+S=${WORKDIR}/${P}
+DESCRIPTION="A GNOME groupware application, a Microsoft Outlook workalike"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz
+ ftp://ftp.ximian.com/pub/source/${PN}/${P}.tar.gz
+ http://people.codefactory.se/~micke/${PN}/${P}.tar.gz
+ http://www.sleepycat.com/update/3.1.17/${DB3}.tar.gz"
+HOMEPAGE="http://www.ximian.com"
+
+RDEPEND=">=gnome-extra/bonobo-conf-0.14
+ >=gnome-base/bonobo-1.0.18
+ >=gnome-extra/gal-0.19
+ >=gnome-base/gconf-1.0.7
+ >=gnome-extra/gtkhtml-1.0.1
+ >=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/libglade-0.17-r1
+ >=media-libs/gdk-pixbuf-0.14.0
+ >=dev-libs/libxml-1.8.16
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/gnome-print-0.34
+ >=app-text/scrollkeeper-0.2
+ dev-util/gob
+ ssl? ( >=net-www/mozilla-0.9.9 )
+ ldap? ( >=net-nds/openldap-2.0 )
+ mozilla? ( >=net-www/mozilla-0.9.9 )
+ pda? ( >=gnome-extra/gnome-pilot-0.1.61-r2 )
+ spell? ( >=app-text/gnome-spell-0.4.1-r1 )"
+
+# Added dependency on "dev-util/gob" this should fix a configure bug
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.4.1-r1
+ doc? ( dev-util/gtk-doc )
+ nls? ( >=dev-util/intltool-0.11
+ sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix the filter crash. This is actually a problem in the add and
+ # edit code. Mikael Hallendal originally fixed the bug in the add
+ # code. I added the fixes for the edit code.
+ #
+ # Martin Schlemmer (02 April 2002)
+ patch -p0 < ${FILESDIR}/evolution-1.0.3-filter-crash.patch || die
+ # add mandrake patches
+ # fix KDE detection
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-kde.patch || die
+ # call pilot conduit applet (not pilot link applet)
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-conduit.patch || die
+ # Patch from Preston A. Elder to resolve bug #1355
+ # fix a problem with literal strings and sertain IMAP servers
+ patch -d ${S} -p1 < ${FILESDIR}/evolution-1.0.2-imapfix.diff || die
+
+ # A fix for a recent security related issue
+ patch -d ${S} -p0 < ${FILESDIR}/${PN}-${PV}-24140.patch || die "security-patch failed"
+ # lobtoolize to fix not all libs installing, and buggy .la files.
+ # also add the gnome-pilot.m4 to the macros directory to fix
+ # problems with the pilot conduct
+ cd ${S}
+ if [ ! -f ${S}/macros/gnome-pilot.m4 ]
+ then
+ cp -f ${FILESDIR}/gnome-pilot.m4 ${S}/macros || die
+ fi
+ [ -z "`use pda`" ] && libtoolize --copy --force
+ aclocal -I macros
+ automake --add-missing
+ autoconf
+}
+
+src_compile() {
+
+ cd ${WORKDIR}/${DB3}/build_unix
+ ../dist/configure --prefix=${WORKDIR}/db3 || die
+
+ make || die
+ make prefix=${WORKDIR}/db3 install || die
+
+ cd ${S}
+
+ local myconf=""
+
+ MOZILLA=$MOZILLA_FIVE_HOME
+
+ if [ -n "`use pda`" ] ; then
+ myconf="${myconf} --with-pisock=/usr --enable-pilot-conduits=yes"
+ else
+ myconf="${myconf} --enable-pilot-conduits=no"
+ fi
+
+ if [ -n "`use ldap`" ] ; then
+ myconf="${myconf} --with-openldap=yes"
+ else
+ myconf="${myconf} --with-openldap=no"
+ fi
+
+ if [ -n "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nspr-libs --without-nspr-includes"
+ fi
+
+ if [ -n "`use ssl`" ] ; then
+ myconf="${myconf} --with-nss-includes=${MOZILLA}/include/nss \
+ --with-nss-libs=${MOZILLA}"
+ else
+ myconf="${myconf} --without-nss-libs --without-nss-includes"
+ fi
+
+ # SSL needs NSPR libs ...
+ if [ -n "`use ssl`" ] && [ -z "`use mozilla`" ] ; then
+ myconf="${myconf} --with-nspr-includes=${MOZILLA}/include/nspr \
+ --with-nspr-libs=${MOZILLA}"
+ fi
+
+ if [ -n "`use doc`" ] ; then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} -I/usr/include/libpisock"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-db3=${WORKDIR}/db3 \
+ --disable-python-bindings \
+ ${myconf} || die
+
+ #needs to be able to connect to X display to build.
+ Xemake || Xmake || die
+}
+
+src_install() {
+ cd omf-install
+ cp Makefile Makefile.old
+ sed -e "s:scrollkeeper-update.*::g" Makefile.old > Makefile
+ rm Makefile.old
+ cd ${S}
+
+ # Don't use DESTDIR it violates sandbox // Hallski
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ KDE_APPLNK_DIR=${D}/usr/share/applnk \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog HACKING MAINTAINERS
+ dodoc NEWS README
+}
+
+pkg_postinst() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
+pkg_postrm() {
+ echo ">>> Updating Scrollkeeper database..."
+ scrollkeeper-update >/dev/null 2>&1
+}
+
diff --git a/net-mail/evolution/files/digest-evolution-1.0.3-r7 b/net-mail/evolution/files/digest-evolution-1.0.3-r7
new file mode 100644
index 000000000000..c04a2f7454ba
--- /dev/null
+++ b/net-mail/evolution/files/digest-evolution-1.0.3-r7
@@ -0,0 +1,2 @@
+MD5 28ffb3911f46a591466a78f5c805c0aa evolution-1.0.3.tar.gz 12908768
+MD5 5baeb94fb934d0bf783ea42117c400be db-3.1.17.tar.gz 1954117
diff --git a/net-mail/evolution/files/evolution-1.0.3-24140.patch b/net-mail/evolution/files/evolution-1.0.3-24140.patch
new file mode 100644
index 000000000000..54d24953a4e5
--- /dev/null
+++ b/net-mail/evolution/files/evolution-1.0.3-24140.patch
@@ -0,0 +1,11 @@
+--- camel/camel-mime-utils.c.old Fri May 3 23:02:19 2002
++++ camel/camel-mime-utils.c Fri May 3 23:02:32 2002
+@@ -2367,7 +2367,7 @@
+ } else {
+ /* Fix for stupidly-broken-mailers that like to put '.''s in names unquoted */
+ /* see bug #8147 */
+- if (*inptr && *inptr != '<') {
++ while (!pre && *inptr && *inptr != '<') {
+ w(g_warning("Working around stupid mailer bug #5: unescaped characters in names"));
+ name = g_string_append_c(name, *inptr++);
+ pre = header_decode_word(&inptr);