summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-03-25 19:28:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-03-25 19:28:47 +0000
commit5e40b050b73841cc3dfd0264db9981df98702fe6 (patch)
treee544030f0107e5b60cf934b3c718d20fee7bc15a /net-misc/adjtimex
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-5e40b050b73841cc3dfd0264db9981df98702fe6.tar.gz
gentoo-2-5e40b050b73841cc3dfd0264db9981df98702fe6.tar.bz2
gentoo-2-5e40b050b73841cc3dfd0264db9981df98702fe6.zip
Straight bump to fix bug in init.d script of /usr/bin call without 'need localmount', so startup failed sometimes.
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-misc/adjtimex')
-rw-r--r--net-misc/adjtimex/ChangeLog11
-rw-r--r--net-misc/adjtimex/adjtimex-1.20-r3.ebuild51
-rw-r--r--net-misc/adjtimex/files/adjtimex.init3
3 files changed, 62 insertions, 3 deletions
diff --git a/net-misc/adjtimex/ChangeLog b/net-misc/adjtimex/ChangeLog
index 94e4419e582e..6de78ae0a3d8 100644
--- a/net-misc/adjtimex/ChangeLog
+++ b/net-misc/adjtimex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/adjtimex
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.22 2009/09/23 19:32:56 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.23 2010/03/25 19:28:46 robbat2 Exp $
+
+*adjtimex-1.20-r3 (25 Mar 2010)
+
+ 25 Mar 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +adjtimex-1.20-r3.ebuild, files/adjtimex.init:
+ Straight bump to fix bug in init.d script of /usr/bin call without 'need
+ localmount', so startup failed sometimes.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> adjtimex-1.16.ebuild,
adjtimex-1.16-r1.ebuild, adjtimex-1.20.ebuild, adjtimex-1.20-r1.ebuild,
diff --git a/net-misc/adjtimex/adjtimex-1.20-r3.ebuild b/net-misc/adjtimex/adjtimex-1.20-r3.ebuild
new file mode 100644
index 000000000000..cc5afc54e036
--- /dev/null
+++ b/net-misc/adjtimex/adjtimex-1.20-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/adjtimex-1.20-r3.ebuild,v 1.1 2010/03/25 19:28:46 robbat2 Exp $
+
+inherit fixheadtails eutils
+
+DEBIAN_PV="6"
+MY_P="${P/-/_}"
+DEBIAN_URI="mirror://debian/pool/main/${PN:0:1}/${PN}"
+DEBIAN_PATCH="${MY_P}-${DEBIAN_PV}.diff.gz"
+DEBIAN_SRC="${MY_P}.orig.tar.gz"
+DESCRIPTION="display or set the kernel time variables"
+HOMEPAGE="http://www.ibiblio.org/linsearch/lsms/adjtimex.html"
+SRC_URI="${DEBIAN_URI}/${DEBIAN_PATCH}
+ ${DEBIAN_URI}/${DEBIAN_SRC}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND} sys-apps/sed"
+
+src_unpack() {
+ unpack ${DEBIAN_SRC}
+ epatch ${DISTDIR}/${DEBIAN_PATCH}
+ cd ${S}
+ for i in debian/adjtimexconfig debian/adjtimexconfig.8 ; do
+ sed -e 's|/etc/default/adjtimex|/etc/conf.d/adjtimex|' \
+ -i.orig ${i}
+ sed -e 's|^/sbin/adjtimex |/usr/sbin/adjtimex |' \
+ -i.orig ${i}
+ done
+ epatch ${FILESDIR}/${PN}-1.20-gentoo-utc.patch
+ ht_fix_file debian/adjtimexconfig
+ sed -e '/CFLAGS = -Wall -t/,/endif/d' -i Makefile.in
+ epatch ${FILESDIR}/${PN}-1.16-pic.patch
+ epatch ${FILESDIR}/${PN}-1.20-fix-syscall.patch
+}
+
+src_install() {
+ dodoc README* ChangeLog
+ doman adjtimex.8 debian/adjtimexconfig.8
+ dosbin adjtimex debian/adjtimexconfig
+ newinitd ${FILESDIR}/adjtimex.init adjtimex
+}
+
+pkg_postinst() {
+ einfo "Please run adjtimexconfig to create the configuration file"
+}
diff --git a/net-misc/adjtimex/files/adjtimex.init b/net-misc/adjtimex/files/adjtimex.init
index 50c90a53eda3..fd99138e962a 100644
--- a/net-misc/adjtimex/files/adjtimex.init
+++ b/net-misc/adjtimex/files/adjtimex.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/files/adjtimex.init,v 1.4 2008/09/14 05:03:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/files/adjtimex.init,v 1.5 2010/03/25 19:28:47 robbat2 Exp $
DAEMON=adjtimex
OPTS="--tick ${TICK} --frequency ${FREQ}"
@@ -9,6 +9,7 @@ CONFD="/etc/conf.d/${DAEMON}"
depend() {
before ntp-client ntpd
+ need localmount
}
checkconfig() {