summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-08-26 20:41:52 +0000
committerJeroen Roovers <jer@gentoo.org>2010-08-26 20:41:52 +0000
commitfbbbdffdc60fbe3f095429bd5f2c3ad824b51066 (patch)
tree2199d48bdda4a8da4153193681af8be9c0815ec8 /net-misc/adjtimex
parentBump (diff)
downloadgentoo-2-fbbbdffdc60fbe3f095429bd5f2c3ad824b51066.tar.gz
gentoo-2-fbbbdffdc60fbe3f095429bd5f2c3ad824b51066.tar.bz2
gentoo-2-fbbbdffdc60fbe3f095429bd5f2c3ad824b51066.zip
Version bump. Respect LDFLAGS (bug #334677). Respect CC.
(Portage version: 2.2_rc69/cvs/Linux i686)
Diffstat (limited to 'net-misc/adjtimex')
-rw-r--r--net-misc/adjtimex/ChangeLog8
-rw-r--r--net-misc/adjtimex/adjtimex-1.29.ebuild61
-rw-r--r--net-misc/adjtimex/files/adjtimex-1.29-gentoo-utc.patch23
3 files changed, 91 insertions, 1 deletions
diff --git a/net-misc/adjtimex/ChangeLog b/net-misc/adjtimex/ChangeLog
index 997668eca627..fe2d8c383770 100644
--- a/net-misc/adjtimex/ChangeLog
+++ b/net-misc/adjtimex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/adjtimex
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.24 2010/03/25 19:30:25 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.25 2010/08/26 20:41:52 jer Exp $
+
+*adjtimex-1.29 (26 Aug 2010)
+
+ 26 Aug 2010; Jeroen Roovers <jer@gentoo.org> +adjtimex-1.29.ebuild,
+ +files/adjtimex-1.29-gentoo-utc.patch:
+ Version bump. Respect LDFLAGS (bug #334677). Respect CC.
25 Mar 2010; Robin H. Johnson <robbat2@gentoo.org> -adjtimex-1.16.ebuild,
-adjtimex-1.16-r1.ebuild, -adjtimex-1.20.ebuild, -adjtimex-1.20-r1.ebuild,
diff --git a/net-misc/adjtimex/adjtimex-1.29.ebuild b/net-misc/adjtimex/adjtimex-1.29.ebuild
new file mode 100644
index 000000000000..35cd551af5c1
--- /dev/null
+++ b/net-misc/adjtimex/adjtimex-1.29.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/adjtimex-1.29.ebuild,v 1.1 2010/08/26 20:41:52 jer Exp $
+
+EAPI="2"
+
+inherit eutils fixheadtails toolchain-funcs
+
+DEBIAN_PV="2"
+MY_P="${P/-/_}"
+DEBIAN_URI="mirror://debian/pool/main/${PN:0:1}/${PN}"
+DEBIAN_PATCH="${MY_P}-${DEBIAN_PV}.diff.gz"
+DEBIAN_SRC="${MY_P}.orig.tar.gz"
+DESCRIPTION="display or set the kernel time variables"
+HOMEPAGE="http://www.ibiblio.org/linsearch/lsms/adjtimex.html"
+SRC_URI="${DEBIAN_URI}/${DEBIAN_PATCH}
+ ${DEBIAN_URI}/${DEBIAN_SRC}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_prepare() {
+ cd ${WORKDIR}
+ epatch "${DISTDIR}"/${DEBIAN_PATCH}
+ cd ${S}
+ for i in debian/adjtimexconfig debian/adjtimexconfig.8 ; do
+ sed -e 's|/etc/default/adjtimex|/etc/conf.d/adjtimex|' \
+ -i.orig ${i}
+ sed -e 's|^/sbin/adjtimex |/usr/sbin/adjtimex |' \
+ -i.orig ${i}
+ done
+ epatch "${FILESDIR}"/${P}-gentoo-utc.patch
+ ht_fix_file debian/adjtimexconfig
+ sed -i \
+ -e '/CFLAGS = -Wall -t/,/endif/d' \
+ -e '/$(CC).* -o/s|$(CFLAGS)|& $(LDFLAGS)|g' \
+ Makefile.in || die "sed Makefile.in"
+ #epatch "${FILESDIR}"/${PN}-1.16-pic.patch
+ #epatch "${FILESDIR}"/${PN}-1.20-fix-syscall.patch
+}
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dodoc README* ChangeLog
+ doman adjtimex.8 debian/adjtimexconfig.8
+ dosbin adjtimex debian/adjtimexconfig
+ newinitd "${FILESDIR}"/adjtimex.init adjtimex
+}
+
+pkg_postinst() {
+ einfo "Please run adjtimexconfig to create the configuration file"
+}
diff --git a/net-misc/adjtimex/files/adjtimex-1.29-gentoo-utc.patch b/net-misc/adjtimex/files/adjtimex-1.29-gentoo-utc.patch
new file mode 100644
index 000000000000..6c563a1c8272
--- /dev/null
+++ b/net-misc/adjtimex/files/adjtimex-1.29-gentoo-utc.patch
@@ -0,0 +1,23 @@
+--- a/debian/adjtimexconfig
++++ b/debian/adjtimexconfig
+@@ -3,6 +3,11 @@
+ conffile=/etc/conf.d/adjtimex
+ startfile=/etc/init.d/adjtimex
+
++# Get UTC setting
++source /etc/conf.d/clock
++params=''
++[ "$CLOCK" == "UTC" ] && params='--utc'
++
+ echo -n "Comparing clocks (this will take 70 sec)..."
+
+ # Get the parameters
+@@ -11,7 +16,7 @@
+ baseline=`awk '/<= tick/{print ($1+$NF)/2}' /etc/adj.adjust`
+ hz=`awk '/USER_HZ/{print $3}' /etc/adj.adjust`
+ /usr/sbin/adjtimex --tick $baseline --frequency 0
+-/usr/sbin/adjtimex --adjust --force-adjust >/etc/adj.adjust
++/usr/sbin/adjtimex ${params} --adjust --force-adjust >/etc/adj.adjust
+ echo "done."
+ ticks=`tail -n 1 /etc/adj.adjust|awk '{print $6}'`
+ freq=`tail -n 1 /etc/adj.adjust|awk '{print $7}'`