summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-25 19:22:34 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-10-25 19:22:34 +0000
commit091826b97d0c8a3d4284ee6fd93cc2744d5fdf87 (patch)
treeaa4d7ec18fa0f6b900e8dc89e5f0ec6b590489e7 /net-misc/apt-proxy
parentVersion bump (diff)
downloadgentoo-2-091826b97d0c8a3d4284ee6fd93cc2744d5fdf87.tar.gz
gentoo-2-091826b97d0c8a3d4284ee6fd93cc2744d5fdf87.tar.bz2
gentoo-2-091826b97d0c8a3d4284ee6fd93cc2744d5fdf87.zip
EAPI4, inherit user, use more , add ~amd64
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/apt-proxy')
-rw-r--r--net-misc/apt-proxy/ChangeLog8
-rw-r--r--net-misc/apt-proxy/apt-proxy-1.3.0.ebuild55
2 files changed, 33 insertions, 30 deletions
diff --git a/net-misc/apt-proxy/ChangeLog b/net-misc/apt-proxy/ChangeLog
index 38823f19e15e..fd498fc10850 100644
--- a/net-misc/apt-proxy/ChangeLog
+++ b/net-misc/apt-proxy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-misc/apt-proxy
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-proxy/ChangeLog,v 1.6 2007/05/14 19:45:44 bangert Exp $
+# Copyright 2000-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-proxy/ChangeLog,v 1.7 2012/10/25 19:22:34 ago Exp $
+
+ 25 Oct 2012; Agostino Sarubbo <ago@gentoo.org> apt-proxy-1.3.0.ebuild:
+ EAPI4, inherit user, use more , add ~amd64
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
@@ -19,4 +22,3 @@
22 Apr 2004; Martin Holzer <mholzer@gentoo.org> apt-proxy-1.3.0.ebuild,
files/apt-proxy, files/apt-proxy-1.3.0-sh.patch:
initial ebuild. submitted by Radek Podgorny <radek@podgorny.cz> in 20235
-
diff --git a/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild b/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild
index 6ef9863d60db..8a538f76da98 100644
--- a/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild
+++ b/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild,v 1.7 2010/10/28 10:41:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild,v 1.8 2012/10/25 19:22:34 ago Exp $
-inherit eutils
+EAPI=4
+
+inherit eutils user
DESCRIPTION="Caching proxy for the Debian package system"
HOMEPAGE="http://sourceforge.net/projects/apt-proxy/"
@@ -10,60 +12,59 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-RDEPEND="sys-apps/xinetd
- net-misc/rsync
- net-misc/wget"
+RDEPEND="sys-apps/xinetd"
pkg_setup () {
- enewgroup apt-proxy
- enewuser apt-proxy -1 -1 /dev/null apt-proxy
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
}
-src_compile() {
- #patch -u apt-proxy < ${FILESDIR}/${P}-sh.patch
+src_prepare() {
epatch "${FILESDIR}"/${P}-sh.patch
}
src_install() {
- dosbin apt-proxy
+ dosbin ${PN}
+
+ insinto /etc/${PN}
+ doins ${PN}.conf
- insinto /etc/apt-proxy ; doins apt-proxy.conf
- insinto /etc/xinetd.d ; doins "${FILESDIR}"/apt-proxy
+ insinto /etc/xinetd.d
+ doins "${FILESDIR}"/${PN}
dodoc README INSTALL HISTORY
- doman apt-proxy.{8,conf.5}
+ doman ${PN}.{8,conf.5}
# Create the log file with the proper permissions
dodir /var/log
- touch "${D}"/var/log/apt-proxy.log
- fowners apt-proxy:apt-proxy /var/log/apt-proxy.log
+ touch "${D}"/var/log/${PN}.log
+ fowners ${PN}:${PN} /var/log/${PN}.log
# Create the cache directories and set the proper permissions
- dodir /var/cache/apt-proxy
- keepdir /var/cache/apt-proxy
- fowners apt-proxy:apt-proxy /var/cache/apt-proxy
+ dodir /var/cache/${PN}
+ keepdir /var/cache/${PN}
+ fowners ${PN}:${PN} /var/cache/${PN}
}
pkg_postinst() {
einfo ""
- einfo "Don't forget to modify the /etc/apt-proxy/apt-proxy.conf"
+ einfo "Don't forget to modify the /etc/${PN}/${PN}.conf"
einfo "file to fit your needs..."
einfo ""
- einfo "Also note that apt-proxy is called from running xinetd"
- einfo "and you have to enable it first (/etc/xinetd.d/apt-proxy)..."
+ einfo "Also note that ${PN} is called from running xinetd"
+ einfo "and you have to enable it first (/etc/xinetd.d/${PN})..."
einfo ""
}
pkg_postrm() {
einfo ""
- einfo "You have to remove the apt-proxy cache by hand. It's located"
- einfo "in the \"/var/cache/apt-proxy\" dir..."
+ einfo "You have to remove the ${PN} cache by hand. It's located"
+ einfo "in the \"/var/cache/${PN}\" dir..."
einfo ""
- einfo "You can also remove the apt-proxy user and group..."
+ einfo "You can also remove the ${PN} user and group..."
einfo ""
}