summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-06-15 23:42:46 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-06-15 23:42:46 +0000
commit1500efac56c942410f10d673ee6d67eb086b05c3 (patch)
tree0d7b1d16050409bdbccb96b57210507074448269 /net-misc/asterisk-app_icd
parentSmall tweak to the mips-headers appCompat patch to block off a die() #define ... (diff)
downloadgentoo-2-1500efac56c942410f10d673ee6d67eb086b05c3.tar.gz
gentoo-2-1500efac56c942410f10d673ee6d67eb086b05c3.tar.bz2
gentoo-2-1500efac56c942410f10d673ee6d67eb086b05c3.zip
Initial import, not ready for prime-time (some issues need to be resolved first)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc/asterisk-app_icd')
-rw-r--r--net-misc/asterisk-app_icd/ChangeLog11
-rw-r--r--net-misc/asterisk-app_icd/asterisk-app_icd-1.0.0.ebuild64
-rw-r--r--net-misc/asterisk-app_icd/files/asterisk-app_icd-1.0.0-bristuff.diff11
-rw-r--r--net-misc/asterisk-app_icd/files/asterisk-app_icd-1.0.0-gentoo.diff139
-rw-r--r--net-misc/asterisk-app_icd/files/digest-asterisk-app_icd-1.0.01
-rw-r--r--net-misc/asterisk-app_icd/metadata.xml8
6 files changed, 234 insertions, 0 deletions
diff --git a/net-misc/asterisk-app_icd/ChangeLog b/net-misc/asterisk-app_icd/ChangeLog
new file mode 100644
index 000000000000..4088761e36fa
--- /dev/null
+++ b/net-misc/asterisk-app_icd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/asterisk-app_icd
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_icd/ChangeLog,v 1.1 2005/06/15 23:42:46 stkn Exp $
+
+*asterisk-app_icd-1.0.0 (16 Jun 2005)
+
+ 16 Jun 2005; Stefan Knoblich <stkn@gentoo.org> +metadata.xml,
+ +files/asterisk-app_icd-1.0.0-bristuff.diff,
+ +files/asterisk-app_icd-1.0.0-gentoo.diff, +asterisk-app_icd-1.0.0.ebuild:
+ Initial import, -* masked because some issues need to be resolved.
+
diff --git a/net-misc/asterisk-app_icd/asterisk-app_icd-1.0.0.ebuild b/net-misc/asterisk-app_icd/asterisk-app_icd-1.0.0.ebuild
new file mode 100644
index 000000000000..d5bcf7be3e1d
--- /dev/null
+++ b/net-misc/asterisk-app_icd/asterisk-app_icd-1.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_icd/asterisk-app_icd-1.0.0.ebuild,v 1.1 2005/06/15 23:42:46 stkn Exp $
+
+inherit eutils
+
+MY_PN="icd"
+
+DESCRIPTION="ICD (Intelligent Call Distributor) application plugin for Asterisk"
+HOMEPAGE="http://icd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+IUSE="debug"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+
+DEPEND="sys-libs/glibc
+ >=net-misc/asterisk-1.0.7-r1
+ >=net-misc/zaptel-1.0.7-r1"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ # asterisk + bristuff
+ if built_with_use net-misc/asterisk bri; then
+ epatch ${FILESDIR}/${P}-bristuff.diff
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ use debug && \
+ myconf="${myconf} DEBUG=1"
+
+ emake -j1 \
+ ${myconf} || die "emake failed"
+}
+
+src_install() {
+ make INSTALL_PREFIX=${D} install || die
+
+ insinto /etc/asterisk
+ newins icd_config/extensions.conf.sample extensions.conf.icd
+
+ chmod -R 750 ${D}/etc/asterisk
+ chown -R root:asterisk ${D}/etc/asterisk
+
+ dodoc README README.memory BUGS *.txt
+}
+
+pkg_postinst() {
+ einfo "An example dialplan config for asterisk has been installed into:"
+ einfo " ${ROOT}/etc/asterisk/extensions.conf.icd"
+ einfo ""
+ einfo "See http://icd.sourceforge.net/ for more information"
+}
diff --git a/net-misc/asterisk-app_icd/files/asterisk-app_icd-1.0.0-bristuff.diff b/net-misc/asterisk-app_icd/files/asterisk-app_icd-1.0.0-bristuff.diff
new file mode 100644
index 000000000000..da11a262a219
--- /dev/null
+++ b/net-misc/asterisk-app_icd/files/asterisk-app_icd-1.0.0-bristuff.diff
@@ -0,0 +1,11 @@
+--- icd-1.0.0/icd_bridge.c.orig 2005-06-15 20:44:32.000000000 +0200
++++ icd-1.0.0/icd_bridge.c 2005-06-15 20:44:58.000000000 +0200
+@@ -605,7 +605,7 @@
+ *data = '\0';
+ data++;
+ /* BCA - Is ULAW the only format we support? */
+- chan = ast_request(type, AST_FORMAT_ULAW, data);
++ chan = ast_request(type, AST_FORMAT_ULAW, data, NULL);
+ }
+ ICD_STD_FREE(type);
+ }
diff --git a/net-misc/asterisk-app_icd/files/asterisk-app_icd-1.0.0-gentoo.diff b/net-misc/asterisk-app_icd/files/asterisk-app_icd-1.0.0-gentoo.diff
new file mode 100644
index 000000000000..8bc49a7a5b5e
--- /dev/null
+++ b/net-misc/asterisk-app_icd/files/asterisk-app_icd-1.0.0-gentoo.diff
@@ -0,0 +1,139 @@
+--- icd-1.0.0/Makefile.orig 2005-06-15 20:48:38.000000000 +0200
++++ icd-1.0.0/Makefile 2005-06-15 21:09:04.000000000 +0200
+@@ -3,56 +3,37 @@
+
+ all: .sqlite app_icd.so
+
+-
+ .sqlite:
+ cd sqlite && test -f ./config.status || ./configure --enable-threadsafe
+ cd sqlite && make
+ touch .sqlite
+
+-
+-
+ %.o: %.c
+ @echo -n " ===> Compile:" `pwd` ; echo "/$< ($@)"
+ @$(CC) -fPIC $(CFLAGS) -c -o $@ $<
+
+-
+ app_icd.so: $(OBJS)
+ @echo " ===> Linking: >> $(OBJS) << ($@)"
+ @$(CC) -fPIC -shared -Xlinker -x -o $@ $(OBJS) $(LDFLAGS) ./sqlite/.libs/libsqlite3.a
+
+-
+-config_if_none:
++config:
+ @if [ ! -d $(ASTETCDIR)/icd_config ] ; then echo INSTALLING NEW CONFIGS ;\
+- mkdir $(ASTETCDIR)/icd_config ;\
++ mkdir -p $(ASTETCDIR)/icd_config ;\
+ /bin/cp -dp icd_config/*.conf $(ASTETCDIR)/icd_config ;\
+ echo CONFIGS INSTALLED ;\
+ fi
+
+-
+-config_overwrite:
+- @echo 'INSTALLING CONFIGS (OVERWRITE)'
+- @if [ ! -d $(ASTETCDIR)/icd_config ] ; then mkdir $(ASTETCDIR)/icd_config ; fi
+- @/bin/cp -dp icd_config/*.conf $(ASTETCDIR)/icd_config ;\
+- echo CONFIGS OVERWRITTEN
+-
+-overwrite: clean all install config_overwrite
+-
+-fresh: clean all install
+-
+-$(MODULES_DIR)/app_icd.so: app_icd.so
+- @/bin/cp -pf app_icd.so $(MODULES_DIR)
+-
+-modules: $(MODULES_DIR)/app_icd.so $(DYNA)
+- @/bin/mkdir -p /usr/lib/icd
+- @/bin/cp icd_mod_*.so /usr/lib/icd
++modules: app_icd.so $(DYNA)
++ @/bin/mkdir -p $(INSTALL_PREFIX)/usr/lib/icd
++ @/bin/cp icd_mod_*.so $(INSTALL_PREFIX)/usr/lib/icd
+ @echo OK MODULE INSTALL COMPLETE
+
+-install: all modules config_if_none
+- @echo INSTALLING
+- @/bin/rm -f $(MODULES_DIR)/app_icd.so
++install: modules config
++ @echo INSTALLING
++ @/bin/mkdir -p $(MODULES_DIR)
+ @/bin/cp -p app_icd.so $(MODULES_DIR)
+- @/bin/mkdir -p /usr/lib/icd
+- @/bin/cp icd_mod_*.so /usr/lib/icd
++ @/bin/mkdir -p $(INSTALL_PREFIX)/usr/lib/icd
++ @/bin/cp icd_mod_*.so $(INSTALL_PREFIX)/usr/lib/icd
+ @echo OK INSTALL COMPLETE
+
+ clean:
+@@ -65,5 +46,4 @@
+ %.so: %.c
+ @echo -n " ===> Compile External Module:" `pwd` ; echo "/$< ($@)"
+ @$(CC) -fPIC $(CFLAGS) -c $<
+- @$(CC) -fPIC -shared -Xlinker -x -o $@ $(shell echo $@ | sed "s/\.so/\.o/g" ) /usr/lib/asterisk/modules/app_icd.so $(LDFLAGS)
+-
++ @$(CC) -fPIC -shared -Xlinker -x -o $@ $(shell echo $@ | sed "s/\.so/\.o/g" ) $(LDFLAGS)
+--- icd-1.0.0/make.conf.orig 2005-06-15 20:52:32.000000000 +0200
++++ icd-1.0.0/make.conf 2005-06-15 21:02:26.000000000 +0200
+@@ -1,31 +1,25 @@
+ # what compiler
+-CC=gcc
++CC:=gcc
+ OBJS = app_icd.o icd_agent.o icd_bridge.o icd_caller.o icd_caller_list.o icd_command.o \
+ icd_conference.o icd_config.o icd_customer.o icd_distributor.o icd_distributor_list.o \
+ icd_event.o icd_fieldset.o icd_list.o icd_listeners.o icd_member.o icd_member_list.o \
+ icd_metalist.o icd_queue.o voidhash.o \
+- icd_module_api.o icd_plugable_fn.o icd_plugable_fn_list.o
++ icd_module_api.o icd_plugable_fn.o icd_plugable_fn_list.o
+
+ FORDIST = icd_caller.o icd_distributor.o
+
+ # this is the path to apr-config a MUST HAVE for APR
+-APR_CONFIG=/usr/local/apr/bin/apr-config
++APR_CONFIG:=/usr/bin/apr-config
+
+ # Uncomment YES or NO for apr support or just touch .apr file in the icd src dir.
+-#USE_APR=YES
+-#USE_APR=NO
+-USE_APR=$(shell if [ -f .apr ] ; then echo YES ; else echo NO ; fi )
++USE_APR:=NO
+ # Uncomment to print every malloc/dealloc when apr mode is active
+ #CFLAGS += -DICD_APR_DEBUG
+
+-
+-
+ CFLAGS += $(shell if [ -f $(APR_CONFIG) ] && [ $(USE_APR) = "YES" ] ; then $(APR_CONFIG) --cflags --includes ; fi )
+ CFLAGS += $(shell if [ -f $(APR_CONFIG) ] && [ $(USE_APR) = "YES" ] ; then echo -DUSE_APR ; fi )
+ LDFLAGS += $(shell if [ -f $(APR_CONFIG) ] && [ $(USE_APR) = "YES" ] ; then $(APR_CONFIG) --link-ld --libs ; fi )
+ OBJS += $(shell if [ -f $(APR_CONFIG) ] && [ $(USE_APR) = "YES" ] ; then echo icd_apr.o ; fi )
+-# where is the asterisk source tree
+-ASTSRC = /usr/src/asterisk
+
+ #####################################################################################
+ # copy these from the asterisk top level Makefile
+@@ -39,19 +33,20 @@
+ ASTCONFPATH=$(ASTETCDIR)/asterisk.conf
+ ASTBINDIR=$(INSTALL_PREFIX)/usr/bin
+ ASTSBINDIR=$(INSTALL_PREFIX)/usr/sbin
+-ASTVARRUNDIR=$(INSTALL_PREFIX)/var/run
++ASTVARRUNDIR=$(INSTALL_PREFIX)/var/run/asterisk
+ MODULES_DIR=$(ASTLIBDIR)/modules
+ AGI_DIR=$(ASTVARLIBDIR)/agi-bin
+
+-INCLUDES = -I$(ASTSRC) -I$(ASTSRC)/include -I.
++INCLUDES = -I.
+ CFLAGS += $(INCLUDES)
+ CFLAGS += -DINSTALL_PREFIX=\"$(INSTALL_PREFIX)\" -DASTETCDIR=\"$(ASTETCDIR)\" -DASTLIBDIR=\"$(ASTLIBDIR)\"
+ CFLAGS += -DASTVARLIBDIR=\"$(ASTVARLIBDIR)\" -DASTVARRUNDIR=\"$(ASTVARRUNDIR)\" -DASTSPOOLDIR=\"$(ASTSPOOLDIR)\" -DASTLOGDIR=\"$(ASTLOGDIR)\"
+ CFLAGS += -DASTCONFPATH=\"$(ASTCONFPATH)\" -DASTMODDIR=\"$(MODULES_DIR)\" -DASTAGIDIR=\"$(AGI_DIR)\" -D_GNU_SOURCE
+-CFLAGS += -O0 -g
+ CFLAGS += -Wall
+-#CFLAGS += -DNDEBUG
+
++ifeq ($(DEBUG),1)
++CFLAGS += -g -DNDEBUG
++endif
+
+
+
diff --git a/net-misc/asterisk-app_icd/files/digest-asterisk-app_icd-1.0.0 b/net-misc/asterisk-app_icd/files/digest-asterisk-app_icd-1.0.0
new file mode 100644
index 000000000000..f705061aed68
--- /dev/null
+++ b/net-misc/asterisk-app_icd/files/digest-asterisk-app_icd-1.0.0
@@ -0,0 +1 @@
+MD5 678c981e8e39e211ebc341cf36d8a3e7 icd-1.0.0.tar.gz 1405006
diff --git a/net-misc/asterisk-app_icd/metadata.xml b/net-misc/asterisk-app_icd/metadata.xml
new file mode 100644
index 000000000000..a3cddc42f9cc
--- /dev/null
+++ b/net-misc/asterisk-app_icd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+</maintainer>
+</pkgmetadata>