summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-02-11 18:45:45 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-02-11 18:45:45 +0000
commit06673517679c1284122de060ba5a6f774bc520db (patch)
treef2ac313834b56242377bf3eeab44aebe8110b84c /net-misc/axel/axel-1.1.ebuild
parentamd64 stable wrt bug #201405 (diff)
downloadgentoo-2-06673517679c1284122de060ba5a6f774bc520db.tar.gz
gentoo-2-06673517679c1284122de060ba5a6f774bc520db.tar.bz2
gentoo-2-06673517679c1284122de060ba5a6f774bc520db.zip
Version Bump wrt bug #209577
(Portage version: 2.1.4.1)
Diffstat (limited to 'net-misc/axel/axel-1.1.ebuild')
-rw-r--r--net-misc/axel/axel-1.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/axel/axel-1.1.ebuild b/net-misc/axel/axel-1.1.ebuild
new file mode 100644
index 000000000000..ba1f7bf6e1b7
--- /dev/null
+++ b/net-misc/axel/axel-1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/axel/axel-1.1.ebuild,v 1.1 2008/02/11 18:45:45 drizzt Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="light Unix download accelerator"
+HOMEPAGE="http://axel.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/2287/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Set LDFLAGS and fix expr
+ sed -i -e 's/expr/& --/' -e "s/^LFLAGS=$/&${LDFLAGS}/" configure
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--debug=1"
+ use nls && myconf="--i18n=1"
+ econf \
+ --strip=0 \
+ --etcdir=/etc \
+ ${myconf} \
+ || die
+
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc API CHANGES CREDITS README axelrc.example
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND="/usr/bin/axel -a -o \${DISTDIR}/\${FILE} \${URI}"'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}