summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-01-14 10:52:43 +0000
committerMichael Weber <xmw@gentoo.org>2013-01-14 10:52:43 +0000
commit21f69b7fcc3ef0b271c0f16120a17ec244ec6304 (patch)
tree7ea75b2195831b8bd9f7609a9044b805f467ab30 /net-misc/batctl
parentsci-biology/t-coffee: Don't build TMalign, but depend on sci-chemistry/tm-ali... (diff)
downloadgentoo-2-21f69b7fcc3ef0b271c0f16120a17ec244ec6304.tar.gz
gentoo-2-21f69b7fcc3ef0b271c0f16120a17ec244ec6304.tar.bz2
gentoo-2-21f69b7fcc3ef0b271c0f16120a17ec244ec6304.zip
Version bump (thanks euscan), drop old.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'net-misc/batctl')
-rw-r--r--net-misc/batctl/ChangeLog9
-rw-r--r--net-misc/batctl/batctl-2013.0.0.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/net-misc/batctl/ChangeLog b/net-misc/batctl/ChangeLog
index e289fa0f332e..b4a47f2855d6 100644
--- a/net-misc/batctl/ChangeLog
+++ b/net-misc/batctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/batctl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/ChangeLog,v 1.9 2012/10/29 17:54:01 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/ChangeLog,v 1.10 2013/01/14 10:52:43 xmw Exp $
+
+*batctl-2013.0.0 (14 Jan 2013)
+
+ 14 Jan 2013; Michael Weber <xmw@gentoo.org> +batctl-2013.0.0.ebuild:
+ Version bump (thanks euscan), drop old.
*batctl-2012.4.0 (29 Oct 2012)
diff --git a/net-misc/batctl/batctl-2013.0.0.ebuild b/net-misc/batctl/batctl-2013.0.0.ebuild
new file mode 100644
index 000000000000..e4e157526215
--- /dev/null
+++ b/net-misc/batctl/batctl-2013.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/batctl/batctl-2013.0.0.ebuild,v 1.1 2013/01/14 10:52:43 xmw Exp $
+
+EAPI=4
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="BATMAN advanced control and management tool"
+HOMEPAGE="http://www.open-mesh.org/"
+SRC_URI="http://downloads.open-mesh.org/batman/stable/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ if ( linux_config_exists && linux_chkconfig_present BATMAN_ADV ) \
+ || ! has_version net-misc/batman-adv ; then
+ ewarn "You need the batman-adv kernel module,"
+ ewarn "either from the kernel tree or via net-misc/batman-adv"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 REVISION=gentoo-"${PVR}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc README
+}