summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-10-04 00:23:04 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-10-04 00:23:04 +0000
commit8d3b7b055775311f50aa47622f4d34abf456f237 (patch)
treeca9536cf8ceb3825b72de6f7e2e30c219a89abe7 /net-misc/capi4hylafax
parentunused (diff)
downloadgentoo-2-8d3b7b055775311f50aa47622f4d34abf456f237.tar.gz
gentoo-2-8d3b7b055775311f50aa47622f4d34abf456f237.tar.bz2
gentoo-2-8d3b7b055775311f50aa47622f4d34abf456f237.zip
fixed 64-Bit issue in recvdev.cpp, see bug #145982.
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'net-misc/capi4hylafax')
-rw-r--r--net-misc/capi4hylafax/ChangeLog9
-rw-r--r--net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild143
-rw-r--r--net-misc/capi4hylafax/files/capi4hylafax-01.03.00.99.300.3-recvdev.diff20
-rw-r--r--net-misc/capi4hylafax/files/digest-capi4hylafax-01.03.00.99.300.3-r16
4 files changed, 177 insertions, 1 deletions
diff --git a/net-misc/capi4hylafax/ChangeLog b/net-misc/capi4hylafax/ChangeLog
index 48618558d008..cab76e462da7 100644
--- a/net-misc/capi4hylafax/ChangeLog
+++ b/net-misc/capi4hylafax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/capi4hylafax
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/capi4hylafax/ChangeLog,v 1.19 2006/09/30 00:03:05 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/capi4hylafax/ChangeLog,v 1.20 2006/10/04 00:23:04 sbriesen Exp $
+
+*capi4hylafax-01.03.00.99.300.3-r1 (04 Oct 2006)
+
+ 04 Oct 2006; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/capi4hylafax-01.03.00.99.300.3-recvdev.diff,
+ +capi4hylafax-01.03.00.99.300.3-r1.ebuild:
+ fixed 64-Bit issue in recvdev.cpp, see bug #145982.
*capi4hylafax-01.03.00.99.300.3 (30 Sep 2006)
diff --git a/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild
new file mode 100644
index 000000000000..dc50f608317e
--- /dev/null
+++ b/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/capi4hylafax/capi4hylafax-01.03.00.99.300.3-r1.ebuild,v 1.1 2006/10/04 00:23:04 sbriesen Exp $
+
+inherit eutils versionator
+
+FAX_SPOOL_DIR="/var/spool/fax"
+
+MY_PV1="$(get_version_component_range 1-4)"
+MY_PV2="$(get_version_component_range 5)"
+MY_PV3="$(get_version_component_range 6)"
+MY_P="${PN}_${MY_PV1}.svn.${MY_PV2}"
+
+DESCRIPTION="capi4hylafax adds a faxcapi modem to the hylafax enviroment."
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/capi4hylafax/${MY_P}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/capi4hylafax/${MY_P}-${MY_PV3}.diff.gz"
+HOMEPAGE="http://packages.qa.debian.org/c/capi4hylafax.html"
+
+S="${WORKDIR}/${PN}-svn"
+
+IUSE="unicode"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="net-dialup/capi4k-utils
+ media-libs/tiff
+ media-libs/jpeg
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # apply debian patches + update configs
+ epatch "${WORKDIR}/${MY_P}-${MY_PV3}.diff"
+
+ # apply bugfix patch (see bug #145982)
+ epatch "${FILESDIR}/${P}-recvdev.diff"
+
+ # run libtoolize
+ libtoolize --copy --force
+
+ # fix location of fax spool
+ for i in config.faxCAPI Readme_src src/defaults.h.in debian/*.1; do
+ [ -f "${i}" ] && sed -i -e "s:/var/spool/hylafax:${FAX_SPOOL_DIR}:g" "${i}"
+ done
+
+ # fix location of fax config
+ sed -i -e "s:/etc/hylafax:${FAX_SPOOL_DIR}/etc:g" setupconffile
+
+ # fix name and location of logfile
+ sed -i -e "s:/var/spool/fax/log/capi4hylafax:/var/log/${PN}.log:" config.faxCAPI
+ sed -i -e "s:/tmp/capifax.log:/var/log/${PN}.log:" src/defaults.h.in config.faxCAPI
+
+ # patch man pages
+ sed -i -e "s:/usr/share/doc/capi4hylafax/:/usr/share/doc/${PF}/html/:g" \
+ -e "s:c2send:c2faxsend:g" -e "s:c2recv:c2faxrecv:g" \
+ -e "s:CAPI4HYLAFAXCONFIG \"1\":C2FAXADDMODEM \"8\":g" \
+ -e "s:capi4hylafaxconfig:c2faxaddmodem:g" debian/*.1
+ cp -f debian/capi4hylafaxconfig.1 debian/c2faxaddmodem.8
+
+ # if specified, convert all relevant files from latin1 to UTF-8
+ if use unicode; then
+ for i in config.faxCAPI; do
+ einfo "Converting ${i} to UTF-8"
+ iconv -f latin1 -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_compile() {
+ econf --with-hylafax-spooldir="${FAX_SPOOL_DIR}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ keepdir "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fowners uucp:uucp "${FAX_SPOOL_DIR}" "${FAX_SPOOL_DIR}"/{etc,recvq,pollq,log,status}
+ fperms 0700 "${FAX_SPOOL_DIR}"
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # install setup script
+ newsbin setupconffile c2faxaddmodem
+
+ # install sample config
+ insinto "${FAX_SPOOL_DIR}/etc"
+ newins config.faxCAPI config.faxCAPI.default
+
+ # install docs
+ dodoc AUTHORS ChangeLog Readme_src
+ newdoc debian/changelog ChangeLog.debian
+ dohtml README.html LIESMICH.html
+
+ # install man pages
+ doman debian/c2fax*.[18]
+
+ # install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins sample_faxrcvd faxrcvd config.faxCAPI fritz_pic.tif GenerateFileMail.pl
+ newins sample_AVMC4_config.faxCAPI config.faxCAPI_AVMC4
+ newins debian/faxsend sample_faxsend
+
+ # finally install init-script + config
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}
+
+pkg_postinst() {
+ einfo "To use capi4hylafax:"
+ einfo "Make sure that your isdn/capi devices are owned by"
+ einfo "the \"uucp\" user (see udev or devfsd config)."
+ einfo "Modify ${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ einfo "to suit your system."
+
+ if [ -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI" ]; then
+ einfo
+ einfo "If you're upgrading from a previous version"
+ einfo "please check for new or changed options."
+ einfo "A sample default config is installed as:"
+ einfo "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default"
+ else
+ # install default config
+ cp -f "${FAX_SPOOL_DIR}/etc/config.faxCAPI.default" \
+ "${FAX_SPOOL_DIR}/etc/config.faxCAPI"
+ fi
+
+ einfo
+ einfo "You should also check special options in:"
+ einfo "/etc/conf.d/${PN}"
+ einfo
+ einfo "If you want to use capi4hylafax together with"
+ einfo "hylafax, then please emerge net-misc/hylafax"
+ einfo
+ einfo "Then append the following line to your hylafax"
+ einfo "config file (${FAX_SPOOL_DIR}/etc/config):"
+ einfo "SendFaxCmd: /usr/bin/c2faxsend"
+}
diff --git a/net-misc/capi4hylafax/files/capi4hylafax-01.03.00.99.300.3-recvdev.diff b/net-misc/capi4hylafax/files/capi4hylafax-01.03.00.99.300.3-recvdev.diff
new file mode 100644
index 000000000000..ae56d740c929
--- /dev/null
+++ b/net-misc/capi4hylafax/files/capi4hylafax-01.03.00.99.300.3-recvdev.diff
@@ -0,0 +1,20 @@
+--- src/faxrecv/recvdev.cpp.orig 2006-08-15 11:13:33.000000000 +0200
++++ src/faxrecv/recvdev.cpp 2006-10-04 02:09:46.000000000 +0200
+@@ -114,7 +114,7 @@
+ CMultiString tmpDDIs;
+ CMultiString tmpMSNs;
+ CMultiString *pMSNs;
+- tSize FindPos;
++ tUInt FindPos;
+
+ ConfigAssignment_Item CntrlAssignments[] = {
+ { "Controller", ConfigAssignment_UInt, &tmpController },
+@@ -162,7 +162,7 @@
+ MSNlauf->RemoveChars ((tChar *)" \t_()[]{}\"'`TtPp,.:;");
+ if (MSNlauf->IsEmpty() == vFalse) {
+ FindPos = MSNlauf->FindChar ('-');
+- if (FindPos == MAXVAL_tSize) {
++ if (FindPos == MAXVAL_tUInt) {
+ dprint ("Add MSN-Value=(%s) ", MSNlauf->GetPointer());
+ switch (CIPMSNList.AddMSN (tmpController, MSNlauf)) {
+ case iErr_OutOfMemory:
diff --git a/net-misc/capi4hylafax/files/digest-capi4hylafax-01.03.00.99.300.3-r1 b/net-misc/capi4hylafax/files/digest-capi4hylafax-01.03.00.99.300.3-r1
new file mode 100644
index 000000000000..46f1f6ec12fb
--- /dev/null
+++ b/net-misc/capi4hylafax/files/digest-capi4hylafax-01.03.00.99.300.3-r1
@@ -0,0 +1,6 @@
+MD5 641d17f1c4bb681ba526cff44cd18b6e capi4hylafax_01.03.00.99.svn.300-3.diff.gz 155360
+RMD160 2001d97e99e938823d922d800ba85df74200f520 capi4hylafax_01.03.00.99.svn.300-3.diff.gz 155360
+SHA256 dec167255e2307d12b5093e11ddbb6b1f96d0ac94985643579cfd6b534313ed2 capi4hylafax_01.03.00.99.svn.300-3.diff.gz 155360
+MD5 af2610c5219e89ef9dc47eead30276b4 capi4hylafax_01.03.00.99.svn.300.orig.tar.gz 533410
+RMD160 163374cfcaa91909a5f70169203aa6c7df6a590d capi4hylafax_01.03.00.99.svn.300.orig.tar.gz 533410
+SHA256 8c5433fda85d5f178382c0a4fbc07cf22fc22c448146a4b7a090bc6a0b1789c2 capi4hylafax_01.03.00.99.svn.300.orig.tar.gz 533410