summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2009-03-08 00:05:09 +0000
committerDaniel Black <dragonheart@gentoo.org>2009-03-08 00:05:09 +0000
commit7b9d4b012594b9b346a6e06aa6b2600d479c1a19 (patch)
tree7352427ebfb6fa1de137d97c768c162fb84d3014 /net-misc/curl
parentAdd hamcrest-core to test dependencies. (diff)
downloadgentoo-2-7b9d4b012594b9b346a6e06aa6b2600d479c1a19.tar.gz
gentoo-2-7b9d4b012594b9b346a6e06aa6b2600d479c1a19.tar.bz2
gentoo-2-7b9d4b012594b9b346a6e06aa6b2600d479c1a19.zip
cleanup
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/ChangeLog11
-rw-r--r--net-misc/curl/curl-7.16.4.ebuild111
-rw-r--r--net-misc/curl/curl-7.17.1.ebuild131
-rw-r--r--net-misc/curl/curl-7.18.2.ebuild117
-rw-r--r--net-misc/curl/curl-7.19.2.ebuild117
-rw-r--r--net-misc/curl/curl-7.19.3.ebuild117
-rw-r--r--net-misc/curl/files/curl-7.15-strip-ldflags.patch20
-rw-r--r--net-misc/curl/files/curl-7.15.1-test62.patch15
-rw-r--r--net-misc/curl/files/curl-7.16.2-strip-ldflags.patch24
-rw-r--r--net-misc/curl/files/curl-7.17.1-null-handler-segfault.patch69
-rw-r--r--net-misc/curl/files/curl-7.18.2-nss-threadsafe.patch77
-rw-r--r--net-misc/curl/files/libcurl-gnutlscert.patch51
12 files changed, 10 insertions, 850 deletions
diff --git a/net-misc/curl/ChangeLog b/net-misc/curl/ChangeLog
index f45818c2a8b0..6fc7ace8a820 100644
--- a/net-misc/curl/ChangeLog
+++ b/net-misc/curl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-misc/curl
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.141 2009/03/04 20:00:22 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/ChangeLog,v 1.142 2009/03/08 00:05:08 dragonheart Exp $
+
+ 08 Mar 2009; Daniel Black <dragonheart@gentoo.org>
+ -files/curl-7.15.1-test62.patch, -files/curl-7.15-strip-ldflags.patch,
+ -files/curl-7.16.2-strip-ldflags.patch,
+ -files/curl-7.17.1-null-handler-segfault.patch,
+ -files/curl-7.18.2-nss-threadsafe.patch, -files/libcurl-gnutlscert.patch,
+ -curl-7.16.4.ebuild, -curl-7.17.1.ebuild, -curl-7.18.2.ebuild,
+ -curl-7.19.2.ebuild, -curl-7.19.3.ebuild:
+ cleanup
04 Mar 2009; Tobias Scherbaum <dertobi123@gentoo.org> curl-7.19.4.ebuild:
ppc stable, bug #260361
diff --git a/net-misc/curl/curl-7.16.4.ebuild b/net-misc/curl/curl-7.16.4.ebuild
deleted file mode 100644
index c1198a466059..000000000000
--- a/net-misc/curl/curl-7.16.4.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.16.4.ebuild,v 1.12 2008/04/01 13:46:49 dragonheart Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit autotools eutils
-
-#MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
-
-RDEPEND="gnutls? ( net-libs/gnutls )
- nss? ( !gnutls? ( dev-libs/nss ) )
- ssl? ( !gnutls? ( !nss? ( dev-libs/openssl ) ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )
- app-misc/ca-certificates"
-
-# net-libs/libssh2 (masked) --with-libssh2
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-#S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-# epatch "${FILESDIR}"/${P}-strip-ldflags.patch
- epatch "${FILESDIR}"/curl-7.16.2-strip-ldflags.patch
- elibtoolize
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_with idn libidn)
- $(use_enable kerberos gssapi)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
- --without-krb4
- --without-libssh2
- --without-spnego"
-
- if use ipv6 && use ares; then
- elog "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
- emake || die "install failed for current version"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "curl-7.15.* by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libcurl.so.3"
- fi
-}
diff --git a/net-misc/curl/curl-7.17.1.ebuild b/net-misc/curl/curl-7.17.1.ebuild
deleted file mode 100644
index 386b59d12b1a..000000000000
--- a/net-misc/curl/curl-7.17.1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.17.1.ebuild,v 1.9 2008/12/07 11:05:47 vapier Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit libtool eutils
-
-#MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
-#IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
-
-RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
- nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
- ssl? ( !gnutls? ( !nss? ( dev-libs/openssl app-misc/ca-certificates ) ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )"
-# libssh2? ( >=net-libs/libssh2-0.16 )"
-
-# net-libs/libssh2 (masked) --with-libssh2
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-#S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-# epatch "${FILESDIR}"/${P}-strip-ldflags.patch
- epatch "${FILESDIR}"/curl-7.16.2-strip-ldflags.patch
- epatch "${FILESDIR}"/${P}-null-handler-segfault.patch
- elibtoolize
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_enable ldap ldaps)
- $(use_with idn libidn)
- $(use_with kerberos gssapi /usr)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt
- --without-krb4
- --without-libssh2
- --without-spnego"
-# $(use_with libssh2)
-
- if use ldap && use kerberos; then
- die 'ldap and kerberos (gssapi) not playing nicely try version >=7.18.1'
- fi
-
- if use ipv6 && use ares; then
- elog "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
- emake || die "install failed for current version"
-}
-
-src_test() {
- if use gnutls; then
- elog 'disabling test 405 ftps as gnutls does differing return codes'
- elog 'that the test case does not allow for. '
- elog 'https://bugs.gentoo.org/show_bug.cgi?id=204130 refers'
- cd "${S}"/tests
- ./runtests.pl -a -s '!405' || die 'self test failed'
- else
- make check || die 'self test failed'
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "curl-7.15.* by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libcurl.so.3"
- fi
-}
diff --git a/net-misc/curl/curl-7.18.2.ebuild b/net-misc/curl/curl-7.18.2.ebuild
deleted file mode 100644
index f58e9bb0fc9b..000000000000
--- a/net-misc/curl/curl-7.18.2.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.18.2.ebuild,v 1.9 2008/12/07 11:05:47 vapier Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit libtool autotools
-
-#MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-#IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
-IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
-
-# TODO - change to openssl USE flag in the not too distant future
-# https://bugs.gentoo.org/show_bug.cgi?id=207653#c3 (April 2008)
-
-RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
- nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
- ssl? ( !gnutls? ( !nss? ( dev-libs/openssl app-misc/ca-certificates ) ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )
- libssh2? ( >=net-libs/libssh2-0.16 )"
-
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-#S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
- epatch "${FILESDIR}"/curl-7.18.2-nss-threadsafe.patch
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_enable ldap ldaps)
- $(use_with idn libidn)
- $(use_with kerberos gssapi /usr)
- $(use_with libssh2)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --without-krb4
- --without-spnego"
-
- if use ipv6 && use ares; then
- elog "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
-
- emake || die "install failed for current version"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "curl-7.15.* by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libcurl.so.3"
- fi
-}
diff --git a/net-misc/curl/curl-7.19.2.ebuild b/net-misc/curl/curl-7.19.2.ebuild
deleted file mode 100644
index 17f7f1759930..000000000000
--- a/net-misc/curl/curl-7.19.2.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.19.2.ebuild,v 1.1 2008/11/22 05:33:50 loki_val Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit multilib eutils
-
-#MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-#IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
-IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
-
-# TODO - change to openssl USE flag in the not too distant future
-# https://bugs.gentoo.org/show_bug.cgi?id=207653#c3 (April 2008)
-
-RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
- nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
- ssl? ( !gnutls? ( !nss? ( dev-libs/openssl app-misc/ca-certificates ) ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )
- libssh2? ( >=net-libs/libssh2-0.16 )"
-
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-#S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_enable ldap ldaps)
- $(use_with idn libidn)
- $(use_with kerberos gssapi /usr)
- $(use_with libssh2)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --without-krb4
- --without-spnego"
-
- if use ipv6 && use ares; then
- elog "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
-
- emake || die "install failed for current version"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "curl-7.15.* by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libcurl.so.3"
- fi
-}
diff --git a/net-misc/curl/curl-7.19.3.ebuild b/net-misc/curl/curl-7.19.3.ebuild
deleted file mode 100644
index 22b7bf87d9fb..000000000000
--- a/net-misc/curl/curl-7.19.3.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.19.3.ebuild,v 1.7 2009/02/17 17:12:51 armin76 Exp $
-
-# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
-
-inherit multilib eutils
-
-#MY_P=${P/_pre/-}
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="http://curl.haxx.se/ http://curl.planetmirror.com"
-#SRC_URI="http://cool.haxx.se/curl-daily/${MY_P}.tar.bz2"
-#SRC_URI="http://curl.planetmirror.com/download/${P}.tar.bz2"
-SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
-
-LICENSE="MIT X11"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-#IUSE="ssl ipv6 ldap ares gnutls nss idn kerberos test"
-IUSE="ssl ipv6 ldap ares gnutls libssh2 nss idn kerberos test"
-
-# TODO - change to openssl USE flag in the not too distant future
-# https://bugs.gentoo.org/show_bug.cgi?id=207653#c3 (April 2008)
-
-RDEPEND="gnutls? ( net-libs/gnutls app-misc/ca-certificates )
- nss? ( !gnutls? ( dev-libs/nss app-misc/ca-certificates ) )
- ssl? ( !gnutls? ( !nss? ( dev-libs/openssl app-misc/ca-certificates ) ) )
- ldap? ( net-nds/openldap )
- idn? ( net-dns/libidn )
- ares? ( >=net-dns/c-ares-1.4.0 )
- kerberos? ( virtual/krb5 )
- libssh2? ( >=net-libs/libssh2-0.16 )"
-
-# fbopenssl (not in gentoo) --with-spnego
-# krb4 http://web.mit.edu/kerberos/www/krb4-end-of-life.html
-
-DEPEND="${RDEPEND}
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-# used - but can do without in self test: net-misc/stunnel
-#S="${WORKDIR}"/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/curl-7.17.0-strip-ldflags.patch
-}
-
-src_compile() {
-
- myconf="$(use_enable ldap)
- $(use_enable ldap ldaps)
- $(use_with idn libidn)
- $(use_with kerberos gssapi /usr)
- $(use_with libssh2)
- $(use_enable ipv6)
- --enable-http
- --enable-ftp
- --enable-gopher
- --enable-file
- --enable-dict
- --enable-manual
- --enable-telnet
- --enable-nonblocking
- --enable-largefile
- --enable-maintainer-mode
- --disable-sspi
- --without-krb4
- --without-spnego"
-
- if use ipv6 && use ares; then
- elog "c-ares support disabled because it is incompatible with ipv6."
- myconf="${myconf} --disable-ares"
- else
- myconf="${myconf} $(use_enable ares)"
- fi
-
- if use gnutls; then
- myconf="${myconf} --without-ssl --with-gnutls --without-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use nss; then
- myconf="${myconf} --without-ssl --without-gnutls --with-nss"
- myconf="${myconf} --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt"
- elif use ssl; then
- myconf="${myconf} --without-gnutls --without-nss --with-ssl"
- myconf="${myconf} --without-ca-bundle --with-ca-path=/etc/ssl/certs"
- else
- myconf="${myconf} --without-gnutls --without-nss --without-ssl"
- fi
-
- econf ${myconf} || die 'configure failed'
-
- emake || die "install failed for current version"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installed failed for current version"
- rm -rf "${D}"/etc/
-
- # https://sourceforge.net/tracker/index.php?func=detail&aid=1705197&group_id=976&atid=350976
- insinto /usr/share/aclocal
- doins docs/libcurl/libcurl.m4
-
- dodoc CHANGES README
- dodoc docs/FEATURES docs/INTERNALS
- dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
-}
-
-pkg_postinst() {
- if [[ -e "${ROOT}"/usr/$(get_libdir)/libcurl.so.3 ]] ; then
- elog "You must re-compile all packages that are linked against"
- elog "curl-7.15.* by using revdep-rebuild from gentoolkit:"
- elog "# revdep-rebuild --library libcurl.so.3"
- fi
-}
diff --git a/net-misc/curl/files/curl-7.15-strip-ldflags.patch b/net-misc/curl/files/curl-7.15-strip-ldflags.patch
deleted file mode 100644
index 5c5999aee657..000000000000
--- a/net-misc/curl/files/curl-7.15-strip-ldflags.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- curl-7.15.4/curl-config.in 2006-05-02 23:48:22.000000000 +0100
-+++ curl-7.15.4/curl-config.in 2006-07-17 12:32:59.000000000 +0100
-@@ -181,7 +181,7 @@
- ;;
-
- --libs)
-- echo -L@libdir@ -lcurl @LDFLAGS@ @LIBS@
-+ echo -L@libdir@ -lcurl @LIBS@
- ;;
-
- *)
---- curl-7.15.4/libcurl.pc.in 2004-12-11 18:46:40.000000000 +0000
-+++ curl-7.15.4/libcurl.pc.in 2006-07-17 12:33:10.000000000 +0100
-@@ -6,5 +6,5 @@
- Name: libcurl
- Description: Library to transfer files with ftp, http, etc.
- Version: @VERSION@
--Libs: -L${libdir} -lcurl @LDFLAGS@ @LIBS@
-+Libs: -L${libdir} -lcurl @LIBS@
- Cflags: -I${includedir}
diff --git a/net-misc/curl/files/curl-7.15.1-test62.patch b/net-misc/curl/files/curl-7.15.1-test62.patch
deleted file mode 100644
index 15ec36372d72..000000000000
--- a/net-misc/curl/files/curl-7.15.1-test62.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- curl-7.15.5/tests/data/test62.orig 2007-02-11 13:56:10.000000000 +1100
-+++ curl-7.15.5/tests/data/test62 2007-02-11 14:01:18.000000000 +1100
-@@ -32,9 +32,9 @@
- # http://www.netscape.com/newsref/std/cookie_spec.html
- # This file was generated by libcurl! Edit at your own risk.
-
--.foo.com TRUE /we/want/ FALSE 1170327387 test yes
--.host.foo.com TRUE /we/want/ FALSE 1170327387 test2 yes
--.fake.host.foo.com TRUE /we/want/ FALSE 1170327387 test4 yes
-+.foo.com TRUE /we/want/ FALSE 1577802600 test yes
-+.host.foo.com TRUE /we/want/ FALSE 1577802600 test2 yes
-+.fake.host.foo.com TRUE /we/want/ FALSE 1577802600 test4 yes
-
- .foo.com TRUE /moo TRUE 0 test3 maybe
- </file>
diff --git a/net-misc/curl/files/curl-7.16.2-strip-ldflags.patch b/net-misc/curl/files/curl-7.16.2-strip-ldflags.patch
deleted file mode 100644
index 1c33fc5f8e1d..000000000000
--- a/net-misc/curl/files/curl-7.16.2-strip-ldflags.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- curl-7.16.2/libcurl.pc.in.orig 2007-04-14 10:11:14.000000000 +1000
-+++ curl-7.16.2/libcurl.pc.in 2007-04-14 10:11:26.000000000 +1000
-@@ -33,6 +33,6 @@
- URL: http://curl.haxx.se/
- Description: Library to transfer files with ftp, http, etc.
- Version: @VERSION@
--Libs: -L${libdir} -lcurl @LDFLAGS@ @LIBS@
-+Libs: -L${libdir} -lcurl @LIBS@
- Libs.private: @LIBCURL_LIBS@ @LIBS@
- Cflags: -I${includedir}
---- curl-7.16.3/curl-config.in.orig 2007-06-28 22:22:51.000000000 +1000
-+++ curl-7.16.3/curl-config.in 2007-06-28 22:23:10.000000000 +1000
-@@ -187,9 +187,9 @@
- CURLLIBDIR=""
- fi
- if test "X@REQUIRE_LIB_DEPS@" = "Xyes"; then
-- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBCURL_LIBS@ @LIBS@
-+ echo ${CURLLIBDIR}-lcurl @LIBCURL_LIBS@ @LIBS@
- else
-- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBS@
-+ echo ${CURLLIBDIR}-lcurl @LIBS@
- fi
- ;;
-
diff --git a/net-misc/curl/files/curl-7.17.1-null-handler-segfault.patch b/net-misc/curl/files/curl-7.17.1-null-handler-segfault.patch
deleted file mode 100644
index 0d3b766e9175..000000000000
--- a/net-misc/curl/files/curl-7.17.1-null-handler-segfault.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-Segfault in CURL (used from PHP)
-Found by Robin H. Johnson <robbat2@gentoo.org>
-This was because of an invalid URL: /hash/597cfbe5740d2bf91eb4b037e6750bacd76d3729/added
-
-#0 0x00002b33e61ba166 in Curl_disconnect (conn=0xe46210) at url.c:2077
-2077 if(conn->handler->disconnect)
-(gdb) print conn->handler
-$1 = (const struct Curl_handler *) 0x0
-(gdb) bt full
-#0 0x00002b33e61ba166 in Curl_disconnect (conn=0xe46210) at url.c:2077
- data = (struct SessionHandle *) 0xe363d0
-#1 0x00002b33e61bc27e in Curl_connect (data=0xe363d0, in_connect=0x7fffc6067818, asyncp=0x7fffc6067827, protocol_done=0x7fffc6067826) at url.c:4255
- connected = false
- code = CURLE_OK
- dns = (struct Curl_dns_entry *) 0x0
-#2 0x00002b33e61c67db in Curl_perform (data=0xe363d0) at transfer.c:2333
- res = CURLE_OK
- res2 = <value optimized out>
- conn = (struct connectdata *) 0xe46210
- newurl = 0x0
- retry = 232
-#3 0x0000000000472005 in zif_curl_exec ()
-#4 0x000000000061bd42 in ?? ()
-#5 0x000000000061ae23 in execute ()
-#6 0x000000000061b815 in ?? ()
-#7 0x000000000061ae23 in execute ()
-#8 0x00000000005fcef3 in zend_execute_scripts ()
-#9 0x00000000005bd468 in php_execute_script ()
-#10 0x00000000006791ab in main ()
-
-diff -Nuar curl-7.17.1-20071013.orig/lib/url.c curl-7.17.1-20071013/lib/url.c
---- curl-7.17.1-20071013.orig/lib/url.c 2007-10-13 02:00:02.000000000 +0000
-+++ curl-7.17.1-20071013/lib/url.c 2007-11-12 13:13:37.401514781 +0000
-@@ -2594,7 +2594,7 @@
- curl_socket_t *socks,
- int numsocks)
- {
-- if(conn->handler->proto_getsock)
-+ if(conn && conn->handler && conn->handler->proto_getsock)
- return conn->handler->proto_getsock(conn, socks, numsocks);
- return GETSOCK_BLANK;
- }
-@@ -4325,7 +4325,7 @@
- }
-
- /* this calls the protocol-specific function pointer previously set */
-- if(conn->handler->done)
-+ if(conn->handler && conn->handler->done)
- result = conn->handler->done(conn, status, premature);
- else
- result = CURLE_OK;
-@@ -4378,7 +4378,7 @@
- conn->bits.done = FALSE; /* Curl_done() is not called yet */
- conn->bits.do_more = FALSE; /* by default there's no curl_do_more() to use */
-
-- if(conn->handler->do_it) {
-+ if(conn->handler && conn->handler->do_it) {
- /* generic protocol-specific function pointer set in curl_connect() */
- result = conn->handler->do_it(conn, done);
-
-@@ -4441,7 +4441,7 @@
- {
- CURLcode result=CURLE_OK;
-
-- if(conn->handler->do_more)
-+ if(conn->handler && conn->handler->do_more)
- result = conn->handler->do_more(conn);
-
- return result;
diff --git a/net-misc/curl/files/curl-7.18.2-nss-threadsafe.patch b/net-misc/curl/files/curl-7.18.2-nss-threadsafe.patch
deleted file mode 100644
index a45120283c13..000000000000
--- a/net-misc/curl/files/curl-7.18.2-nss-threadsafe.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-===================================================================
-RCS file: /cvsroot/curl/curl/lib/nss.c,v
-retrieving revision 1.33
-retrieving revision 1.34
-diff -u -r1.33 -r1.34
---- curl/lib/nss.c 2008/09/06 05:29:06 1.33
-+++ curl/lib/nss.c 2008/09/23 10:27:04 1.34
-@@ -78,7 +78,9 @@
-
- PRFileDesc *PR_ImportTCPSocket(PRInt32 osfd);
-
--int initialized = 0;
-+PRLock * nss_initlock = NULL;
-+
-+volatile int initialized = 0;
-
- #define HANDSHAKE_TIMEOUT 30
-
-@@ -837,8 +839,11 @@
- */
- int Curl_nss_init(void)
- {
-- if(!initialized)
-+ /* curl_global_init() is not thread-safe so this test is ok */
-+ if (nss_initlock == NULL) {
- PR_Init(PR_USER_THREAD, PR_PRIORITY_NORMAL, 256);
-+ nss_initlock = PR_NewLock();
-+ }
-
- /* We will actually initialize NSS later */
-
-@@ -848,7 +853,17 @@
- /* Global cleanup */
- void Curl_nss_cleanup(void)
- {
-- NSS_Shutdown();
-+ /* This function isn't required to be threadsafe and this is only done
-+ * as a safety feature.
-+ */
-+ PR_Lock(nss_initlock);
-+ if (initialized)
-+ NSS_Shutdown();
-+ PR_Unlock(nss_initlock);
-+
-+ PR_DestroyLock(nss_initlock);
-+ nss_initlock = NULL;
-+
- initialized = 0;
- }
-
-@@ -926,7 +941,8 @@
- return CURLE_OK;
-
- /* FIXME. NSS doesn't support multiple databases open at the same time. */
-- if(!initialized) {
-+ PR_Lock(nss_initlock);
-+ if(!initialized && !NSS_IsInitialized()) {
- initialized = 1;
-
- certDir = getenv("SSL_DIR"); /* Look in $SSL_DIR */
-@@ -950,6 +966,8 @@
- if(rv != SECSuccess) {
- infof(conn->data, "Unable to initialize NSS database\n");
- curlerr = CURLE_SSL_CACERT_BADFILE;
-+ initialized = 0;
-+ PR_Unlock(nss_initlock);
- goto error;
- }
-
-@@ -972,6 +990,7 @@
- }
- #endif
- }
-+ PR_Unlock(nss_initlock);
-
- model = PR_NewTCPSocket();
- if(!model)
diff --git a/net-misc/curl/files/libcurl-gnutlscert.patch b/net-misc/curl/files/libcurl-gnutlscert.patch
deleted file mode 100644
index f905701c0842..000000000000
--- a/net-misc/curl/files/libcurl-gnutlscert.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-Index: lib/gtls.c
-===================================================================
-RCS file: /cvsroot/curl/curl/lib/gtls.c,v
-retrieving revision 1.27
-diff -u -r1.27 gtls.c
---- lib/gtls.c 28 Apr 2007 21:01:30 -0000 1.27
-+++ lib/gtls.c 10 Jul 2007 20:27:43 -0000
-@@ -420,6 +420,43 @@
- else
- infof(data, "\t common name: %s (matched)\n", certbuf);
-
-+ /* Check for time-based validity */
-+ clock = gnutls_x509_crt_get_expiration_time(x509_cert);
-+
-+ if(clock == (time_t)-1) {
-+ failf(data, "server cert expiration date verify failed");
-+ return CURLE_SSL_CONNECT_ERROR;
-+ }
-+
-+ if(clock < time(NULL)) {
-+ if (data->set.ssl.verifypeer) {
-+ failf(data, "server certificate expiration date has passed.");
-+ return CURLE_SSL_PEER_CERTIFICATE;
-+ }
-+ else
-+ infof(data, "\t server certificate expiration date FAILED\n");
-+ }
-+ else
-+ infof(data, "\t server certificate expiration date OK\n");
-+
-+ clock = gnutls_x509_crt_get_activation_time(x509_cert);
-+
-+ if(clock == (time_t)-1) {
-+ failf(data, "server cert activation date verify failed");
-+ return CURLE_SSL_CONNECT_ERROR;
-+ }
-+
-+ if(clock > time(NULL)) {
-+ if (data->set.ssl.verifypeer) {
-+ failf(data, "server certificate not activated yet.");
-+ return CURLE_SSL_PEER_CERTIFICATE;
-+ }
-+ else
-+ infof(data, "\t server certificate activation date FAILED\n");
-+ }
-+ else
-+ infof(data, "\t server certificate activation date OK\n");
-+
- /* Show:
-
- - ciphers used