summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-09-03 07:40:14 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-09-03 07:40:14 +0000
commitc3677190661d0ad582026403025ea94363243a46 (patch)
treeec04f84fb7e936865ead091c25279b8197d260f7 /net-misc/dhcp
parentadded ppc to keywords (diff)
downloadgentoo-2-c3677190661d0ad582026403025ea94363243a46.tar.gz
gentoo-2-c3677190661d0ad582026403025ea94363243a46.tar.bz2
gentoo-2-c3677190661d0ad582026403025ea94363243a46.zip
fixor some stuffzor see changelog
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/ChangeLog10
-rw-r--r--net-misc/dhcp/dhcp-3.0-r3.ebuild87
-rw-r--r--net-misc/dhcp/files/conf.dhcpd5
-rw-r--r--net-misc/dhcp/files/dhcp.rc74
-rw-r--r--net-misc/dhcp/files/digest-dhcp-3.0-r31
5 files changed, 103 insertions, 4 deletions
diff --git a/net-misc/dhcp/ChangeLog b/net-misc/dhcp/ChangeLog
index d1ae19362775..28d8abbcfe44 100644
--- a/net-misc/dhcp/ChangeLog
+++ b/net-misc/dhcp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/dhcp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.6 2002/07/21 21:07:39 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/ChangeLog,v 1.7 2002/09/03 07:40:14 lostlogic Exp $
+
+*dhcp-3.0-r3 (16 Jun 2002)
+
+ 03 Sep 2002; Brandon Low <lostlogic@gentoo.org> dhcp-3.0-r3.ebuild, files/conf.dhcp,
+ files/dhcp.rc7, digest-dhcp-3.0-r3:
+
+ Update ebuild to touch dhcp.leases, fix config and init.d files
+ to work more sanetly.
*dhcp-3.0-r2 (16 Jun 2002)
diff --git a/net-misc/dhcp/dhcp-3.0-r3.ebuild b/net-misc/dhcp/dhcp-3.0-r3.ebuild
new file mode 100644
index 000000000000..6f424d0c9bae
--- /dev/null
+++ b/net-misc/dhcp/dhcp-3.0-r3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/dhcp-3.0-r3.ebuild,v 1.1 2002/09/03 07:40:14 lostlogic Exp $
+
+#This is only needed for a release with pl1 at the end.
+P="dhcp-3.0pl1"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ISC Dynamic Host Configuration Protocol"
+SRC_URI="ftp://ftp.isc.org/isc/dhcp/${P}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/DHCP"
+LICENSE="isc-dhcp"
+KEYWORDS="x86 ppc sparc sparc64"
+
+SLOT="0"
+DEPEND="virtual/glibc sys-apps/groff"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/includes
+ cat <<- END >> site.h
+#define _PATH_DHCPD_CONF "/etc/dhcp/dhcpd.conf"
+#define _PATH_DHCLIENT_DB "/var/lib/dhcp/dhclient.leases"
+#define _PATH_DHCPD_DB "/var/lib/dhcp/dhcpd.leases"
+ END
+}
+
+src_compile() {
+ cat <<- END > site.conf
+CC = gcc ${CFLAGS}
+ETC = /etc/dhcp
+VARDB = /var/lib/dhcp
+ADMMANDIR = /usr/share/man/man8
+FFMANDIR = /usr/share/man/man5
+LIBMANDIR = /usr/share/man/man3
+END
+ ./configure --with-nsupdate || die
+ emake || die
+}
+
+src_install() {
+ dodir /var/lib/dhcp
+ touch ${D}/var/lib/dhcp/dhclient.leases
+ touch ${D}/var/lib/dhcp/dhcpd.leases
+
+ cd ${S}/work.linux-2.2/client
+ into / ; dosbin dhclient
+ into /usr ; doman *.5 *.8
+
+ cd ../dhcpctl ; dolib libdhcpctl.a ; doman *.3
+ insinto /usr/include ; doins dhcpctl.h
+
+ cd ../omapip ; dolib libomapi.a ; doman *.3
+ cd ../relay ; dosbin dhcrelay ; doman *.8
+ cd ../common ; doman *.5
+ cd ../server ; dosbin dhcpd ; doman *.5 *.8
+
+ cd ${S}/client
+ # admins might wanna edit dhclient-script, so /etc is proper for it.
+ dosed "s:/etc/dhclient-script:/etc/dhcp/dhclient-script:" dhclient.conf
+ insinto /etc/dhcp ; newins dhclient.conf dhclient.conf.sample
+ exeinto /etc/dhcp ; newexe scripts/linux dhclient-script.sample
+
+ cd ${S}/server
+ insinto /etc/dhcp ; newins dhcpd.conf dhcpd.conf.sample
+
+ cd ${S}/includes/omapip
+ insinto /usr/include/omapip ; doins alloc.h buffer.h omapip.h
+
+ cd ${S}/includes/isc-dhcp
+ insinto /usr/include/isc-dhcp
+ doins boolean.h dst.h int.h lang.h list.h result.h types.h
+
+ cd ${S}
+ dodoc ANONCVS CHANGES COPYRIGHT README RELNOTES
+ newdoc client/dhclient.conf dhclient.conf.sample
+ newdoc client/scripts/linux dhclient-script.sample
+ newdoc server/dhcpd.conf dhcpd.conf.sample
+ docinto doc ; dodoc doc/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/conf.dhcpd dhcp
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dhcp.rc7 dhcp
+}
diff --git a/net-misc/dhcp/files/conf.dhcpd b/net-misc/dhcp/files/conf.dhcpd
index 4fb2ce4e9336..4bba86c1e2c3 100644
--- a/net-misc/dhcp/files/conf.dhcpd
+++ b/net-misc/dhcp/files/conf.dhcpd
@@ -1,7 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/files/conf.dhcpd,v 1.3 2002/06/23 04:23:48 nitro Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/files/conf.dhcpd,v 1.4 2002/09/03 07:40:14 lostlogic Exp $
#configure which interface or interfaces to for dhcp to listen on
#list all interfaces space separated.
IFACE="eth0"
+
+# Insert any other options needed
+DHCPD_OPTS=""
diff --git a/net-misc/dhcp/files/dhcp.rc7 b/net-misc/dhcp/files/dhcp.rc7
index 3b48dad11ced..958645ba4fab 100644
--- a/net-misc/dhcp/files/dhcp.rc7
+++ b/net-misc/dhcp/files/dhcp.rc7
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/files/dhcp.rc7,v 1.1 2002/06/17 04:07:11 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcp/files/dhcp.rc7,v 1.2 2002/09/03 07:40:14 lostlogic Exp $
#configuration is done in /etc/conf.d/dhcp
@@ -20,7 +20,7 @@ checkconfig() {
start() {
checkconfig || return 1
ebegin "Starting dhcpd"
- start-stop-daemon --start --quiet --exec /usr/sbin/dhcpd -- ${IFACE}
+ start-stop-daemon --start --quiet --exec /usr/sbin/dhcpd -- ${DHCPD_OPTS} ${IFACE}
eend $?
}
diff --git a/net-misc/dhcp/files/digest-dhcp-3.0-r3 b/net-misc/dhcp/files/digest-dhcp-3.0-r3
new file mode 100644
index 000000000000..6b2999d46c71
--- /dev/null
+++ b/net-misc/dhcp/files/digest-dhcp-3.0-r3
@@ -0,0 +1 @@
+MD5 85164daf66b2a46b59923750c5716fd1 dhcp-3.0pl1.tar.gz 865096