summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-09-13 20:10:16 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-09-13 20:10:16 +0000
commit12da1dba70302367f1f95304eead8dc88d978de0 (patch)
tree38b3b3cbbddb47f26262d9f163840ee376c0992d /net-misc/dhcpcd/dhcpcd-9999.ebuild
parentFix compilation on Solaris (diff)
downloadgentoo-2-12da1dba70302367f1f95304eead8dc88d978de0.tar.gz
gentoo-2-12da1dba70302367f1f95304eead8dc88d978de0.tar.bz2
gentoo-2-12da1dba70302367f1f95304eead8dc88d978de0.zip
--with-udev and --with-dev are not valid switches to configure, so only use --without-dev and --without-udev if the udev use flag is disabled.
(Portage version: 2.2.1/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'net-misc/dhcpcd/dhcpcd-9999.ebuild')
-rw-r--r--net-misc/dhcpcd/dhcpcd-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-misc/dhcpcd/dhcpcd-9999.ebuild b/net-misc/dhcpcd/dhcpcd-9999.ebuild
index 1f2999094d93..07d453251683 100644
--- a/net-misc/dhcpcd/dhcpcd-9999.ebuild
+++ b/net-misc/dhcpcd/dhcpcd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-9999.ebuild,v 1.6 2013/09/09 22:13:01 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-9999.ebuild,v 1.7 2013/09/13 20:10:16 williamh Exp $
EAPI=5
@@ -35,7 +35,9 @@ src_prepare()
src_configure()
{
- local hooks="--with-hook=ntp.conf"
+ local dev hooks
+ use udev || dev="--without-dev --without-udev"
+ hooks="--with-hook=ntp.conf"
use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
econf \
--prefix="${EPREFIX}" \
@@ -43,7 +45,7 @@ src_configure()
--dbdir="${EPREFIX}/var/lib/dhcpcd" \
--localstatedir="${EPREFIX}/var" \
$(use_enable ipv6) \
- $(use_with udev) \
+ ${dev} \
${hooks}
}