summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2008-02-25 08:44:01 +0000
committerPeter Weller <welp@gentoo.org>2008-02-25 08:44:01 +0000
commitcab92c473bd32250726af65c60a9e728730a1299 (patch)
tree2746516adac48ba44d146e877599557c15b47b6f /net-misc/dhcpcd
parentUpdated upstream patchset, fixes security bug #211240, thank Lars Hartmann fo... (diff)
downloadgentoo-2-cab92c473bd32250726af65c60a9e728730a1299.tar.gz
gentoo-2-cab92c473bd32250726af65c60a9e728730a1299.tar.bz2
gentoo-2-cab92c473bd32250726af65c60a9e728730a1299.zip
Bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/dhcpcd')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-3.2.3.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index 636bdc8304ae..a91edb5cd8e4 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.178 2008/02/20 20:48:51 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.179 2008/02/25 08:44:01 welp Exp $
+
+*dhcpcd-3.2.3 (25 Feb 2008)
+
+ 25 Feb 2008; <welp@gentoo.org> +dhcpcd-3.2.3.ebuild:
+ Bump
*dhcpcd-3.2.2 (20 Feb 2008)
diff --git a/net-misc/dhcpcd/dhcpcd-3.2.3.ebuild b/net-misc/dhcpcd/dhcpcd-3.2.3.ebuild
new file mode 100644
index 000000000000..2daecb7e5108
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-3.2.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-3.2.3.ebuild,v 1.1 2008/02/25 08:44:01 welp Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://roy.marples.name/dhcpcd"
+SRC_URI="http://roy.marples.name/${PN}/${P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="vram zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use zeroconf; then
+ elog "ZeroConf support enabled"
+ else
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "/* User indicated no zeroconf support */"
+ echo "#undef ENABLE_IPV4LL"
+ } >> config.h
+ fi
+
+ # Disable DUID support if we have volatile storage.
+ # LiveCD's *should* enable this USE flag
+ if use vram; then
+ elog "Disabling DUID support"
+ {
+ echo
+ echo "/* User indicated volatile ram storage */"
+ echo "#undef ENABLE_DUID"
+ } >> config.h
+ else
+ elog "DUID support enabled"
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" INFODIR=/var/lib/dhcpcd || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ if [ -e "${duid}" ] && ! grep -q '..:..:..:..:..:..' "${duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+
+ if ! use vram; then
+ use zeroconf && echo
+ elog "You have installed dhcpcd with DUID support."
+ elog "This means that we will generate a DUID in /var/lib/dhcpcd/dhcpcd.duid"
+ elog "This is generated from a MAC address of the card and a timestamp."
+ elog "It will be used in every subsequent DHCP transaction, along with a IAID"
+ elog "in the ClientID option. This is required by RFC 4361."
+ echo
+ elog "Some DHCP server implementations require a MAC address only in the"
+ elog "ClientID field. These DHCP servers should be updated to be RFC"
+ elog "conformant. If you cannot do this, you can revert to the old"
+ elog "behaviour by using the -I '' option OR building dhcpcd with the"
+ elog "vram USE flag enabled."
+ fi
+}