summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-21 17:34:40 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-21 17:34:40 +0000
commit518c59b81cf2b618eb665fc2265b70e22936d3fd (patch)
tree03ccb64a50f23cfd48aa566165b22b04322325cc /net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild
parentgcc2 fix (diff)
downloadgentoo-2-518c59b81cf2b618eb665fc2265b70e22936d3fd.tar.gz
gentoo-2-518c59b81cf2b618eb665fc2265b70e22936d3fd.tar.bz2
gentoo-2-518c59b81cf2b618eb665fc2265b70e22936d3fd.zip
add static support #29264
Diffstat (limited to 'net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild')
-rw-r--r--net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild b/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild
index d9b6830869f4..a1afc4f47c4c 100644
--- a/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild
+++ b/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild,v 1.2 2003/09/05 22:01:48 msterret Exp $
-
-DESCRIPTION="Server and client for DHCPv6"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpv6/dhcpv6-0.85-r1.ebuild,v 1.3 2003/09/21 17:34:40 vapier Exp $
MY_P=${P/dhcpv6/dhcp6}
+DESCRIPTION="Server and client for DHCPv6"
HOMEPAGE="http://www.sourceforge.net/projects/dhcp6/"
SRC_URI="mirror://sourceforge/dhcpv6/${MY_P}.tgz"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~x86"
-IUSE=""
+IUSE="static"
+
DEPEND=""
+
S=${WORKDIR}/${MY_P}
src_unpack() {
@@ -21,6 +22,12 @@ src_unpack() {
epatch ${FILESDIR}/patch-iaid-dhcp6-${PV}
}
+src_compile() {
+ econf || die
+ use static && export LDFLAGS="${LDFLAGS} -static"
+ emake || die
+}
+
src_install() {
einstall || die
dodoc Install ReadMe docs/draft-ietf-dhc-dhcpv6-28.txt \
@@ -33,6 +40,7 @@ src_install() {
exeinto /etc/init.d
newexe ${FILESDIR}/dhcp6s.rc dhcp6s
}
+
pkg_postinst() {
einfo "Sample dhcp6c.conf and dhcp6s.conf files are in"
einfo "/usr/share/doc/${P}/"