summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-04-13 21:02:49 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-04-13 21:02:49 +0000
commit9b6efa49647eed9b22baeff8e4fcae59928e7b92 (patch)
tree0581faca306a90df99b3ddfaaa19c4ddf30b9a9c /net-misc/e1000/e1000-5.2.39.ebuild
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-9b6efa49647eed9b22baeff8e4fcae59928e7b92.tar.gz
gentoo-2-9b6efa49647eed9b22baeff8e4fcae59928e7b92.tar.bz2
gentoo-2-9b6efa49647eed9b22baeff8e4fcae59928e7b92.zip
Version bumped.
Diffstat (limited to 'net-misc/e1000/e1000-5.2.39.ebuild')
-rw-r--r--net-misc/e1000/e1000-5.2.39.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/e1000/e1000-5.2.39.ebuild b/net-misc/e1000/e1000-5.2.39.ebuild
new file mode 100644
index 000000000000..baf5d5256756
--- /dev/null
+++ b/net-misc/e1000/e1000-5.2.39.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/e1000-5.2.39.ebuild,v 1.1 2004/04/13 21:02:49 mholzer Exp $
+
+DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
+HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
+LICENSE="GPL-2"
+DEPEND="virtual/linux-sources"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+SLOT="${KV}"
+KEYWORDS="~x86"
+S="${WORKDIR}/${P}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ # rem out the DEPVER line, since it would cause a sandbox violation and
+ # since it is only needed by RPM ;-)
+ sed -i "/^DEPVER :=/ d" Makefile
+}
+
+
+src_compile() {
+ check_KV
+ cd "${S}/src"
+
+ # workaround needed for some ethernet controllers to work with low end switches
+ if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
+ then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
+ else CFLAGS_EXTRA=""
+ fi
+
+ make ${CFLAGS_EXTRA} KSRC=/usr/src/linux clean e1000.o
+}
+
+
+src_install() {
+ insinto "/lib/modules/${KV}/kernel/drivers/net"
+ doins "${S}/src/e1000.o"
+ doman e1000.7
+ dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
+ einfo ""
+ einfo "In case you have problems, loading the module, try to run depmod -A"
+ einfo ""
+ einfo "If you experience problems with low-end switches, read"
+ einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
+ einfo ""
+}