summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-12-07 17:06:09 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-12-07 17:06:09 +0000
commit732782e17d239d00712a0a9a980ba9d3ad2d7890 (patch)
tree98a568f10d87fb63be10c3deec87a0c7837ebe9b /net-misc/freenet6/freenet6-1.0.0.ebuild
parentNew version (diff)
downloadgentoo-2-732782e17d239d00712a0a9a980ba9d3ad2d7890.tar.gz
gentoo-2-732782e17d239d00712a0a9a980ba9d3ad2d7890.tar.bz2
gentoo-2-732782e17d239d00712a0a9a980ba9d3ad2d7890.zip
New version
Diffstat (limited to 'net-misc/freenet6/freenet6-1.0.0.ebuild')
-rw-r--r--net-misc/freenet6/freenet6-1.0.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/freenet6/freenet6-1.0.0.ebuild b/net-misc/freenet6/freenet6-1.0.0.ebuild
new file mode 100644
index 000000000000..dac3f8336856
--- /dev/null
+++ b/net-misc/freenet6/freenet6-1.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/freenet6-1.0.0.ebuild,v 1.1 2003/12/07 17:05:50 gmsoft Exp $
+
+DESCRIPTION="Client to configure an IPv6 tunnel to freenet6"
+HOMEPAGE="http://www.freenet6.net/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="VPL-1.0"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa"
+DEPEND=""
+S=${WORKDIR}/freenet6-client-1.0
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ mv -f src/Makefile ${T}
+ sed "s:gcc -g -I\$(INC) -Wall:${CC} -I\$(INC) ${CFLAGS}:" \
+ ${T}/Makefile > src/Makefile
+}
+
+src_compile() {
+ emake all target=linux || die "Build Failed"
+}
+
+src_install() {
+ dosbin bin/tspc
+
+ insopts -m 600
+ insinto /etc/freenet6
+ doins ${FILESDIR}/tspc.conf
+ exeinto /etc/freenet6/template
+ doexe template/{linux,checktunnel}.sh
+ doexe ${FILESDIR}/gentoo.sh
+
+ dodoc CONTRIB.txt LEGAL README
+ doman man/{man5/tspc.conf.5,man8/tspc.8}
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/tspc.rc tspc
+}
+
+pkg_postinst() {
+ einfo "The freenet6 ebuild installs an init script named 'tspc'"
+ einfo "to coincide with the name of the client binary installed"
+ einfo "To add support for a freenet6 connection at startup, do"
+ einfo ""
+ einfo "# rc-update add tspc default"
+}