summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-07-30 00:33:14 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-07-30 00:33:14 +0000
commitf59a5da0e14072f2717c422b5187e1037d995cf7 (patch)
treeaa02110d8a5e9094cf0b9d629d087195347ec620 /net-misc/gnugk
parentSo long, <=media-video/ati-gatos-4.4.0. Don't let the door hit you on the bum... (diff)
downloadgentoo-2-f59a5da0e14072f2717c422b5187e1037d995cf7.tar.gz
gentoo-2-f59a5da0e14072f2717c422b5187e1037d995cf7.tar.bz2
gentoo-2-f59a5da0e14072f2717c422b5187e1037d995cf7.zip
Version bump, readded ~x86 flag, cleanups, fixes #92976 and #48565
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/gnugk')
-rw-r--r--net-misc/gnugk/ChangeLog10
-rw-r--r--net-misc/gnugk/files/digest-gnugk-2.2.21
-rw-r--r--net-misc/gnugk/gnugk-2.2.1.ebuild38
-rw-r--r--net-misc/gnugk/gnugk-2.2.2.ebuild48
4 files changed, 69 insertions, 28 deletions
diff --git a/net-misc/gnugk/ChangeLog b/net-misc/gnugk/ChangeLog
index c7a6cc2251bb..def01c13e161 100644
--- a/net-misc/gnugk/ChangeLog
+++ b/net-misc/gnugk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/gnugk
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gnugk/ChangeLog,v 1.6 2005/07/29 23:45:26 stkn Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnugk/ChangeLog,v 1.7 2005/07/30 00:33:14 stkn Exp $
+
+*gnugk-2.2.2 (30 Jul 2005)
+
+ 30 Jul 2005; <stkn@gentoo.org> gnugk-2.2.1.ebuild, +gnugk-2.2.2.ebuild:
+ Version bump, cleanups, gnugk-2.2.x doesn't support ldap at the moment, ldap
+ flag removed. Fixes bug #48565 and #92976. Readded ~x86 flag.
*gnukg-2.2.1 (24 Mar 2005)
diff --git a/net-misc/gnugk/files/digest-gnugk-2.2.2 b/net-misc/gnugk/files/digest-gnugk-2.2.2
new file mode 100644
index 000000000000..d1a3f29c9a69
--- /dev/null
+++ b/net-misc/gnugk/files/digest-gnugk-2.2.2
@@ -0,0 +1 @@
+MD5 689d1239273d21daba5746fd128d3184 gnugk-2.2.2.tar.gz 562982
diff --git a/net-misc/gnugk/gnugk-2.2.1.ebuild b/net-misc/gnugk/gnugk-2.2.1.ebuild
index f6625e3f0227..451f20b98604 100644
--- a/net-misc/gnugk/gnugk-2.2.1.ebuild
+++ b/net-misc/gnugk/gnugk-2.2.1.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gnugk/gnugk-2.2.1.ebuild,v 1.1 2005/03/24 22:14:03 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnugk/gnugk-2.2.1.ebuild,v 1.2 2005/07/30 00:33:14 stkn Exp $
-inherit eutils
-
-IUSE="mysql postgres ldap radius"
+IUSE="mysql postgres radius"
DESCRIPTION="GNU H.323 gatekeeper"
HOMEPAGE="http://www.gnugk.org/"
@@ -12,48 +10,36 @@ SRC_URI="mirror://sourceforge/openh323gk/gnugk-${PV}.tgz"
S=${WORKDIR}/openh323gk
-MY_OS="`uname -s | tr [:upper:] [:lower:]`"
-
SLOT="0"
-KEYWORDS="~ppc"
+KEYWORDS="~x86 ~ppc"
LICENSE="GPL-2"
DEPEND="net-libs/openh323
mysql? ( dev-db/mysql++ )
- postgres? ( dev-db/postgresql )
- ldap? ( net-nds/openldap )"
+ postgres? ( dev-db/postgresql )"
src_compile() {
econf \
`use_enable mysql` \
- `use_enable ldap` \
- `use_enable postgres sql` \
- `use_enable radius` || die
- emake optdepend opt || die
+ `use_enable postgres sql` \
+ `use_enable radius` || die
+
+ emake optdepend opt addpasswd || die
}
src_install() {
- dodir /usr/sbin /etc/gnugk
- dosbin obj_${MY_OS}_${ARCH}_r/gnugk
+ dosbin obj_*_*_r/gnugk
+ dosbin obj_*_*_r/addpasswd
insinto /etc/gnugk
doins etc/*
- if use ldap && [ -d /etc/openldap/schema ]; then
- insinto /etc/openldap/schema
- doins etc/voip.schema
- rm -f ${D}/etc/gnugk/voip.schema
- fi
-
dodoc changes.txt readme.txt copying docs/*
mv ${D}/etc/gnugk/*.pl ${D}/usr/share/doc/${PF}
docinto old
dodoc docs/old/*
- exeinto /etc/init.d/
- newexe ${FILESDIR}/gnugk.rc6 gnugk
-
- insinto /etc/conf.d/
- newins ${FILESDIR}/gnugk.confd gnugk
+ newinitd ${FILESDIR}/gnugk.rc6 gnugk
+ newconfd ${FILESDIR}/gnugk.confd gnugk
}
diff --git a/net-misc/gnugk/gnugk-2.2.2.ebuild b/net-misc/gnugk/gnugk-2.2.2.ebuild
new file mode 100644
index 000000000000..6be90200e6da
--- /dev/null
+++ b/net-misc/gnugk/gnugk-2.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gnugk/gnugk-2.2.2.ebuild,v 1.1 2005/07/30 00:33:14 stkn Exp $
+
+IUSE="mysql postgres radius"
+
+DESCRIPTION="GNU H.323 gatekeeper"
+HOMEPAGE="http://www.gnugk.org/"
+SRC_URI="mirror://sourceforge/openh323gk/gnugk-${PV}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+
+DEPEND="
+ >=dev-libs/pwlib-1.8.4
+ >=net-libs/openh323-1.15.3
+ mysql? ( dev-db/mysql++ )
+ postgres? ( dev-db/postgresql )"
+
+src_compile() {
+ econf \
+ `use_enable mysql` \
+ `use_enable postgres sql` \
+ `use_enable radius` || die
+
+ emake optdepend opt addpasswd || die
+}
+
+src_install() {
+ dosbin obj_*_*_r/gnugk
+ dosbin obj_*_*_r/addpasswd
+
+ insinto /etc/gnugk
+ doins etc/*
+
+ dodoc changes.txt readme.txt copying docs/*.txt
+ mv ${D}/etc/gnugk/*.pl ${D}/usr/share/doc/${PF}
+
+ docinto old
+ dodoc docs/old/*
+
+ dodir /usr/share/doc/${PF}/contrib
+ cp -r contrib/sqlbill ${D}/usr/share/doc/${PF}/contrib
+
+ newinitd ${FILESDIR}/gnugk.rc6 gnugk
+ newconfd ${FILESDIR}/gnugk.confd gnugk
+}