summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2005-04-23 11:49:11 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2005-04-23 11:49:11 +0000
commitc61815c2eab79a7b2100c6a965d70339778454fb (patch)
tree8dbf7545cf8ff2f7354986eaa2b1ad0c0df1889c /net-misc/gwget/gwget-0.94.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-c61815c2eab79a7b2100c6a965d70339778454fb.tar.gz
gentoo-2-c61815c2eab79a7b2100c6a965d70339778454fb.tar.bz2
gentoo-2-c61815c2eab79a7b2100c6a965d70339778454fb.zip
Update for gwget. Patch fix for epiphany path. Fixes bugs #67719, #89882.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/gwget/gwget-0.94.ebuild')
-rw-r--r--net-misc/gwget/gwget-0.94.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/gwget/gwget-0.94.ebuild b/net-misc/gwget/gwget-0.94.ebuild
new file mode 100644
index 000000000000..650613d76a72
--- /dev/null
+++ b/net-misc/gwget/gwget-0.94.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-0.94.ebuild,v 1.1 2005/04/23 11:49:11 allanonjl Exp $
+
+inherit eutils gnome2 libtool
+
+DESCRIPTION="GTK2 WGet Frontend"
+HOMEPAGE="http://gnome.org/projects/gwget/"
+SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/${PN}/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+IUSE="doc epiphany"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+RDEPEND="net-misc/wget
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/gconf-1.1.11
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ epiphany? ( >=www-client/epiphany-1.4 )
+ >=dev-libs/glib-2.4.0
+ "
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.11
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.10.4
+ "
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO"
+
+G2CONF="${G2CONF} $(use_enable epiphany epiphany-extension)"
+USE_DESTDIR="1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ elibtoolize
+ # Fix the Epiphany extension installation directory:
+ epatch ${FILESDIR}/gwget-0.94-epiphany-path-fix.patch
+}
+
+src_install() {
+ gnome2_src_install
+ # remove /var/lib, which is created without any reason
+ rm -rf ${D}/var
+}