summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-07-30 01:49:46 +0000
committerJeroen Roovers <jer@gentoo.org>2008-07-30 01:49:46 +0000
commit0617e159f019c58afdb4d427a3a8df9048c19c85 (patch)
treeaa32efa6e2c616611f87e8e85a21db2a36807c55 /net-misc/iperf
parentTaking on maintainership of wput (diff)
downloadgentoo-2-0617e159f019c58afdb4d427a3a8df9048c19c85.tar.gz
gentoo-2-0617e159f019c58afdb4d427a3a8df9048c19c85.tar.bz2
gentoo-2-0617e159f019c58afdb4d427a3a8df9048c19c85.zip
Version bump thanks to Jeff Waller (bug #233215).
(Portage version: 2.2_rc3/cvs/Linux 2.6.24-gentoo-r2-JeR i686)
Diffstat (limited to 'net-misc/iperf')
-rw-r--r--net-misc/iperf/ChangeLog9
-rw-r--r--net-misc/iperf/iperf-2.0.4.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/net-misc/iperf/ChangeLog b/net-misc/iperf/ChangeLog
index 49e8c5378290..21247e9849b7 100644
--- a/net-misc/iperf/ChangeLog
+++ b/net-misc/iperf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/iperf
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.23 2007/06/12 17:54:39 lavajoe Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.24 2008/07/30 01:49:46 jer Exp $
+
+*iperf-2.0.4 (30 Jul 2008)
+
+ 30 Jul 2008; Jeroen Roovers <jer@gentoo.org> +iperf-2.0.4.ebuild:
+ Version bump thanks to Jeff Waller (bug #233215).
12 Jun 2007; Joe Peterson <lavajoe@gentoo.org> iperf-2.0.2.ebuild:
Add ~x86-fbsd keyword
diff --git a/net-misc/iperf/iperf-2.0.4.ebuild b/net-misc/iperf/iperf-2.0.4.ebuild
new file mode 100644
index 000000000000..9e50ba0b9b55
--- /dev/null
+++ b/net-misc/iperf/iperf-2.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/iperf-2.0.4.ebuild,v 1.1 2008/07/30 01:49:46 jer Exp $
+
+DESCRIPTION="tool to measure IP bandwidth using UDP or TCP"
+HOMEPAGE="http://iperf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="ipv6 threads debug"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable threads) \
+ $(use_enable debug debuginfo) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc INSTALL README
+ dohtml doc/*
+ newinitd ${FILESDIR}/${PN}.initd ${PN}
+ newconfd ${FILESDIR}/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ echo
+ einfo "To run iperf in server mode, run:"
+ einfo " /etc/init.d/iperf start"
+ echo
+}