summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-28 17:05:49 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-28 17:05:49 +0000
commit9e96e0b45840b9719dd5473bfbb43cad4f3ddd69 (patch)
tree5e3434be89c38652c85a2dd4f0b27d3fecfa8e06 /net-misc/jigdo
parentVersion bump. (diff)
downloadgentoo-2-9e96e0b45840b9719dd5473bfbb43cad4f3ddd69.tar.gz
gentoo-2-9e96e0b45840b9719dd5473bfbb43cad4f3ddd69.tar.bz2
gentoo-2-9e96e0b45840b9719dd5473bfbb43cad4f3ddd69.zip
Fixed gtk+ dep and some cleanup
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/jigdo')
-rw-r--r--net-misc/jigdo/ChangeLog8
-rw-r--r--net-misc/jigdo/jigdo-0.7.3-r1.ebuild15
-rw-r--r--net-misc/jigdo/jigdo-0.7.3.ebuild16
3 files changed, 20 insertions, 19 deletions
diff --git a/net-misc/jigdo/ChangeLog b/net-misc/jigdo/ChangeLog
index 2024e6c86585..0da668ba3dfc 100644
--- a/net-misc/jigdo/ChangeLog
+++ b/net-misc/jigdo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/jigdo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/ChangeLog,v 1.22 2009/09/04 15:49:34 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/ChangeLog,v 1.23 2011/03/28 17:05:49 angelos Exp $
+
+ 28 Mar 2011; Christoph Mende <angelos@gentoo.org> jigdo-0.7.3.ebuild,
+ jigdo-0.7.3-r1.ebuild:
+ Fixed gtk+ dep and some cleanup
*jigdo-0.7.3-r1 (04 Sep 2009)
diff --git a/net-misc/jigdo/jigdo-0.7.3-r1.ebuild b/net-misc/jigdo/jigdo-0.7.3-r1.ebuild
index f5c2f0ecef70..6807c3770866 100644
--- a/net-misc/jigdo/jigdo-0.7.3-r1.ebuild
+++ b/net-misc/jigdo/jigdo-0.7.3-r1.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3-r1.ebuild,v 1.1 2009/09/04 15:49:34 jer Exp $
-
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3-r1.ebuild,v 1.2 2011/03/28 17:05:49 angelos Exp $
+EAPI=3
inherit eutils
DESCRIPTION="Jigsaw Download is a tool designed to ease the distribution of large files, for example DVD images."
HOMEPAGE="http://atterer.net/jigdo/"
-SRC_URI="http://atterer.net/jigdo/${P}.tar.bz2"
+SRC_URI="http://atterer.net/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="gtk nls berkdb libwww"
-RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
berkdb? ( >=sys-libs/db-3.2 )
libwww? ( >=net-libs/libwww-5.3.2 )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc43.patch
- epatch "${FILESDIR}"/${P}-strip.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-strip.patch
}
src_configure() {
diff --git a/net-misc/jigdo/jigdo-0.7.3.ebuild b/net-misc/jigdo/jigdo-0.7.3.ebuild
index 3bb31d5e595e..d847971b7c94 100644
--- a/net-misc/jigdo/jigdo-0.7.3.ebuild
+++ b/net-misc/jigdo/jigdo-0.7.3.ebuild
@@ -1,38 +1,36 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3.ebuild,v 1.8 2008/04/29 19:15:09 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/jigdo/jigdo-0.7.3.ebuild,v 1.9 2011/03/28 17:05:49 angelos Exp $
+EAPI=3
inherit eutils
DESCRIPTION="Jigsaw Download is a tool designed to ease the distribution of large files, for example DVD images."
HOMEPAGE="http://atterer.net/jigdo/"
-SRC_URI="http://atterer.net/jigdo/${P}.tar.bz2"
+SRC_URI="http://atterer.net/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE="gtk nls berkdb libwww"
-RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
berkdb? ( >=sys-libs/db-3.2 )
libwww? ( >=net-libs/libwww-5.3.2 )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc43.patch
}
-src_compile() {
+src_configure() {
local myconf
use gtk && use libwww || myconf="${myconf} --without-gui"
use berkdb || myconf="${myconf} --without-libdb"
econf $(use_enable nls) ${myconf}
- emake || die "emake failed."
}
src_install() {