summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-08-10 13:52:47 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-08-10 13:52:47 +0000
commitd6be4db50cd4eb773e2a5d408db82fc8cb89c208 (patch)
tree99f7efbe2e09b7166476618d635a0f6fb02ce9ec /net-misc/leechcraft-core
parentVersion bump from upstream with many, many bug fixes. Bug 430694 by Dustin C.... (diff)
downloadgentoo-2-d6be4db50cd4eb773e2a5d408db82fc8cb89c208.tar.gz
gentoo-2-d6be4db50cd4eb773e2a5d408db82fc8cb89c208.tar.bz2
gentoo-2-d6be4db50cd4eb773e2a5d408db82fc8cb89c208.zip
Pass -DLEECHCRAFT_VERSION to cmake in non-999 ebuilds. Thanks to 0xd34df00d
(Portage version: 2.1.11.4/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/leechcraft-core')
-rw-r--r--net-misc/leechcraft-core/ChangeLog10
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-0.5.70-r1.ebuild (renamed from net-misc/leechcraft-core/leechcraft-core-0.5.75.ebuild)9
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-0.5.75-r1.ebuild42
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-9999.ebuild14
4 files changed, 65 insertions, 10 deletions
diff --git a/net-misc/leechcraft-core/ChangeLog b/net-misc/leechcraft-core/ChangeLog
index caa562bfa2a5..e5c2ded9f2fc 100644
--- a/net-misc/leechcraft-core/ChangeLog
+++ b/net-misc/leechcraft-core/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/leechcraft-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.20 2012/07/19 19:59:41 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.21 2012/08/10 13:52:47 maksbotan Exp $
+
+*leechcraft-core-0.5.70-r1 (10 Aug 2012)
+*leechcraft-core-0.5.75-r1 (10 Aug 2012)
+
+ 10 Aug 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-core-0.5.70-r1.ebuild, +leechcraft-core-0.5.75-r1.ebuild,
+ -leechcraft-core-0.5.75.ebuild, leechcraft-core-9999.ebuild:
+ Pass -DLEECHCRAFT_VERSION to cmake in non-999 ebuilds. Thanks to 0xd34df00d
*leechcraft-core-0.5.75 (19 Jul 2012)
diff --git a/net-misc/leechcraft-core/leechcraft-core-0.5.75.ebuild b/net-misc/leechcraft-core/leechcraft-core-0.5.70-r1.ebuild
index d45feedf6a68..1478491246ed 100644
--- a/net-misc/leechcraft-core/leechcraft-core-0.5.75.ebuild
+++ b/net-misc/leechcraft-core/leechcraft-core-0.5.70-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.5.75.ebuild,v 1.1 2012/07/19 19:59:41 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.5.70-r1.ebuild,v 1.1 2012/08/10 13:52:47 maksbotan Exp $
EAPI="4"
@@ -28,8 +28,11 @@ pkg_setup() {
}
src_configure() {
- local mycmakeargs="
- -DWITH_PLUGINS=False"
+ local mycmakeargs=(
+ -DWITH_PLUGINS=False
+ -DLEECHCRAFT_VERSION=${PV}
+ )
+
cmake-utils_src_configure
}
diff --git a/net-misc/leechcraft-core/leechcraft-core-0.5.75-r1.ebuild b/net-misc/leechcraft-core/leechcraft-core-0.5.75-r1.ebuild
new file mode 100644
index 000000000000..3c19122b9b1c
--- /dev/null
+++ b/net-misc/leechcraft-core/leechcraft-core-0.5.75-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.5.75-r1.ebuild,v 1.1 2012/08/10 13:52:47 maksbotan Exp $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit eutils confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sqlite postgres"
+
+DEPEND=">=dev-libs/boost-1.46
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ x11-libs/qt-sql:4[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ x11-libs/qt-svg:4"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_PLUGINS=False
+ -DLEECHCRAFT_VERSION=${PV}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+}
diff --git a/net-misc/leechcraft-core/leechcraft-core-9999.ebuild b/net-misc/leechcraft-core/leechcraft-core-9999.ebuild
index 7685e04b8413..9fe0084aa4d7 100644
--- a/net-misc/leechcraft-core/leechcraft-core-9999.ebuild
+++ b/net-misc/leechcraft-core/leechcraft-core-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-9999.ebuild,v 1.6 2012/07/15 16:00:50 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-9999.ebuild,v 1.7 2012/08/10 13:52:47 maksbotan Exp $
EAPI="4"
@@ -23,13 +23,15 @@ DEPEND=">=dev-libs/boost-1.46
RDEPEND="${DEPEND}
x11-libs/qt-svg:4"
-pkg_setup() {
- confutils_require_any postgres sqlite
-}
+REQUIRED_USE="|| ( postgres sqlite )"
src_configure() {
- local mycmakeargs="
- -DWITH_PLUGINS=False"
+ local mycmakeargs=(
+ -DWITH_PLUGINS=False
+ )
+ if [[ ${PV} != 9999 ]]; then
+ mycmakeargs += "-DLEECHCRAFT_VERSION=${PV}"
+ fi
cmake-utils_src_configure
}