summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-09-03 19:07:19 +0000
committerPacho Ramos <pacho@gentoo.org>2013-09-03 19:07:19 +0000
commitd1a1a2ee7514f4ed49b546907c80c2ac400fa501 (patch)
treeb35dc8a2311089481f457e0836579830bfb55fae /net-misc/logmein-hamachi
parentBump KDE to 4.1.1 (diff)
downloadgentoo-2-d1a1a2ee7514f4ed49b546907c80c2ac400fa501.tar.gz
gentoo-2-d1a1a2ee7514f4ed49b546907c80c2ac400fa501.tar.bz2
gentoo-2-d1a1a2ee7514f4ed49b546907c80c2ac400fa501.zip
Add unit file (#478524)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-misc/logmein-hamachi')
-rw-r--r--net-misc/logmein-hamachi/ChangeLog8
-rw-r--r--net-misc/logmein-hamachi/files/logmein-hamachi.service10
-rw-r--r--net-misc/logmein-hamachi/logmein-hamachi-2.1.0.101-r1.ebuild65
3 files changed, 82 insertions, 1 deletions
diff --git a/net-misc/logmein-hamachi/ChangeLog b/net-misc/logmein-hamachi/ChangeLog
index a2777181c252..1e4e0300ea52 100644
--- a/net-misc/logmein-hamachi/ChangeLog
+++ b/net-misc/logmein-hamachi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/logmein-hamachi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.12 2013/07/06 16:38:53 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.13 2013/09/03 19:07:19 pacho Exp $
+
+*logmein-hamachi-2.1.0.101-r1 (03 Sep 2013)
+
+ 03 Sep 2013; Pacho Ramos <pacho@gentoo.org> +files/logmein-hamachi.service,
+ +logmein-hamachi-2.1.0.101-r1.ebuild:
+ Add unit file (#478524)
*logmein-hamachi-2.1.0.101 (06 Jul 2013)
diff --git a/net-misc/logmein-hamachi/files/logmein-hamachi.service b/net-misc/logmein-hamachi/files/logmein-hamachi.service
new file mode 100644
index 000000000000..609447e16373
--- /dev/null
+++ b/net-misc/logmein-hamachi/files/logmein-hamachi.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LogMeIn Hamachi daemon
+After=local-fs.target network.target
+
+[Service]
+ExecStart=/opt/logmein-hamachi/bin/hamachid
+Type=forking
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.101-r1.ebuild b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.101-r1.ebuild
new file mode 100644
index 000000000000..da959ef74fd1
--- /dev/null
+++ b/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.101-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.1.0.101-r1.ebuild,v 1.1 2013/09/03 19:07:19 pacho Exp $
+
+EAPI=5
+inherit eutils linux-info systemd
+
+DESCRIPTION="LogMeIn Hamachi VPN tunneling engine"
+HOMEPAGE="https://secure.logmein.com/products/hamachi2"
+SRC_URI="x86? ( https://secure.logmein.com/labs/${P}-x86.tgz )
+ amd64? ( https://secure.logmein.com/labs/${P}-x64.tgz )"
+
+LICENSE="LogMeIn"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-misc/hamachi"
+
+RESTRICT="mirror"
+
+QA_PREBUILT="/opt/${PN}/bin/hamachid"
+QA_PRESTRIPPED="/opt/${PN}/bin/hamachid"
+QA_WX_LOAD="/opt/${PN}/bin/hamachid"
+
+pkg_setup() {
+ einfo "Checking your kernel configuration for TUN/TAP support."
+ CONFIG_CHECK="~TUN"
+ check_extra_config
+}
+
+src_unpack() {
+ unpack ${A}
+ mv "${P}-$(use x86 && echo x86 || echo x64)" "${S}" || die
+}
+
+src_install() {
+ into /opt/${PN}
+ dobin hamachid dnsup dnsdown
+ dosym /opt/${PN}/bin/hamachid /usr/bin/hamachi
+
+ # Config and log directory
+ dodir /var/lib/${PN}
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ dodoc CHANGES README
+}
+
+pkg_postinst() {
+ elog "LogMeIn Hamachi2 is installed."
+ elog "Consult the README file on how to configure your client."
+ elog "You can run the client 'hamachi' as root,"
+ elog "or as a user if you add a newline terminated line:"
+ elog "Ipc.User <login name>"
+ elog "to the file '/var/lib/${PN}/h2-engine-override.cfg'"
+ elog "and restart the daemon with"
+ elog "/etc/init.d/${PN} restart"
+ elog "or:"
+ elog "systemctl restart ${PN}"
+ elog "To enable auto-login when the service starts set a nickname in"
+ elog "/etc/conf.d/${PN} (only supported using openRC)"
+}