summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2009-04-16 20:25:04 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2009-04-16 20:25:04 +0000
commit282dbc0156cfdcf151b52fb716dbd8864178f763 (patch)
tree32328ed3ffc013abde57362833faf837284b6a8d /net-misc/mico
parentDrop KDE 4.2.1 (diff)
downloadgentoo-2-282dbc0156cfdcf151b52fb716dbd8864178f763.tar.gz
gentoo-2-282dbc0156cfdcf151b52fb716dbd8864178f763.tar.bz2
gentoo-2-282dbc0156cfdcf151b52fb716dbd8864178f763.zip
use gcc pthread flag instead of -lpthread.
do not link -lstdc++ explicitly on aix. (Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'net-misc/mico')
-rw-r--r--net-misc/mico/ChangeLog8
-rw-r--r--net-misc/mico/files/mico-2.3.13-aix.patch12
-rw-r--r--net-misc/mico/files/mico-2.3.13-pthread.patch46
-rw-r--r--net-misc/mico/mico-2.3.13.ebuild9
4 files changed, 73 insertions, 2 deletions
diff --git a/net-misc/mico/ChangeLog b/net-misc/mico/ChangeLog
index c2184d8effbc..4370d2986ced 100644
--- a/net-misc/mico/ChangeLog
+++ b/net-misc/mico/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/mico
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.19 2009/04/07 08:33:33 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/ChangeLog,v 1.20 2009/04/16 20:25:03 haubi Exp $
+
+ 16 Apr 2009; Michael Haubenwallner <haubi@gentoo.org>
+ +files/mico-2.3.13-aix.patch, +files/mico-2.3.13-pthread.patch,
+ mico-2.3.13.ebuild:
+ use gcc pthread flag instead of -lpthread.
+ do not link -lstdc++ explicitly on aix.
07 Apr 2009; Michael Haubenwallner <haubi@gentoo.org> metadata.xml:
added <longdescription lang=en/>
diff --git a/net-misc/mico/files/mico-2.3.13-aix.patch b/net-misc/mico/files/mico-2.3.13-aix.patch
new file mode 100644
index 000000000000..feac0f71a293
--- /dev/null
+++ b/net-misc/mico/files/mico-2.3.13-aix.patch
@@ -0,0 +1,12 @@
+Do not add '-lstdc++' explicitly, this is c++ compiler's job.
+--- admin/mico-shld.aix.in.orig 2009-04-02 17:33:03 +0200
++++ admin/mico-shld.aix.in 2009-04-02 17:33:22 +0200
+@@ -87,7 +87,7 @@
+
+
+ ldcmd="@SHARED_CC@ @LDSOFLAGS@ @DLFLAGS@ $libdirs @LDFLAGS@ \
+- -Wl,-bE:lib.exp,-bnoentry -o '$outfile' $args @LIBS@ -lstdc++"
++ -Wl,-bE:lib.exp,-bnoentry -o '$outfile' $args @LIBS@"
+
+ echo "$ldcmd"
+ eval "$ldcmd"
diff --git a/net-misc/mico/files/mico-2.3.13-pthread.patch b/net-misc/mico/files/mico-2.3.13-pthread.patch
new file mode 100644
index 000000000000..f2c419e44235
--- /dev/null
+++ b/net-misc/mico/files/mico-2.3.13-pthread.patch
@@ -0,0 +1,46 @@
+When using gcc, use '-pthread' (or '-pthreads' on solaris)
+compiler flag to do all pthread specific things.
+--- configure.in.orig 2009-04-02 17:25:45 +0200
++++ configure.in 2009-04-02 17:32:00 +0200
+@@ -524,7 +524,19 @@
+ )
+ AC_CHECK_HEADERS(semaphore.h)
+ AC_DEFINE(HAVE_PTHREADS)
++ case "${GXX}:${target}" in
++ yes:*solaris*|yes:*sunos*)
++ CXXFLAGS="-pthreads ${CXXFLAGS}"
++ LDFLAGS="-pthreads ${LDFLAGS}"
++ ;;
++ yes:*)
++ CXXFLAGS="-pthread ${CXXFLAGS}"
++ LDFLAGS="-pthread ${LDFLAGS}"
++ ;;
++ *)
+ SHLIBS="-lpthread"
++ ;;
++ esac
+ else
+ AC_CHECK_LIB(c_r, pthread_create, use_pthreads=yes, use_pthreads=no)
+ if test X"$use_pthreads" = Xyes; then
+--- configure.orig 2009-04-02 17:25:42 +0200
++++ configure 2009-04-02 17:32:00 +0200
+@@ -2738,7 +2738,19 @@
+ #define HAVE_PTHREADS 1
+ EOF
+
++ case "${GXX}:${target}" in
++ yes:*solaris*|yes:*sunos*)
++ CXXFLAGS="-pthreads ${CXXFLAGS}"
++ LDFLAGS="-pthreads ${LDFLAGS}"
++ ;;
++ yes:*)
++ CXXFLAGS="-pthread ${CXXFLAGS}"
++ LDFLAGS="-pthread ${LDFLAGS}"
++ ;;
++ *)
+ SHLIBS="-lpthread"
++ ;;
++ esac
+ else
+ echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
+ echo "configure:2745: checking for pthread_create in -lc_r" >&5
diff --git a/net-misc/mico/mico-2.3.13.ebuild b/net-misc/mico/mico-2.3.13.ebuild
index 475cde80ecd9..707cd4ba129b 100644
--- a/net-misc/mico/mico-2.3.13.ebuild
+++ b/net-misc/mico/mico-2.3.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.13.ebuild,v 1.3 2009/03/31 12:13:18 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mico/mico-2.3.13.ebuild,v 1.4 2009/04/16 20:25:03 haubi Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -37,6 +37,13 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-nolibcheck.patch
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-pthread.patch
+ epatch "${FILESDIR}"/${P}-aix.patch
+
+ # cannot use big TOC (AIX only), gdb doesn't like it.
+ # This assumes that the compiler (or -wrapper) uses
+ # gcc flag '-mminimal-toc' for compilation.
+ sed -i -e 's/,-bbigtoc//' "${S}"/configure
}
src_compile() {