summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2007-11-10 19:37:18 +0000
committerBenedikt Boehm <hollow@gentoo.org>2007-11-10 19:37:18 +0000
commit47d0c77384f6e8174f297ca151d2bd7162398403 (patch)
tree85c86afb76eade475925fb4d33eb00fda084be52 /net-misc/neon
parentamd64 stable and I'm done with perl yayay (diff)
downloadgentoo-2-47d0c77384f6e8174f297ca151d2bd7162398403.tar.gz
gentoo-2-47d0c77384f6e8174f297ca151d2bd7162398403.tar.bz2
gentoo-2-47d0c77384f6e8174f297ca151d2bd7162398403.zip
version bump; fixes #114759, #162318, #186929, #197964
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-misc/neon')
-rw-r--r--net-misc/neon/ChangeLog7
-rw-r--r--net-misc/neon/files/digest-neon-0.26.43
-rw-r--r--net-misc/neon/neon-0.26.4.ebuild87
3 files changed, 96 insertions, 1 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index ce367eaeb912..2b90f7fc3353 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/neon
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.89 2007/07/06 18:48:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.90 2007/11/10 19:37:18 hollow Exp $
+
+*neon-0.26.4 (10 Nov 2007)
+
+ 10 Nov 2007; Benedikt Böhm <hollow@gentoo.org> +neon-0.26.4.ebuild:
+ version bump; fixes #114759, #162318, #186929, #197964
06 Jul 2007; Mike Frysinger <vapier@gentoo.org> neon-0.26.1.ebuild,
neon-0.26.1-r1.ebuild, neon-0.26.3.ebuild:
diff --git a/net-misc/neon/files/digest-neon-0.26.4 b/net-misc/neon/files/digest-neon-0.26.4
new file mode 100644
index 000000000000..b9e7ef13ec90
--- /dev/null
+++ b/net-misc/neon/files/digest-neon-0.26.4
@@ -0,0 +1,3 @@
+MD5 2d11fff51ffa856fc6b5d4bd801d6cc4 neon-0.26.4.tar.gz 794225
+RMD160 7f1f63aa05b8b1329a88d95dca513af08f2d632d neon-0.26.4.tar.gz 794225
+SHA256 92d9a9f097734e9baa542febae9419b0d22540e3158e245220fea1b078b159de neon-0.26.4.tar.gz 794225
diff --git a/net-misc/neon/neon-0.26.4.ebuild b/net-misc/neon/neon-0.26.4.ebuild
new file mode 100644
index 000000000000..36d7cb334657
--- /dev/null
+++ b/net-misc/neon/neon-0.26.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.4.ebuild,v 1.1 2007/11/10 19:37:18 hollow Exp $
+
+inherit eutils libtool versionator autotools
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="http://www.webdav.org/neon/"
+SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="expat kerberos nls socks5 ssl zlib"
+RESTRICT="test"
+
+DEPEND="expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ kerberos? ( virtual/krb5 )
+ nls? ( virtual/libintl )
+ socks5? ( net-proxy/dante )
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ elibtoolize
+}
+
+src_compile() {
+ local myconf=
+
+ if has_version sys-libs/glibc; then
+ if built_with_use --missing true sys-libs/glibc nptlonly \
+ || built_with_use --missing true sys-libs/glibc nptl; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf="${myconf} --enable-threadsafe-ssl=posix"
+ fi
+ fi
+
+ if use expat; then
+ myconf="${myconf} --with-expat"
+ else
+ myconf="${myconf} --with-libxml2"
+ fi
+
+ if use ssl; then
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_with zlib) \
+ $(use_with kerberos gssapi) \
+ $(use_enable socks5 socks) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ make check || die "Trying make check without success."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die 'install failed'
+ dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/*
+}
+
+pkg_postinst() {
+ ewarn "There are new features in this version; please beware that"
+ ewarn "upstream considers the socks support experimental. If you"
+ ewarn "experience test failures (eg, bug 135863) then try rebuilding"
+ ewarn "glibc."
+ ewarn
+ ewarn "Neon has a policy of breaking API across versions, this means"
+ ewarn "that any packages that links against neon will be broken after"
+ ewarn "updating. They will remain broken until they are ported to the"
+ ewarn "new API. You can downgrade neon to the previous version by doing:"
+ ewarn
+ ewarn " emerge --oneshot '<net-misc/neon-$(get_version_component_range 1-2 ${PV})'"
+ ewarn
+ ewarn "You may also have to downgrade any packages that have already been"
+ ewarn "ported to the new API."
+}