summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2015-03-12 12:24:41 +0000
committerBenda XU <heroxbd@gentoo.org>2015-03-12 12:24:41 +0000
commit2a683f7276caf20848166bcf337b2689414c73ca (patch)
tree72091afe5a50858bea13ac7e973267c5080f804f /net-misc/netifrc
parentOld. (diff)
downloadgentoo-2-2a683f7276caf20848166bcf337b2689414c73ca.tar.gz
gentoo-2-2a683f7276caf20848166bcf337b2689414c73ca.tar.bz2
gentoo-2-2a683f7276caf20848166bcf337b2689414c73ca.zip
Add UDEVDIR back to support Prefix.
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/netifrc')
-rw-r--r--net-misc/netifrc/netifrc-0.3.1.ebuild5
-rw-r--r--net-misc/netifrc/netifrc-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/net-misc/netifrc/netifrc-0.3.1.ebuild b/net-misc/netifrc/netifrc-0.3.1.ebuild
index dea0efeac306..5bb0805fc613 100644
--- a/net-misc/netifrc/netifrc-0.3.1.ebuild
+++ b/net-misc/netifrc/netifrc-0.3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-0.3.1.ebuild,v 1.2 2015/03/05 04:18:06 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-0.3.1.ebuild,v 1.3 2015/03/12 12:24:41 heroxbd Exp $
EAPI=5
-inherit eutils systemd
+inherit eutils systemd udev
DESCRIPTION="Gentoo Network Interface Management Scripts"
HOMEPAGE="http://www.gentoo.org/proj/en/base/openrc/"
@@ -40,6 +40,7 @@ src_prepare() {
src_compile() {
MAKE_ARGS="${MAKE_ARGS}
+ UDEVDIR=${EPREFIX}$(get_udevdir)
LIBEXECDIR=${EPREFIX}/lib/${PN} PF=${PF}"
use prefix && MAKE_ARGS="${MAKE_ARGS} MKPREFIX=yes PREFIX=${EPREFIX}"
diff --git a/net-misc/netifrc/netifrc-9999.ebuild b/net-misc/netifrc/netifrc-9999.ebuild
index c0f66c3e4be5..85db13d2a0b6 100644
--- a/net-misc/netifrc/netifrc-9999.ebuild
+++ b/net-misc/netifrc/netifrc-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-9999.ebuild,v 1.11 2015/03/05 04:20:35 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netifrc/netifrc-9999.ebuild,v 1.12 2015/03/12 12:24:41 heroxbd Exp $
EAPI=5
-inherit eutils systemd
+inherit eutils systemd udev
DESCRIPTION="Gentoo Network Interface Management Scripts"
HOMEPAGE="http://www.gentoo.org/proj/en/base/openrc/"
@@ -40,6 +40,7 @@ src_prepare() {
src_compile() {
MAKE_ARGS="${MAKE_ARGS}
+ UDEVDIR=${EPREFIX}$(get_udevdir)
LIBEXECDIR=${EPREFIX}/lib/${PN} PF=${PF}"
use prefix && MAKE_ARGS="${MAKE_ARGS} MKPREFIX=yes PREFIX=${EPREFIX}"