summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-16 15:19:53 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-16 15:19:53 +0000
commit933285f1af5d8ae16bdf83efc173726351379ec3 (patch)
treed2a3d73e49ce0b0e41a469548383833b33de4a76 /net-misc/netpipes/netpipes-4.2-r1.ebuild
parentVersion bump to 1.10 (diff)
downloadgentoo-2-933285f1af5d8ae16bdf83efc173726351379ec3.tar.gz
gentoo-2-933285f1af5d8ae16bdf83efc173726351379ec3.tar.bz2
gentoo-2-933285f1af5d8ae16bdf83efc173726351379ec3.zip
Respect LDFLAGS (bug #337648). Clean up.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'net-misc/netpipes/netpipes-4.2-r1.ebuild')
-rw-r--r--net-misc/netpipes/netpipes-4.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/netpipes/netpipes-4.2-r1.ebuild b/net-misc/netpipes/netpipes-4.2-r1.ebuild
new file mode 100644
index 000000000000..46ef8c5c131a
--- /dev/null
+++ b/net-misc/netpipes/netpipes-4.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/netpipes/netpipes-4.2-r1.ebuild,v 1.1 2010/09/16 15:19:53 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="netpipes - a package to manipulate BSD TCP/IP stream sockets"
+HOMEPAGE="http://web.purplefrog.com/~thoth/netpipes/"
+SRC_URI="http://web.purplefrog.com/~thoth/netpipes/ftp/${P}-export.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i \
+ -e 's/CFLAGS =/CFLAGS +=/' \
+ -e '/ -o /s:${CFLAGS}:& $(LDFLAGS):g' \
+ Makefile || die "sed failed"
+
+ epatch "${FILESDIR}/${P}-string.patch"
+}
+
+src_compile () {
+ emake CC=$(tc-getCC) || die
+}
+
+src_install() {
+ mkdir -p "${D}"/usr/share/man || die
+ emake INSTROOT="${D}"/usr INSTMAN="${D}"/usr/share/man install || die
+}