summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-02-10 03:10:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-02-10 03:10:55 +0000
commitf8f527cfca7e156da86a9b3588a9e0a02dd3280b (patch)
tree4138b1466c4452fe3770038744f1f29c17974e13 /net-misc/openssh
parentDrop libmms dep since xbmc now uses ffmpeg #353919 by BT. (diff)
downloadgentoo-2-f8f527cfca7e156da86a9b3588a9e0a02dd3280b.tar.gz
gentoo-2-f8f527cfca7e156da86a9b3588a9e0a02dd3280b.tar.bz2
gentoo-2-f8f527cfca7e156da86a9b3588a9e0a02dd3280b.zip
Revamp AES-CTR-MT disable comment, with explicit reference to upstream documentation and testcase reference (bug #354113, comment 6).
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/ChangeLog8
-rw-r--r--net-misc/openssh/openssh-5.5_p1-r2.ebuild18
-rw-r--r--net-misc/openssh/openssh-5.6_p1-r2.ebuild16
-rw-r--r--net-misc/openssh/openssh-5.7_p1-r1.ebuild16
-rw-r--r--net-misc/openssh/openssh-5.8_p1-r1.ebuild16
-rw-r--r--net-misc/openssh/openssh-5.8_p1.ebuild16
6 files changed, 63 insertions, 27 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 46580494b5a2..fd3200c92156 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.409 2011/02/10 02:44:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.410 2011/02/10 03:10:55 robbat2 Exp $
+
+ 10 Feb 2011; Robin H. Johnson <robbat2@gentoo.org> openssh-5.5_p1-r2.ebuild,
+ openssh-5.6_p1-r2.ebuild, openssh-5.7_p1-r1.ebuild, openssh-5.8_p1.ebuild,
+ openssh-5.8_p1-r1.ebuild:
+ Revamp AES-CTR-MT disable comment, with explicit reference to upstream
+ documentation and testcase reference (bug #354113, comment 6).
10 Feb 2011; Mike Frysinger <vapier@gentoo.org> openssh-5.8_p1-r1.ebuild,
+files/openssh-5.8_p1-selinux.patch:
diff --git a/net-misc/openssh/openssh-5.5_p1-r2.ebuild b/net-misc/openssh/openssh-5.5_p1-r2.ebuild
index f24de433f624..28818cc89c63 100644
--- a/net-misc/openssh/openssh-5.5_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-5.5_p1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.5_p1-r2.ebuild,v 1.7 2010/09/24 11:11:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.5_p1-r2.ebuild,v 1.8 2011/02/10 03:10:55 robbat2 Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -106,10 +106,16 @@ src_prepare() {
# version.h patch conflict avoidence
mv version.h version.h.hpn
cp -f version.h.pristine version.h
- # The AES-CTR multithreaded variant is temporarily broken, and
- # causes random hangs when combined with the -f switch of ssh.
- # To avoid this, we change the internal table to use the non-multithread
- # version for the meantime.
+ # The AES-CTR multithreaded variant is broken, and causes random hangs
+ # when combined background threading and control sockets. To avoid
+ # this, we change the internal table to use the non-multithread version
+ # for the meantime. Do NOT remove this in new versions. See bug #354113,
+ # comment #6 for testcase.
+ # Upstream reference: http://www.psc.edu/networking/projects/hpn-ssh/
+ ## Additionally, the MT-AES-CTR mode cipher replaces the default ST-AES-CTR mode
+ ## cipher. Be aware that if the client process is forked using the -f command line
+ ## option the process will hang as the parent thread gets 'divorced' from the key
+ ## generation threads. This issue will be resolved as soon as possible
sed -i \
-e '/aes...-ctr.*SSH_CIPHER_SSH2/s,evp_aes_ctr_mt,evp_aes_128_ctr,' \
cipher.c || die
diff --git a/net-misc/openssh/openssh-5.6_p1-r2.ebuild b/net-misc/openssh/openssh-5.6_p1-r2.ebuild
index c12d854da5ea..829c5ac3b37f 100644
--- a/net-misc/openssh/openssh-5.6_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-5.6_p1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.6_p1-r2.ebuild,v 1.9 2011/02/10 02:30:27 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.6_p1-r2.ebuild,v 1.10 2011/02/10 03:10:55 robbat2 Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -99,10 +99,16 @@ src_prepare() {
# version.h patch conflict avoidence
mv version.h version.h.hpn
cp -f version.h.pristine version.h
- # The AES-CTR multithreaded variant is temporarily broken, and
- # causes random hangs when combined with the -f switch of ssh.
- # To avoid this, we change the internal table to use the non-multithread
- # version for the meantime. Do NOT remove this in new versions.
+ # The AES-CTR multithreaded variant is broken, and causes random hangs
+ # when combined background threading and control sockets. To avoid
+ # this, we change the internal table to use the non-multithread version
+ # for the meantime. Do NOT remove this in new versions. See bug #354113
+ # comment #6 for testcase.
+ # Upstream reference: http://www.psc.edu/networking/projects/hpn-ssh/
+ ## Additionally, the MT-AES-CTR mode cipher replaces the default ST-AES-CTR mode
+ ## cipher. Be aware that if the client process is forked using the -f command line
+ ## option the process will hang as the parent thread gets 'divorced' from the key
+ ## generation threads. This issue will be resolved as soon as possible
sed -i \
-e '/aes...-ctr.*SSH_CIPHER_SSH2/s,evp_aes_ctr_mt,evp_aes_128_ctr,' \
cipher.c || die
diff --git a/net-misc/openssh/openssh-5.7_p1-r1.ebuild b/net-misc/openssh/openssh-5.7_p1-r1.ebuild
index 8c7b291a2fb8..e170f7465125 100644
--- a/net-misc/openssh/openssh-5.7_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-5.7_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.7_p1-r1.ebuild,v 1.2 2011/02/10 02:30:27 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.7_p1-r1.ebuild,v 1.3 2011/02/10 03:10:55 robbat2 Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -97,10 +97,16 @@ src_prepare() {
# version.h patch conflict avoidence
mv version.h version.h.hpn
cp -f version.h.pristine version.h
- # The AES-CTR multithreaded variant is temporarily broken, and
- # causes random hangs when combined with the -f switch of ssh.
- # To avoid this, we change the internal table to use the non-multithread
- # version for the meantime. Do NOT remove this in new versions.
+ # The AES-CTR multithreaded variant is broken, and causes random hangs
+ # when combined background threading and control sockets. To avoid
+ # this, we change the internal table to use the non-multithread version
+ # for the meantime. Do NOT remove this in new versions. See bug #354113
+ # comment #6 for testcase.
+ # Upstream reference: http://www.psc.edu/networking/projects/hpn-ssh/
+ ## Additionally, the MT-AES-CTR mode cipher replaces the default ST-AES-CTR mode
+ ## cipher. Be aware that if the client process is forked using the -f command line
+ ## option the process will hang as the parent thread gets 'divorced' from the key
+ ## generation threads. This issue will be resolved as soon as possible
sed -i \
-e '/aes...-ctr.*SSH_CIPHER_SSH2/s,evp_aes_ctr_mt,evp_aes_128_ctr,' \
cipher.c || die
diff --git a/net-misc/openssh/openssh-5.8_p1-r1.ebuild b/net-misc/openssh/openssh-5.8_p1-r1.ebuild
index 4fad901aeba4..8da79ca25b4e 100644
--- a/net-misc/openssh/openssh-5.8_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-5.8_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p1-r1.ebuild,v 1.2 2011/02/10 02:44:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p1-r1.ebuild,v 1.3 2011/02/10 03:10:55 robbat2 Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -97,10 +97,16 @@ src_prepare() {
# version.h patch conflict avoidence
mv version.h version.h.hpn
cp -f version.h.pristine version.h
- # The AES-CTR multithreaded variant is temporarily broken, and
- # causes random hangs when combined with the -f switch of ssh.
- # To avoid this, we change the internal table to use the non-multithread
- # version for the meantime. Do NOT remove this in new versions.
+ # The AES-CTR multithreaded variant is broken, and causes random hangs
+ # when combined background threading and control sockets. To avoid
+ # this, we change the internal table to use the non-multithread version
+ # for the meantime. Do NOT remove this in new versions. See bug #354113
+ # comment #6 for testcase.
+ # Upstream reference: http://www.psc.edu/networking/projects/hpn-ssh/
+ ## Additionally, the MT-AES-CTR mode cipher replaces the default ST-AES-CTR mode
+ ## cipher. Be aware that if the client process is forked using the -f command line
+ ## option the process will hang as the parent thread gets 'divorced' from the key
+ ## generation threads. This issue will be resolved as soon as possible
sed -i \
-e '/aes...-ctr.*SSH_CIPHER_SSH2/s,evp_aes_ctr_mt,evp_aes_128_ctr,' \
cipher.c || die
diff --git a/net-misc/openssh/openssh-5.8_p1.ebuild b/net-misc/openssh/openssh-5.8_p1.ebuild
index 7b83cc149d2f..ee4afdb6c8ab 100644
--- a/net-misc/openssh/openssh-5.8_p1.ebuild
+++ b/net-misc/openssh/openssh-5.8_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p1.ebuild,v 1.5 2011/02/10 02:32:42 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p1.ebuild,v 1.6 2011/02/10 03:10:55 robbat2 Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -97,10 +97,16 @@ src_prepare() {
# version.h patch conflict avoidence
mv version.h version.h.hpn
cp -f version.h.pristine version.h
- # The AES-CTR multithreaded variant is temporarily broken, and
- # causes random hangs when combined with the -f switch of ssh.
- # To avoid this, we change the internal table to use the non-multithread
- # version for the meantime. Do NOT remove this in new versions.
+ # The AES-CTR multithreaded variant is broken, and causes random hangs
+ # when combined background threading and control sockets. To avoid
+ # this, we change the internal table to use the non-multithread version
+ # for the meantime. Do NOT remove this in new versions. See bug #354113
+ # comment #6 for testcase.
+ # Upstream reference: http://www.psc.edu/networking/projects/hpn-ssh/
+ ## Additionally, the MT-AES-CTR mode cipher replaces the default ST-AES-CTR mode
+ ## cipher. Be aware that if the client process is forked using the -f command line
+ ## option the process will hang as the parent thread gets 'divorced' from the key
+ ## generation threads. This issue will be resolved as soon as possible
sed -i \
-e '/aes...-ctr.*SSH_CIPHER_SSH2/s,evp_aes_ctr_mt,evp_aes_128_ctr,' \
cipher.c || die