summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-22 16:07:20 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-22 16:07:20 +0000
commit1a2551ebd038529dfef73e6e67dfc4aba198e6c0 (patch)
tree21acbea70e6fbb931d72a929f20fe251537701d3 /net-misc/pipes
parentRestore pam_usb from Attic because upstream released version based on UDisks ... (diff)
downloadgentoo-2-1a2551ebd038529dfef73e6e67dfc4aba198e6c0.tar.gz
gentoo-2-1a2551ebd038529dfef73e6e67dfc4aba198e6c0.tar.bz2
gentoo-2-1a2551ebd038529dfef73e6e67dfc4aba198e6c0.zip
Version bump thanks to euscan. Respect CC, respect CFLAGS during linking.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'net-misc/pipes')
-rw-r--r--net-misc/pipes/ChangeLog9
-rw-r--r--net-misc/pipes/pipes-1.16.1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/net-misc/pipes/ChangeLog b/net-misc/pipes/ChangeLog
index 096eb530bb54..e37ffe9dd188 100644
--- a/net-misc/pipes/ChangeLog
+++ b/net-misc/pipes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/pipes
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pipes/ChangeLog,v 1.11 2009/09/23 19:42:48 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pipes/ChangeLog,v 1.12 2011/04/22 16:07:20 jer Exp $
+
+*pipes-1.16.1 (22 Apr 2011)
+
+ 22 Apr 2011; Jeroen Roovers <jer@gentoo.org> +pipes-1.16.1.ebuild:
+ Version bump thanks to euscan. Respect CC, respect CFLAGS during linking.
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> pipes-1.16.ebuild:
Remove virtual/libc
diff --git a/net-misc/pipes/pipes-1.16.1.ebuild b/net-misc/pipes/pipes-1.16.1.ebuild
new file mode 100644
index 000000000000..5d6ef2235527
--- /dev/null
+++ b/net-misc/pipes/pipes-1.16.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pipes/pipes-1.16.1.ebuild,v 1.1 2011/04/22 16:07:20 jer Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Very versatile TCP pipes"
+HOMEPAGE="http://bisqwit.iki.fi/source/pipes.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~s390 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ sed -i Makefile -e "s:-O2:${CFLAGS}:" || die
+ touch .depend
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LDFLAGS="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin plis || die "dobin failed"
+ dohard /usr/bin/plis /usr/bin/pcon || die "dohard failed"
+ dodoc Examples ChangeLog
+ dohtml README.html
+}