summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-08-21 19:11:51 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-08-21 19:11:51 +0000
commit7e11e6b0f61bb8105e49757ce34800f8d4740ba7 (patch)
tree61d69a73d7d8f83679c3317d0792ec968f6fcd42 /net-misc/putty/putty-0.58.ebuild
parentmove the sshd -t test after key generation, and update key generation to retu... (diff)
downloadgentoo-2-7e11e6b0f61bb8105e49757ce34800f8d4740ba7.tar.gz
gentoo-2-7e11e6b0f61bb8105e49757ce34800f8d4740ba7.tar.bz2
gentoo-2-7e11e6b0f61bb8105e49757ce34800f8d4740ba7.zip
bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-misc/putty/putty-0.58.ebuild')
-rw-r--r--net-misc/putty/putty-0.58.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-misc/putty/putty-0.58.ebuild b/net-misc/putty/putty-0.58.ebuild
new file mode 100644
index 000000000000..608c9b830718
--- /dev/null
+++ b/net-misc/putty/putty-0.58.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.58.ebuild,v 1.1 2005/08/21 19:11:51 taviso Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://the.earth.li/~sgtatham/putty/${PV}/${P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64"
+IUSE="doc gtk ipv6"
+
+RDEPEND="gtk? ( =x11-libs/gtk+-1.2* virtual/x11 )"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+src_compile() {
+ use gtk || local targets="puttygen plink pscp psftp"
+ cd ${S}/unix
+
+ append-flags '-I.././' '-I../charset/' '-I../unix/'
+
+ use ipv6 || append-flags '-DNO_IPV6'
+ use gtk && append-flags '`gtk-config --cflags`'
+
+ emake -f Makefile.gtk ${targets:-all} CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ cd ${S}/doc
+ use gtk && doman pterm.1 putty.1 puttytel.1
+ use doc && dohtml *.html
+ dodoc puttydoc.txt
+ doman puttygen.1 plink.1
+
+ cd ${S}/unix
+ use gtk && dobin pterm putty puttytel
+ dobin puttygen plink pscp psftp
+
+ cd ${S}
+ dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER
+
+ prepallman
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ use gtk && {
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins ${FILESDIR}/putty.desktop
+ }
+
+ if test ! -c /dev/ptmx; then
+ ewarn
+ ewarn "The pterm application requires kernel UNIX98 PTY support to operate."
+ ewarn
+ fi
+}