summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-04-22 21:27:03 +0000
committerJon Portnoy <avenj@gentoo.org>2003-04-22 21:27:03 +0000
commit4656e092c591ed639a2adca87ae1a0646a98815b (patch)
treef6a052172a8030fcaf1adbbd5dfbc7290d2e7b8e /net-misc/scponly
parentslotting fixes (diff)
downloadgentoo-2-4656e092c591ed639a2adca87ae1a0646a98815b.tar.gz
gentoo-2-4656e092c591ed639a2adca87ae1a0646a98815b.tar.bz2
gentoo-2-4656e092c591ed639a2adca87ae1a0646a98815b.zip
Initial import of scponly
Diffstat (limited to 'net-misc/scponly')
-rw-r--r--net-misc/scponly/ChangeLog10
-rw-r--r--net-misc/scponly/Manifest2
-rw-r--r--net-misc/scponly/files/digest-scponly-3.71
-rw-r--r--net-misc/scponly/scponly-3.7.ebuild39
4 files changed, 52 insertions, 0 deletions
diff --git a/net-misc/scponly/ChangeLog b/net-misc/scponly/ChangeLog
new file mode 100644
index 000000000000..ab5aeec4d6ae
--- /dev/null
+++ b/net-misc/scponly/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/scponly
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/scponly/ChangeLog,v 1.1 2003/04/22 21:27:03 avenj Exp $
+
+*scponly-3.7 (22 Apr 2003)
+
+ 22 Apr 2003; Jon Portnoy <avenj@gentoo.org> scponly-3.7.ebuild :
+
+ Initial import. Ebuild submitted in bug #18850 by Matsuu Takuto
+ <matsuu@7501.net>.
diff --git a/net-misc/scponly/Manifest b/net-misc/scponly/Manifest
new file mode 100644
index 000000000000..1784d886b3b3
--- /dev/null
+++ b/net-misc/scponly/Manifest
@@ -0,0 +1,2 @@
+MD5 8fd7008186c03dd71c97069bf2869b61 scponly-3.7.ebuild 829
+MD5 7f3245890a81d9e6c8e271517fa8b3ad files/digest-scponly-3.7 59
diff --git a/net-misc/scponly/files/digest-scponly-3.7 b/net-misc/scponly/files/digest-scponly-3.7
new file mode 100644
index 000000000000..11be6ae6206b
--- /dev/null
+++ b/net-misc/scponly/files/digest-scponly-3.7
@@ -0,0 +1 @@
+MD5 6873df71eb44f91412f72158cc2b844e scponly-3.7.tgz 69725
diff --git a/net-misc/scponly/scponly-3.7.ebuild b/net-misc/scponly/scponly-3.7.ebuild
new file mode 100644
index 000000000000..836662346b97
--- /dev/null
+++ b/net-misc/scponly/scponly-3.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/scponly/scponly-3.7.ebuild,v 1.1 2003/04/22 21:27:03 avenj Exp $
+
+DESCRIPTION="A tiny psuedoshell which only permits scp and sftp"
+SRC_URI="http://www.sublimation.org/scponly/${P}.tgz"
+HOMEPAGE="http://www.sublimation.org/scponly/"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glibc
+ net-misc/openssh"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ PATH="${PATH}:/usr/lib/misc" ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ CONFDIR=${D}/etc/scponly \
+ install || die
+ grep -v scponly /etc/shells > ${D}/etc/shells
+ echo "/usr/bin/scponly" >> ${D}/etc/shells
+
+ dodoc AUTHOR CHANGELOG CONTRIB README TODO
+}