summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-20 17:19:50 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-03-20 17:19:50 +0000
commit4e7cbbff75100e341a1fbd99c430ae3b8ad01776 (patch)
tree8728cb9946337bd64317f05f87649a631dfcd42c /net-misc/siproxd
parentrevbump for sys-auth/keystone-2012.2.3-r1 to r2 for bug 462502 - CVE-2013-1865 (diff)
downloadgentoo-2-4e7cbbff75100e341a1fbd99c430ae3b8ad01776.tar.gz
gentoo-2-4e7cbbff75100e341a1fbd99c430ae3b8ad01776.tar.bz2
gentoo-2-4e7cbbff75100e341a1fbd99c430ae3b8ad01776.zip
Version bump. Do not keepdir /var/run, bug #452222. Restrict libosip dependency as the package does not build against libosip-4.0.0.
(Portage version: 2.1.11.52/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/siproxd')
-rw-r--r--net-misc/siproxd/ChangeLog13
-rw-r--r--net-misc/siproxd/files/siproxd-libtool-2.2.patch12
-rwxr-xr-xnet-misc/siproxd/files/siproxd.rc731
-rw-r--r--net-misc/siproxd/siproxd-0.8.0-r2.ebuild7
-rw-r--r--net-misc/siproxd/siproxd-0.8.1.ebuild (renamed from net-misc/siproxd/siproxd-0.8.0-r1.ebuild)27
5 files changed, 60 insertions, 30 deletions
diff --git a/net-misc/siproxd/ChangeLog b/net-misc/siproxd/ChangeLog
index 16407b78eafc..9d17e5d1b043 100644
--- a/net-misc/siproxd/ChangeLog
+++ b/net-misc/siproxd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/siproxd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/ChangeLog,v 1.24 2011/09/04 13:50:44 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/ChangeLog,v 1.25 2013/03/20 17:19:50 chithanh Exp $
+
+*siproxd-0.8.1 (20 Mar 2013)
+
+ 20 Mar 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/siproxd.rc7, +siproxd-0.8.1.ebuild, -files/siproxd-libtool-2.2.patch,
+ -siproxd-0.8.0-r1.ebuild, siproxd-0.8.0-r2.ebuild:
+ Version bump. Do not keepdir /var/run, bug #452222. Restrict libosip
+ dependency as the package does not build against libosip-4.0.0.
04 Sep 2011; Markus Meier <maekke@gentoo.org> siproxd-0.8.0-r2.ebuild:
x86 stable, bug #380807
@@ -100,4 +108,3 @@
+files/siproxd-0.5.11-configure-docs.diff, +files/siproxd.rc6,
+siproxd-0.5.11.ebuild:
Initial import.
-
diff --git a/net-misc/siproxd/files/siproxd-libtool-2.2.patch b/net-misc/siproxd/files/siproxd-libtool-2.2.patch
deleted file mode 100644
index 6210ef0d7618..000000000000
--- a/net-misc/siproxd/files/siproxd-libtool-2.2.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -r -U 2 a/src/plugins.h b/src/plugins.h
---- a/src/plugins.h 2010-01-07 12:44:38.000000000 +0100
-+++ b/src/plugins.h 2010-06-19 13:56:30.960679284 +0200
-@@ -25,4 +25,8 @@
-
-
-+#ifndef lt__PROGRAM__LTX_preloaded_symbols
-+#define lt__PROGRAM__LTX_preloaded_symbols lt_libltdl_LTX_preloaded_symbols
-+#endif
-+
- /* Plugins must return STS_SUCCESS / SUCCESS_FAILURE */
-
diff --git a/net-misc/siproxd/files/siproxd.rc7 b/net-misc/siproxd/files/siproxd.rc7
new file mode 100755
index 000000000000..b7eb2057448f
--- /dev/null
+++ b/net-misc/siproxd/files/siproxd.rc7
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/files/siproxd.rc7,v 1.1 2013/03/20 17:19:50 chithanh Exp $
+
+depend() {
+ need net
+}
+
+check_config() {
+ if [[ ! -f /etc/siproxd.conf ]]; then
+ eerror "Please create /etc/siproxd.conf first!"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ check_config || return 1
+ checkpath -q -d /var/run/siproxd -o siproxd:siproxd
+ ebegin "Starting siproxd"
+ start-stop-daemon --start --exec /usr/sbin/siproxd -- \
+ -p /var/run/siproxd/siproxd.pid -c /etc/siproxd.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping siproxd"
+ start-stop-daemon --stop --pidfile /var/run/siproxd/siproxd.pid
+ eend $?
+}
diff --git a/net-misc/siproxd/siproxd-0.8.0-r2.ebuild b/net-misc/siproxd/siproxd-0.8.0-r2.ebuild
index 981f818cf613..6387bd8305ff 100644
--- a/net-misc/siproxd/siproxd-0.8.0-r2.ebuild
+++ b/net-misc/siproxd/siproxd-0.8.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/siproxd-0.8.0-r2.ebuild,v 1.4 2011/09/04 13:50:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/siproxd-0.8.0-r2.ebuild,v 1.5 2013/03/20 17:19:50 chithanh Exp $
EAPI="2"
@@ -17,7 +17,8 @@ IUSE="examples doc static"
# TODO: debug can be used but dmalloc is breaking the build
# upstream has been contacted, see bug 2649238 in their bugtracker
-RDEPEND=">=net-libs/libosip-3.0.0"
+RDEPEND=">=net-libs/libosip-3.0.0
+ <net-libs/libosip-4.0.0"
# debug? ( dev-libs/dmalloc[threads] )"
DEPEND="${RDEPEND}
>=sys-devel/libtool-2.4
diff --git a/net-misc/siproxd/siproxd-0.8.0-r1.ebuild b/net-misc/siproxd/siproxd-0.8.1.ebuild
index 82ec5bf28ea5..d59091d652a5 100644
--- a/net-misc/siproxd/siproxd-0.8.0-r1.ebuild
+++ b/net-misc/siproxd/siproxd-0.8.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/siproxd-0.8.0-r1.ebuild,v 1.4 2011/01/20 16:39:28 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/siproxd/siproxd-0.8.1.ebuild,v 1.1 2013/03/20 17:19:50 chithanh Exp $
EAPI="2"
-inherit eutils
+inherit eutils autotools
DESCRIPTION="A proxy/masquerading daemon for the SIP protocol"
HOMEPAGE="http://siproxd.sourceforge.net/"
@@ -12,15 +12,16 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="examples doc static"
# TODO: debug can be used but dmalloc is breaking the build
# upstream has been contacted, see bug 2649238 in their bugtracker
-RDEPEND=">=net-libs/libosip-3.0.0"
+RDEPEND=">=net-libs/libosip-3.0.0
+ <net-libs/libosip-4.0.0"
# debug? ( dev-libs/dmalloc[threads] )"
DEPEND="${RDEPEND}
- <sys-devel/libtool-2.4:2
+ >=sys-devel/libtool-2.4
doc? ( app-text/docbook-sgml-utils
app-text/docbook-sgml-dtd:4.2 )"
# docbook-sgml-utils is for building doc
@@ -36,10 +37,12 @@ src_prepare() {
sed -i -e "s:nobody:siproxd:" doc/siproxd.conf.example \
|| die "patching doc/siproxd.conf.example failed"
# do not fail when building with external libltdl
- sed -i 's/libltdl //' Makefile.in Makefile.am || die "patching Makefile failed"
- epatch "${FILESDIR}/${PN}-libtool-2.2.patch"
+ sed -i 's/libltdl //' Makefile.am || die "patching Makefile failed"
+ epatch "${FILESDIR}/${PN}-libtool-2.4.patch"
# do not crash when building with external libltdl, bug 308495
sed -i 's|"../libltdl/ltdl.h"|<ltdl.h>|' src/plugins.h || die "patching plugins.h failed"
+
+ eautoreconf
}
src_configure() {
@@ -69,7 +72,7 @@ src_configure() {
src_install() {
einstall || die "einstall failed"
- newinitd "${FILESDIR}"/${PN}.rc6 ${PN} || die "newinitd failed"
+ newinitd "${FILESDIR}"/${PN}.rc7 ${PN} || die "newinitd failed"
dodoc AUTHORS ChangeLog NEWS README RELNOTES TODO \
doc/FAQ doc/FLI4L_HOWTO.txt doc/KNOWN_BUGS \
@@ -81,7 +84,7 @@ src_install() {
# upstream has been contacted, see bug 2649333 in their bugtracker
dohtml -r doc/html/ || die "dohtml failed"
# pdf is not build all the time
- if built_with_use app-text/docbook-sgml-utils jadetex; then
+ if has_version app-text/docbook-sgml-utils[jadetex]; then
dodoc doc/pdf/*.pdf || die "dodoc failed"
fi
fi
@@ -92,8 +95,8 @@ src_install() {
fi
# set up siproxd directories
- keepdir /var/{lib,run}/${PN} || die "keepdir failed"
- fowners siproxd:siproxd /var/{lib,run}/${PN} || die "fowners failed"
+ keepdir /var/lib/${PN} || die "keepdir failed"
+ fowners siproxd:siproxd /var/lib/${PN} || die "fowners failed"
}
pkg_postinst() {