summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-12-22 05:32:51 +0000
committerChris White <chriswhite@gentoo.org>2005-12-22 05:32:51 +0000
commit17c89c5b60cf3e8a47fec1f6ba5b6ceb940b3a9b (patch)
treeeb3d57c5a6ed33c7f92d62ea2b355e7c33751ead /net-misc/sitecopy/sitecopy-0.16.0.ebuild
parentapp-portage/porthole-0.5.0 masked for testing (diff)
downloadgentoo-2-17c89c5b60cf3e8a47fec1f6ba5b6ceb940b3a9b.tar.gz
gentoo-2-17c89c5b60cf3e8a47fec1f6ba5b6ceb940b3a9b.tar.bz2
gentoo-2-17c89c5b60cf3e8a47fec1f6ba5b6ceb940b3a9b.zip
x86 stable for bug #116347. Removed broken sftp support. built_with_use to pkg_setup. Readded self as maintianer.
(all your kde-base are belong to us version: 2.0.51.22-r3)
Diffstat (limited to 'net-misc/sitecopy/sitecopy-0.16.0.ebuild')
-rw-r--r--net-misc/sitecopy/sitecopy-0.16.0.ebuild46
1 files changed, 18 insertions, 28 deletions
diff --git a/net-misc/sitecopy/sitecopy-0.16.0.ebuild b/net-misc/sitecopy/sitecopy-0.16.0.ebuild
index f20019474b44..af582a7de43c 100644
--- a/net-misc/sitecopy/sitecopy-0.16.0.ebuild
+++ b/net-misc/sitecopy/sitecopy-0.16.0.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.16.0.ebuild,v 1.1 2005/09/10 07:01:54 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.16.0.ebuild,v 1.2 2005/12/22 05:32:51 chriswhite Exp $
inherit eutils toolchain-funcs
-IUSE="expat gssapi nls rsh sftp ssl webdav xml2 zlib"
+IUSE="expat gssapi nls rsh ssl webdav xml2 zlib"
DESCRIPTION="sitecopy is for easily maintaining remote web sites"
SRC_URI="http://www.lyra.org/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.lyra.org/sitecopy/"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+KEYWORDS="x86 ~ppc ~sparc ~amd64"
LICENSE="GPL-2"
SLOT="0"
# gnome support is disabled at this point
@@ -27,21 +27,6 @@ pkg_setup() {
ewarn "gnome support has been disabled"
ewarn "until some major bugs can"
ewarn "be fixed regarding it!"
-}
-
-src_unpack() {
- unpack ${A}
- sed -i -e \
- "s:docdir \= .*:docdir \= \$\(prefix\)\/share/doc\/${PF}:" \
- ${S}/Makefile.in || die "Documentation directory patching failed"
-}
-
-src_compile() {
-
- einfo "Sitecopy uses neon unconditionally for a security bug."
- einfo "The sitecopy system also checks for zlib, ssl, and xml"
- einfo "support through neon instead of the actual system libraries"
- einfo "therefore support must be built into neon."
if use zlib ; then
built_with_use net-misc/neon zlib || die "neon needs zlib support"
@@ -60,6 +45,21 @@ src_compile() {
built_with_use net-misc/neon expat && die "neon needs expat support disabled for
xml2 support to be enabled"
fi
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e \
+ "s:docdir \= .*:docdir \= \$\(prefix\)\/share/doc\/${PF}:" \
+ ${S}/Makefile.in || die "Documentation directory patching failed"
+}
+
+src_compile() {
+
+ einfo "Sitecopy uses neon unconditionally for a security bug."
+ einfo "The sitecopy system also checks for zlib, ssl, and xml"
+ einfo "support through neon instead of the actual system libraries"
+ einfo "therefore support must be built into neon."
# Bug 51585, GLSA 200406-03
einfo "Forcing the use of the system-wide neon library (BR #51585)."
@@ -70,7 +70,6 @@ src_compile() {
$(use_with gssapi) \
$(use_enable nls) \
$(use_enable rsh) \
- $(use_enable sftp) \
$(use_with expat) \
$(use_with xml2 libxml2 ) \
|| die "configuration failed"
@@ -91,12 +90,3 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die "install failed"
}
-
-pkg_postinst() {
- if use sftp
- then
- einfo "Please note that in order to use sftp"
- einfo "You must have 'protocol sftp instead of ftp"
- einfo "This is not documented in the man page"
- fi
-}