summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-04-24 23:11:21 +0000
committerMike Frysinger <vapier@gentoo.org>2015-04-24 23:11:21 +0000
commite978a698f935ffedba7e67ff54eacf49f4defa5d (patch)
tree717643ca8e1892bff2e16dc26a7735c0d92f3108 /net-misc/socat/files
parentFix filename matching in elisp-site-file-install. It should use shortest matc... (diff)
downloadgentoo-2-e978a698f935ffedba7e67ff54eacf49f4defa5d.tar.gz
gentoo-2-e978a698f935ffedba7e67ff54eacf49f4defa5d.tar.bz2
gentoo-2-e978a698f935ffedba7e67ff54eacf49f4defa5d.zip
Fix from Chromium OS for parallel build failures.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-misc/socat/files')
-rw-r--r--net-misc/socat/files/socat-1.7.3.0-filan-build.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/socat/files/socat-1.7.3.0-filan-build.patch b/net-misc/socat/files/socat-1.7.3.0-filan-build.patch
new file mode 100644
index 000000000000..861c673ad91d
--- /dev/null
+++ b/net-misc/socat/files/socat-1.7.3.0-filan-build.patch
@@ -0,0 +1,30 @@
+From aae2ea107b543fa908956f2fdcdf6db684e4a2e6 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@chromium.org>
+Date: Fri, 24 Apr 2015 23:06:37 -0400
+Subject: [PATCH] filan: fix depend list
+
+The link line contains more objects than the depend line; sync them like
+procan does. Otherwise, parallel builds randomly fail.
+---
+ Makefile.in | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index f2a6edb..0c00459 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -118,8 +118,9 @@ PROCAN_OBJS=procan_main.o procan.o procan-cdefs.o hostan.o error.o sycls.o sysut
+ procan: $(PROCAN_OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(PROCAN_OBJS) $(CLIBS)
+
+-filan: filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o $(CLIBS)
++FILAN_OBJS=filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o
++filan: $(FILAN_OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(FILAN_OBJS) $(CLIBS)
+
+ libxio.a: $(XIOOBJS) $(UTLOBJS)
+ $(AR) r $@ $(XIOOBJS) $(UTLOBJS)
+--
+2.3.5
+