summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-27 08:51:51 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-27 08:51:51 +0000
commite08c4b0604ff6cb3b9d921c95a2ff09f247ed780 (patch)
treef883aebb10f6aab7c79876e0cbd153b188a2018f /net-misc/socat
parentversion bump (diff)
downloadgentoo-2-e08c4b0604ff6cb3b9d921c95a2ff09f247ed780.tar.gz
gentoo-2-e08c4b0604ff6cb3b9d921c95a2ff09f247ed780.tar.bz2
gentoo-2-e08c4b0604ff6cb3b9d921c95a2ff09f247ed780.zip
Fix building against sys-kernel/linux-headers-3.17 (bug #526946 by Gangræna Gorgeous).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/ChangeLog7
-rw-r--r--net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch14
-rw-r--r--net-misc/socat/socat-1.7.2.4-r1.ebuild9
3 files changed, 27 insertions, 3 deletions
diff --git a/net-misc/socat/ChangeLog b/net-misc/socat/ChangeLog
index c649f73fa75b..ee68c42c7b08 100644
--- a/net-misc/socat/ChangeLog
+++ b/net-misc/socat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/socat
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.143 2014/07/20 11:53:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.144 2014/10/27 08:51:51 jer Exp $
+
+ 27 Oct 2014; Jeroen Roovers <jer@gentoo.org> socat-1.7.2.4-r1.ebuild,
+ +files/socat-1.7.2.4-linux-3.17.patch:
+ Fix building against sys-kernel/linux-headers-3.17 (bug #526946 by Gangræna
+ Gorgeous).
20 Jul 2014; Jeroen Roovers <jer@gentoo.org> -socat-1.7.2.3.ebuild:
Old.
diff --git a/net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch b/net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch
new file mode 100644
index 000000000000..6bf990a9b610
--- /dev/null
+++ b/net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch
@@ -0,0 +1,14 @@
+--- a/configure.in
++++ b/configure.in
+@@ -80,7 +80,10 @@
+ AC_CHECK_HEADERS(termios.h linux/if_tun.h)
+ AC_CHECK_HEADERS(net/if_dl.h)
+ AC_CHECK_HEADERS(linux/types.h)
+-AC_CHECK_HEADER(linux/errqueue.h, AC_DEFINE(HAVE_LINUX_ERRQUEUE_H), [], [#include <linux/types.h>])
++AC_CHECK_HEADER(linux/errqueue.h, AC_DEFINE(HAVE_LINUX_ERRQUEUE_H), [], [AC_INCLUDES_DEFAULT
++ #if HAVE_LINUX_TYPES_H
++ #include <linux/types.h>
++ #endif])
+ AC_CHECK_HEADERS(sys/utsname.h sys/select.h sys/file.h)
+ AC_CHECK_HEADERS(util.h bsd/libutil.h libutil.h sys/stropts.h regex.h)
+ AC_CHECK_HEADERS(linux/fs.h linux/ext2_fs.h)
diff --git a/net-misc/socat/socat-1.7.2.4-r1.ebuild b/net-misc/socat/socat-1.7.2.4-r1.ebuild
index 6d874a71f3cd..449d511f3db7 100644
--- a/net-misc/socat/socat-1.7.2.4-r1.ebuild
+++ b/net-misc/socat/socat-1.7.2.4-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.2.4-r1.ebuild,v 1.9 2014/07/20 09:16:05 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.2.4-r1.ebuild,v 1.10 2014/10/27 08:51:51 jer Exp $
EAPI=5
-inherit eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs
DESCRIPTION="Multipurpose relay (SOcket CAT)"
HOMEPAGE="http://www.dest-unreach.org/socat/"
@@ -30,6 +30,11 @@ DOCS=(
BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
)
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-linux-3.17.patch
+ eautoreconf
+}
+
src_configure() {
filter-flags '-Wno-error*' #293324
tc-export AR