summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-09-23 01:24:08 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-09-23 01:24:08 +0000
commit76f97ee628618d2bac556d1f614d391e1ac57866 (patch)
tree3d8501d37ed59ac70f53506d409ecc5e0202bcff /net-misc/spice-gtk
parentFix depend for g_clear_pointer() call in libspice-client-glib-2.0.so. Spotted... (diff)
downloadgentoo-2-76f97ee628618d2bac556d1f614d391e1ac57866.tar.gz
gentoo-2-76f97ee628618d2bac556d1f614d391e1ac57866.tar.bz2
gentoo-2-76f97ee628618d2bac556d1f614d391e1ac57866.zip
Drop the glib depend back down with a fix for g_clear_pointer() and add a missing epatch_user. bug #485550
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/ChangeLog8
-rw-r--r--net-misc/spice-gtk/files/spice-gtk-0.21-fix-g-clear-pointer-on-old-glib.patch22
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.21.ebuild9
3 files changed, 36 insertions, 3 deletions
diff --git a/net-misc/spice-gtk/ChangeLog b/net-misc/spice-gtk/ChangeLog
index 701e8721a60b..8bdd12e4ea5b 100644
--- a/net-misc/spice-gtk/ChangeLog
+++ b/net-misc/spice-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/spice-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.72 2013/09/23 01:16:13 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/ChangeLog,v 1.73 2013/09/23 01:24:08 cardoe Exp $
+
+ 23 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
+ +files/spice-gtk-0.21-fix-g-clear-pointer-on-old-glib.patch,
+ spice-gtk-0.21.ebuild:
+ Drop the glib depend back down with a fix for g_clear_pointer() and add a
+ missing epatch_user. bug #485550
23 Sep 2013; Doug Goldstein <cardoe@gentoo.org> spice-gtk-0.21.ebuild:
Fix depend for g_clear_pointer() call in libspice-client-glib-2.0.so. Spotted
diff --git a/net-misc/spice-gtk/files/spice-gtk-0.21-fix-g-clear-pointer-on-old-glib.patch b/net-misc/spice-gtk/files/spice-gtk-0.21-fix-g-clear-pointer-on-old-glib.patch
new file mode 100644
index 000000000000..83e51db67d8b
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice-gtk-0.21-fix-g-clear-pointer-on-old-glib.patch
@@ -0,0 +1,22 @@
+From f31bc2a9a6700bebc258130e802f40180af77d8e Mon Sep 17 00:00:00 2001
+From: Marc-André Lureau <marcandre.lureau@redhat.com>
+Date: Fri, 20 Sep 2013 15:54:58 +0000
+Subject: build-sys: fix g_clear_pointer usage on old glib
+
+As pointed out and verified on the ML after 0.21 release by Klaus
+Hochlehnert.
+---
+diff --git a/gtk/channel-cursor.c b/gtk/channel-cursor.c
+index 0443b9f..bbfb3c9 100644
+--- a/gtk/channel-cursor.c
++++ b/gtk/channel-cursor.c
+@@ -15,6 +15,7 @@
+ You should have received a copy of the GNU Lesser General Public
+ License along with this library; if not, see <http://www.gnu.org/licenses/>.
+ */
++#include "glib-compat.h"
+ #include "spice-client.h"
+ #include "spice-common.h"
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/net-misc/spice-gtk/spice-gtk-0.21.ebuild b/net-misc/spice-gtk/spice-gtk-0.21.ebuild
index 96180541ab19..e2df62203055 100644
--- a/net-misc/spice-gtk/spice-gtk-0.21.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.21.ebuild,v 1.2 2013/09/23 01:16:13 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/spice-gtk/spice-gtk-0.21.ebuild,v 1.3 2013/09/23 01:24:08 cardoe Exp $
EAPI=5
GCONF_DEBUG="no"
@@ -41,7 +41,7 @@ RDEPEND="${PYTHON_DEPS}
dev-libs/openssl
gtk3? ( x11-libs/gtk+:3[introspection?] )
x11-libs/gtk+:2[introspection?]
- >=dev-libs/glib-2.34:2
+ >=dev-libs/glib-2.26:2
>=x11-libs/cairo-1.2
virtual/jpeg
sys-libs/zlib
@@ -77,6 +77,11 @@ GTK2_BUILDDIR="${WORKDIR}/${P}_gtk2"
GTK3_BUILDDIR="${WORKDIR}/${P}_gtk3"
src_prepare() {
+
+ epatch "${FILESDIR}"/spice-gtk-0.21-fix-g-clear-pointer-on-old-glib.patch
+
+ epatch_user
+
use vala && vala_src_prepare
mkdir ${GTK2_BUILDDIR} ${GTK3_BUILDDIR} || die
}