summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-01-10 17:47:00 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-01-10 17:47:00 +0000
commit2dc0155f467258d2e8e17fc34ecf0d56fc3353cf (patch)
tree2d72e9caa44122a1c78b51c876a45580a9725cd0 /net-misc/tor
parentEAPI=2; honor LDFLAGS (bug #351309); tidy (diff)
downloadgentoo-2-2dc0155f467258d2e8e17fc34ecf0d56fc3353cf.tar.gz
gentoo-2-2dc0155f467258d2e8e17fc34ecf0d56fc3353cf.tar.bz2
gentoo-2-2dc0155f467258d2e8e17fc34ecf0d56fc3353cf.zip
added alpha branch
(Portage version: 2.1.9.25/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog8
-rw-r--r--net-misc/tor/tor-0.2.2.20_alpha.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 4b0aab46b938..391a7510aac8 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.225 2011/01/07 23:54:09 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.226 2011/01/10 17:47:00 blueness Exp $
+
+*tor-0.2.2.20_alpha (10 Jan 2011)
+
+ 10 Jan 2011; Anthony G. Basile <blueness@gentoo.org>
+ +tor-0.2.2.20_alpha.ebuild:
+ added alpha branch
07 Jan 2011; Christian Faulhammer <fauli@gentoo.org> -tor-0.2.1.25.ebuild,
-tor-0.2.1.26.ebuild, -tor-0.2.1.27.ebuild:
diff --git a/net-misc/tor/tor-0.2.2.20_alpha.ebuild b/net-misc/tor/tor-0.2.2.20_alpha.ebuild
new file mode 100644
index 000000000000..f82a88c219d0
--- /dev/null
+++ b/net-misc/tor/tor-0.2.2.20_alpha.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.2.20_alpha.ebuild,v 1.1 2011/01/10 17:47:00 blueness Exp $
+
+EAPI=3
+
+inherit eutils versionator
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="http://www.torproject.org/dist/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+# libevent-2.0 is masked but we still depend on it
+# See: bug #206969 and https://trac.torproject.org/projects/tor/ticket/920
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-2.0"
+# The tordns patch for tsocks avoids some leakage of information thus raising anonymity
+RDEPEND="${DEPEND}
+ net-proxy/tsocks[tordns]"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
+ epatch "${FILESDIR}"/${PN}-0.2.1.19-logrotate.patch
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/tor.initd-r4 tor
+ emake DESTDIR="${D}" install || die
+ keepdir /var/{lib,log,run}/tor
+
+ dodoc README ChangeLog ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/*.txt
+
+ fperms 750 /var/lib/tor /var/log/tor
+ fperms 755 /var/run/tor
+ fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
+
+ insinto /etc/logrotate.d
+ newins contrib/tor.logrotate tor
+
+ # allow the tor user more open files to avoid errors, see bug 251171
+ insinto /etc/security/limits.d/
+ doins "${FILESDIR}"/tor.conf
+}
+
+pkg_postinst() {
+ elog "You must create /etc/tor/torrc, you can use the sample that is in that directory"
+ elog "To have privoxy and tor working together you must add:"
+ elog "forward-socks4a / localhost:9050 ."
+ elog "(notice the . at the end of the line)"
+ elog "to /etc/privoxy/config"
+}