summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-09-21 16:32:39 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-09-21 16:32:39 +0000
commit99d921f848813a37811a9d0d7b72982a9c0b3eb3 (patch)
treeae64e2bc4602c70bbec5b58a600db5827d4e4b0b /net-misc/unison/unison-2.17.1.ebuild
parentversion bump (diff)
downloadgentoo-2-99d921f848813a37811a9d0d7b72982a9c0b3eb3.tar.gz
gentoo-2-99d921f848813a37811a9d0d7b72982a9c0b3eb3.tar.bz2
gentoo-2-99d921f848813a37811a9d0d7b72982a9c0b3eb3.zip
Fix for gtk2 deprecation, update latest stable and unstable versions.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc/unison/unison-2.17.1.ebuild')
-rw-r--r--net-misc/unison/unison-2.17.1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/unison/unison-2.17.1.ebuild b/net-misc/unison/unison-2.17.1.ebuild
new file mode 100644
index 000000000000..f33ae0d5f563
--- /dev/null
+++ b/net-misc/unison/unison-2.17.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.17.1.ebuild,v 1.1 2005/09/21 16:32:39 mattam Exp $
+
+inherit eutils
+
+IUSE="gtk doc static debug threads"
+
+DESCRIPTION="Two-way cross-platform file synchronizer"
+HOMEPAGE="http://www.cis.upenn.edu/~bcpierce/unison/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+
+DEPEND=">=dev-lang/ocaml-3.04
+ gtk? ( >=dev-ml/lablgtk-2.2 )"
+
+RDEPEND="gtk? ( >=dev-ml/lablgtk-2.2 )
+|| ( net-misc/x11-ssh-askpass net-misc/gtk2-ssh-askpass )"
+
+SRC_URI="http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
+doc? ( http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
+ http://www.cis.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+
+pkg_setup() {
+ ewarn "This is a beta release, use at your very own risk"
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ # Fix for coreutils change of tail syntax
+ cd ${S}
+ sed -i -e 's/tail -1/tail -n 1/' Makefile.OCaml
+}
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ myconf="$myconf THREADS=true"
+ fi
+
+ if use static; then
+ myconf="$myconf STATIC=true"
+ fi
+
+ if use debug; then
+ myconf="$myconf DEBUGGING=true"
+ fi
+
+ if use gtk; then
+ myconf="$myconf UISTYLE=gtk2"
+ else
+ myconf="$myconf UISTYLE=text"
+ fi
+
+ make $myconf CFLAGS="" || die "error making unsion"
+}
+
+src_install () {
+ # install manually, since it's just too much
+ # work to force the Makefile to do the right thing.
+ dobin unison || die
+ dodoc BUGS.txt CONTRIB COPYING INSTALL NEWS \
+ README ROADMAP.txt TODO.txt || die
+
+ if use doc; then
+ dohtml ${DISTDIR}/${P}-manual.html || die
+ dodoc ${DISTDIR}/${P}-manual.pdf || die
+ fi
+}