summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-29 02:55:44 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-29 02:55:44 +0000
commit0a74eacfb38512d624bb60786ee1ca0c5e1f690b (patch)
treedddd4c9d1a6030a1c759aaffae7d65a81535d6e2 /net-misc/wget
parentVersion bumped. (diff)
downloadgentoo-2-0a74eacfb38512d624bb60786ee1ca0c5e1f690b.tar.gz
gentoo-2-0a74eacfb38512d624bb60786ee1ca0c5e1f690b.tar.bz2
gentoo-2-0a74eacfb38512d624bb60786ee1ca0c5e1f690b.zip
cleanup and fix autotool stuff
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/wget-1.9.1-r5.ebuild48
1 files changed, 18 insertions, 30 deletions
diff --git a/net-misc/wget/wget-1.9.1-r5.ebuild b/net-misc/wget/wget-1.9.1-r5.ebuild
index a55852e8df53..33a47bfbc16c 100644
--- a/net-misc/wget/wget-1.9.1-r5.ebuild
+++ b/net-misc/wget/wget-1.9.1-r5.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9.1-r5.ebuild,v 1.10 2005/05/21 18:47:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9.1-r5.ebuild,v 1.11 2005/05/29 02:55:44 vapier Exp $
-inherit gnuconfig eutils flag-o-matic
-
-IUSE="build debug ipv6 nls socks5 ssl static"
+inherit eutils flag-o-matic
PATCHVER=0.3
DESCRIPTION="Network utility to retrieve files from the WWW"
@@ -16,31 +14,27 @@ SRC_URI="mirror://gnu/wget/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
+IUSE="build debug ipv6 nls socks5 ssl static"
RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
socks5? ( net-proxy/dante )"
-
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
sys-devel/autoconf"
-
-PATCHDIR="${WORKDIR}/patches"
-
src_unpack() {
- unpack ${A} ; cd ${S}
- export EPATCH_SUFFIX="patch"
- epatch ${PATCHDIR}/gentoo
- epatch ${PATCHDIR}/debian
- epatch ${PATCHDIR}/mandrake
+ unpack ${A}
+ cd "${S}"
+ local PATCHDIR=${WORKDIR}/patches
+ EPATCH_SUFFIX="patch"
+ EPATCH_MULTI_MSG="Applying Gentoo patches ..." epatch "${PATCHDIR}"/gentoo
+ EPATCH_MULTI_MSG="Applying Debian patches ..." epatch "${PATCHDIR}"/debian
+ EPATCH_MULTI_MSG="Applying Mandrake patches ..." epatch "${PATCHDIR}"/mandrake
+ autoconf || die "autoconf failed"
}
src_compile() {
- # Make wget use up-to-date configure scripts
- gnuconfig_update
-
- use ssl && append-flags -I/usr/include/openssl
-
+ use static && append-ldflags -static
econf \
--sysconfdir=/etc/wget \
$(use_with ssl) $(use_enable ssl opie) $(use_enable ssl digest) \
@@ -49,22 +43,16 @@ src_compile() {
$(use_enable debug) \
$(use_with socks5 socks) \
|| die
-
- if use static; then
- emake LDFLAGS="--static" || die
- else
- emake || die
- fi
+ emake || die
}
src_install() {
- if use build; then
- insinto /usr
- dobin ${S}/src/wget
- return
+ if use build ; then
+ dobin "${S}"/src/wget || die "dobin"
+ return 0
fi
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog MACHINES MAILING-LIST NEWS README TODO
dodoc doc/sample.wgetrc
}