summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Destuynder <kang@gentoo.org>2006-11-09 15:24:29 +0000
committerGuillaume Destuynder <kang@gentoo.org>2006-11-09 15:24:29 +0000
commitc499d63aef167c4b24d5eb0012145bbbda6ae37b (patch)
tree10782dbebecc0d614471a84b6921591bd461d7c4 /net-misc/whoischk/whoischk-0.2.4-r1.ebuild
parentSmall cleanups. (diff)
downloadgentoo-2-c499d63aef167c4b24d5eb0012145bbbda6ae37b.tar.gz
gentoo-2-c499d63aef167c4b24d5eb0012145bbbda6ae37b.tar.bz2
gentoo-2-c499d63aef167c4b24d5eb0012145bbbda6ae37b.zip
Fixes #111556, remove jwhois caching, add throttling patch (so that this package actually does something usefull;)
(Portage version: 2.1.2_rc1-r4)
Diffstat (limited to 'net-misc/whoischk/whoischk-0.2.4-r1.ebuild')
-rw-r--r--net-misc/whoischk/whoischk-0.2.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/whoischk/whoischk-0.2.4-r1.ebuild b/net-misc/whoischk/whoischk-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..2919f485f481
--- /dev/null
+++ b/net-misc/whoischk/whoischk-0.2.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whoischk/whoischk-0.2.4-r1.ebuild,v 1.1 2006/11/09 15:24:29 kang Exp $
+
+DESCRIPTION="monitor a list of domains and report when there has been any change"
+HOMEPAGE="http://downloads.afterdark.org.uk/whoischk/"
+SRC_URI="http://downloads.afterdark.org.uk/whoischk/${P}.tar.gz"
+
+inherit eutils
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash
+ net-misc/jwhois"
+
+src_compile() {
+ sed -i -e 's|WHOIS=whois|WHOIS="jwhois\ -f"|' whoischk || die
+ epatch ${FILESDIR}/throttle.patch.bz2
+}
+
+src_install() {
+ dobin whoischk || die
+ dodoc AUTHOR ChangeLog INSTALL LICENCE PATCHES README USAGE sample-rc-file
+}