summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-03-26 09:14:57 +0000
committerMichael Weber <xmw@gentoo.org>2012-03-26 09:14:57 +0000
commit080bad8bdfd33705a20bd1d6ea1b56c28b6406fc (patch)
tree7928e378f4e261d2293bb4c9228f6f468fd86080 /net-misc
parentFix UPnP crash and build with libgpod-sharp-0.8.2 (#409597 by Bjoern Ottervik). (diff)
downloadgentoo-2-080bad8bdfd33705a20bd1d6ea1b56c28b6406fc.tar.gz
gentoo-2-080bad8bdfd33705a20bd1d6ea1b56c28b6406fc.tar.bz2
gentoo-2-080bad8bdfd33705a20bd1d6ea1b56c28b6406fc.zip
Version bump to git commit as requested by patkoscsaba (bug 407933)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/hotot/ChangeLog8
-rw-r--r--net-misc/hotot/hotot-0.9.7.51.ebuild65
-rw-r--r--net-misc/hotot/hotot-9999.ebuild25
3 files changed, 95 insertions, 3 deletions
diff --git a/net-misc/hotot/ChangeLog b/net-misc/hotot/ChangeLog
index 20cc2f33e854..a67a46248287 100644
--- a/net-misc/hotot/ChangeLog
+++ b/net-misc/hotot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/hotot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/ChangeLog,v 1.7 2012/03/25 22:46:51 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/ChangeLog,v 1.8 2012/03/26 09:14:57 xmw Exp $
+
+*hotot-0.9.7.51 (26 Mar 2012)
+
+ 26 Mar 2012; Michael Weber <xmw@gentoo.org> +hotot-0.9.7.51.ebuild,
+ hotot-9999.ebuild:
+ Version bump to git commit as requested by patkoscsaba (bug 407933)
25 Mar 2012; Michael Weber <xmw@gentoo.org> hotot-9999.ebuild, metadata.xml:
Update live build, new VCS repo, cmake-utils, use flags (bug 407933)
diff --git a/net-misc/hotot/hotot-0.9.7.51.ebuild b/net-misc/hotot/hotot-0.9.7.51.ebuild
new file mode 100644
index 000000000000..749d42cc0bcb
--- /dev/null
+++ b/net-misc/hotot/hotot-0.9.7.51.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-0.9.7.51.ebuild,v 1.1 2012/03/26 09:14:57 xmw Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="gtk? 2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit cmake-utils python
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+SRC_URI="https://github.com/shellex/Hotot/tarball/4c74e8b2 -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chrome gtk kde qt4"
+
+RDEPEND="
+ gtk? ( dev-python/pywebkitgtk )
+ qt4? ( x11-libs/qt-webkit:4
+ kde? ( kde-base/kdelibs ) )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S=${WORKDIR}/shellex-Hotot-4c74e8b
+
+pkg_setup() {
+ if ! use gtk ; then
+ if ! use qt4 ; then
+ ewarn "neither gtk not qt4 binaries will be build"
+ if ! use chrome ; then
+ die "enable one use flag of chrome, gtk or qt4"
+ fi
+ fi
+ fi
+ python_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} \
+ $(cmake-utils_use_with chrome CHROME) \
+ $(cmake-utils_use_with gtk GTK) \
+ $(cmake-utils_use_with kde KDE) \
+ $(cmake-utils_use_with qt4 QT) \
+ -DPYTHON_EXECUTABLE=$(PYTHON -2 -a)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ find "${D}" -name "*.pyc" -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}
diff --git a/net-misc/hotot/hotot-9999.ebuild b/net-misc/hotot/hotot-9999.ebuild
index 989378dadd30..869b764fde01 100644
--- a/net-misc/hotot/hotot-9999.ebuild
+++ b/net-misc/hotot/hotot-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-9999.ebuild,v 1.2 2012/03/25 22:46:51 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/hotot/hotot-9999.ebuild,v 1.3 2012/03/26 09:14:57 xmw Exp $
EAPI=4
@@ -21,10 +21,23 @@ IUSE="chrome gtk kde qt4"
RDEPEND="
gtk? ( dev-python/pywebkitgtk )
- qt4? ( x11-libs/qt-webkit:4 )"
+ qt4? ( x11-libs/qt-webkit:4
+ kde? ( kde-base/kdelibs ) )"
DEPEND="${RDEPEND}
sys-devel/gettext"
+pkg_setup() {
+ if ! use gtk ; then
+ if ! use qt4 ; then
+ ewarn "neither gtk not qt4 binaries will be build"
+ if ! use chrome ; then
+ die "enable one use flag of chrome, gtk or qt4"
+ fi
+ fi
+ fi
+ python_pkg_setup
+}
+
src_configure() {
mycmakeargs="${mycmakeargs} \
$(cmake-utils_use_with chrome CHROME) \
@@ -41,3 +54,11 @@ src_install() {
find "${D}" -name "*.pyc" -delete
}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}