summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-08-18 23:10:03 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-08-18 23:10:03 +0000
commit5038610d92e0d7811df11592588f0371698b0aa4 (patch)
treef803c30c475e4a2e74c05dd0c553810d44b2f6e4 /net-misc
parentClosing #59223 (Manifest recommit) (diff)
downloadgentoo-2-5038610d92e0d7811df11592588f0371698b0aa4.tar.gz
gentoo-2-5038610d92e0d7811df11592588f0371698b0aa4.tar.bz2
gentoo-2-5038610d92e0d7811df11592588f0371698b0aa4.zip
unmasked and closing #54390
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/stunnel/ChangeLog7
-rw-r--r--net-misc/stunnel/files/stunnel.conf.4.0550
-rw-r--r--net-misc/stunnel/files/stunnel.rc6.4.0520
-rw-r--r--net-misc/stunnel/stunnel-4.05.ebuild4
4 files changed, 78 insertions, 3 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
index 5046512772ff..c70013aa6b84 100644
--- a/net-misc/stunnel/ChangeLog
+++ b/net-misc/stunnel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/stunnel
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.31 2004/07/28 20:35:26 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.32 2004/08/18 23:10:03 aliz Exp $
+
+ 18 Aug 2004; Daniel Ahlberg <aliz@gentoo.org> files/stunnel.conf.4.05,
+ files/stunnel.rc6.4.05:
+ Added missing files to CVS, closing #54390.
+ Unmasked on x86 and amd64.
28 Jul 2004; Danny van Dyk <kugelfang@gentoo.org> stunnel-3.26.ebuild:
Marked ~amd64.
diff --git a/net-misc/stunnel/files/stunnel.conf.4.05 b/net-misc/stunnel/files/stunnel.conf.4.05
new file mode 100644
index 000000000000..571e74b50393
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel.conf.4.05
@@ -0,0 +1,50 @@
+# location of pid file
+pid = /etc/stunnel/stunnel.pid
+
+# user to run as
+setuid = stunnel
+setgid = stunnel
+
+# Authentication stuff
+#verify = 2
+# don't forget about c_rehash CApath
+# it is located inside chroot jail:
+#CApath = /certs
+# or simply use CAfile instead:
+#CAfile = /usr/etc/stunnel/certs.pem
+
+# Some debugging stuff
+#debug = 7
+#output = stunnel.log
+
+# Use it for client mode
+#client = yes
+
+# sample service-level configuration
+
+#[pop3s]
+#accept = 995
+#connect = 110
+
+#[imaps]
+#accept = 993
+#connect = 143
+
+#[ssmtp]
+#accept = 465
+#connect = 25
+
+#[s1]
+#accept = 5000
+#connect = mail.osw.pl:110
+#delay = yes
+
+#[s2]
+#accept = 5001
+#connect = mail.osw.pl:25
+
+#[https]
+#accept = 443
+#connect = 80
+#TIMEOUTclose = 0
+
diff --git a/net-misc/stunnel/files/stunnel.rc6.4.05 b/net-misc/stunnel/files/stunnel.rc6.4.05
new file mode 100644
index 000000000000..4f9d57fba0b2
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel.rc6.4.05
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/files/stunnel.rc6.4.05,v 1.1 2004/08/18 23:10:03 aliz Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting stunnel"
+ start-stop-daemon -p /etc/stunnel/stunnel.pid --start --quiet --exec /usr/sbin/stunnel -- /etc/stunnel/stunnel.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping stunnel"
+ start-stop-daemon -p /etc/stunnel/stunnel.pid --stop --quiet --exec /usr/sbin/stunnel -- /etc/stunnel/stunnel.conf
+ eend $?
+}
diff --git a/net-misc/stunnel/stunnel-4.05.ebuild b/net-misc/stunnel/stunnel-4.05.ebuild
index d8d3501d0658..3e9ae6d61f9c 100644
--- a/net-misc/stunnel/stunnel-4.05.ebuild
+++ b/net-misc/stunnel/stunnel-4.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.05.ebuild,v 1.6 2004/07/15 03:38:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.05.ebuild,v 1.7 2004/08/18 23:10:03 aliz Exp $
inherit ssl-cert eutils flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha arm ~amd64"
+KEYWORDS="x86 ~ppc ~sparc ~alpha arm amd64"
IUSE="static"
DEPEND="virtual/libc