summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-10-29 15:55:35 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-10-29 15:55:35 +0000
commit52760de7eeb875cab5da0b3c37ff22b357c7e3aa (patch)
treea5a1ecb8d7a30221da2d37fe5f5f9e5ede009992 /net-misc
parentStable on hppa, ppc. See bug #109997. (diff)
downloadgentoo-2-52760de7eeb875cab5da0b3c37ff22b357c7e3aa.tar.gz
gentoo-2-52760de7eeb875cab5da0b3c37ff22b357c7e3aa.tar.bz2
gentoo-2-52760de7eeb875cab5da0b3c37ff22b357c7e3aa.zip
Version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yate/ChangeLog8
-rw-r--r--net-misc/yate/files/digest-yate-0.9.0_pre21
-rw-r--r--net-misc/yate/files/yate-0.9.0-gtk2.diff12
-rw-r--r--net-misc/yate/yate-0.9.0_pre2.ebuild59
4 files changed, 79 insertions, 1 deletions
diff --git a/net-misc/yate/ChangeLog b/net-misc/yate/ChangeLog
index 31b7818c0283..1beeadcd778c 100644
--- a/net-misc/yate/ChangeLog
+++ b/net-misc/yate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/yate
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/ChangeLog,v 1.8 2005/09/23 00:04:39 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/ChangeLog,v 1.9 2005/10/29 15:55:35 stkn Exp $
+
+*yate-0.9.0_pre2 (29 Oct 2005)
+
+ 29 Oct 2005; Stefan Knoblich <stkn@gentoo.org>
+ +files/yate-0.9.0-gtk2.diff, +yate-0.9.0_pre2.ebuild:
+ Version bump.
23 Sep 2005; Stefan Knoblich <stkn@gentoo.org> yate-0.9.0_pre1.ebuild:
gtk2 -> gtk use-flag change for bug #106560 and small cleanup.
diff --git a/net-misc/yate/files/digest-yate-0.9.0_pre2 b/net-misc/yate/files/digest-yate-0.9.0_pre2
new file mode 100644
index 000000000000..a75c871bba01
--- /dev/null
+++ b/net-misc/yate/files/digest-yate-0.9.0_pre2
@@ -0,0 +1 @@
+MD5 10ec0a4f1cb1b0964ce3f37cdbce9798 yate-0.9.0pre2.tar.gz 853844
diff --git a/net-misc/yate/files/yate-0.9.0-gtk2.diff b/net-misc/yate/files/yate-0.9.0-gtk2.diff
new file mode 100644
index 000000000000..c105393fdc37
--- /dev/null
+++ b/net-misc/yate/files/yate-0.9.0-gtk2.diff
@@ -0,0 +1,12 @@
+--- yate/contrib/gtk2/Makefile.in.orig 2005-10-29 17:49:21.000000000 +0000
++++ yate/contrib/gtk2/Makefile.in 2005-10-29 17:29:40.000000000 +0000
+@@ -15,7 +15,9 @@
+ MODFLAGS:= @MODULE_LDFLAGS@
+ MODSTRIP:= @MODULE_SYMBOLS@
+
++ifeq (@HAVE_GTK2@,yes)
+ PROJECT = libgtk2client.a
++endif
+ SOURCES = gtk2client.cpp
+ OBJECTS = $(SOURCES:.cpp=.o)
+
diff --git a/net-misc/yate/yate-0.9.0_pre2.ebuild b/net-misc/yate/yate-0.9.0_pre2.ebuild
new file mode 100644
index 000000000000..269ee0ee3533
--- /dev/null
+++ b/net-misc/yate/yate-0.9.0_pre2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/yate/yate-0.9.0_pre2.ebuild,v 1.1 2005/10/29 15:55:35 stkn Exp $
+
+IUSE="gsm gtk h323 ilbc postgres zaptel"
+
+inherit eutils
+
+DESCRIPTION="YATE - Yet Another Telephony Engine"
+HOMEPAGE="http://yate.null.ro/"
+SRC_URI="http://voip.null.ro/tarballs/${P/_/}.tar.gz"
+
+S=${WORKDIR}/${PN}
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="media-sound/sox
+ zaptel? ( >=net-libs/libpri-1.0.0
+ >=net-misc/zaptel-1.0.0 )
+ h323? ( >=net-libs/openh323-1.15.3 )
+ gtk? ( >=x11-libs/gtk+-2.6.8 )
+ gsm? ( media-sound/gsm )
+ postgres? ( dev-db/postgresql )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fix gtk2 plugin makefile
+ epatch ${FILESDIR}/${PN}-0.9.0-gtk2.diff
+}
+
+src_compile() {
+ econf \
+ $(use_with gtk libgtk2 /usr) \
+ $(use_with h323 openh323 /usr) \
+ $(use_with h323 pwlib /usr) \
+ $(use_with zaptel libpri) \
+ $(use_with gsm libgsm) \
+ $(use_with postgres libpq /usr) \
+ $(use_enable ilbc) \
+ || die "Configure failed"
+ emake everything || die "Make failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "Make install failed"
+
+ newinitd ${FILESDIR}/yate.rc6 yate
+ newconfd ${FILESDIR}/yate.confd yate
+
+ # install standard docs...
+ dodoc README ChangeLog docs/*
+
+ docinto scripts
+ dodoc scripts/*
+}