summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-09-14 14:56:15 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-09-14 14:56:15 +0000
commitd83229e4da88344cdfc3b9ba1eaf9dba61ea18a9 (patch)
treee8f39f59dd28b20b8ce5cd76c33e8afa5d87c012 /net-misc
parentVersion bump (diff)
downloadgentoo-2-d83229e4da88344cdfc3b9ba1eaf9dba61ea18a9.tar.gz
gentoo-2-d83229e4da88344cdfc3b9ba1eaf9dba61ea18a9.tar.bz2
gentoo-2-d83229e4da88344cdfc3b9ba1eaf9dba61ea18a9.zip
Version bump, should fix bug #234514
(Portage version: 2.2_rc8/cvs/Linux 2.6.22-gentoo-r2 i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wicd/ChangeLog7
-rw-r--r--net-misc/wicd/wicd-1.5.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index 73c7822209ba..8e36ee06b056 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/wicd
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.5 2008/08/04 16:16:37 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.6 2008/09/14 14:56:15 darkside Exp $
+
+*wicd-1.5.2 (14 Sep 2008)
+
+ 14 Sep 2008; Jeremy Olexa <darkside@gentoo.org> +wicd-1.5.2.ebuild:
+ Version bump, should fix bug #234514
*wicd-1.5.1 (04 Aug 2008)
diff --git a/net-misc/wicd/wicd-1.5.2.ebuild b/net-misc/wicd/wicd-1.5.2.ebuild
new file mode 100644
index 000000000000..5b3123a6bb9e
--- /dev/null
+++ b/net-misc/wicd/wicd-1.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.5.2.ebuild,v 1.1 2008/09/14 14:56:15 darkside Exp $
+
+inherit distutils
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python
+ dev-python/pygtk
+ || (
+ net-misc/dhcp
+ net-misc/dhcpcd
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/ethtool
+ sys-apps/net-tools
+ )"
+
+src_compile() {
+ ${python} ./setup.py configure --no-install-init --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}/wicd-init.d" wicd || die "newinitd failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/conf.d/rc"
+ elog "(For example, RC_PLUG_SERVICES=\"!net.eth0 !net.wlan0\")"
+}