summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-16 20:36:33 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-16 20:36:33 +0000
commit166a313c3fa7f53a33018bc050bb6557209007ac (patch)
treea9a08cb6c32bf109a7adc96c667e55a16ba81313 /net-news/pan
parentebuild now works (diff)
downloadgentoo-2-166a313c3fa7f53a33018bc050bb6557209007ac.tar.gz
gentoo-2-166a313c3fa7f53a33018bc050bb6557209007ac.tar.bz2
gentoo-2-166a313c3fa7f53a33018bc050bb6557209007ac.zip
new version; removed older
Diffstat (limited to 'net-news/pan')
-rw-r--r--net-news/pan/files/digest-pan-0.11.1.911
-rw-r--r--net-news/pan/pan-0.11.1.91.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-news/pan/files/digest-pan-0.11.1.91 b/net-news/pan/files/digest-pan-0.11.1.91
new file mode 100644
index 000000000000..0dc5385435ad
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.11.1.91
@@ -0,0 +1 @@
+MD5 e94593bb3bdabbad1e2f40ab2e6e8c29 pan-0.11.1.91.tar.bz2 1544192
diff --git a/net-news/pan/pan-0.11.1.91.ebuild b/net-news/pan/pan-0.11.1.91.ebuild
new file mode 100644
index 000000000000..eae304050514
--- /dev/null
+++ b/net-news/pan/pan-0.11.1.91.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.11.1.91.ebuild,v 1.1 2002/01/16 20:36:33 azarah Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A newsreader for GNOME."
+SRC_URI="http://pan.rebelbase.com/download/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com/"
+
+DEPEND="virtual/x11
+ nls? ( sys-devel/gettext )
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=media-libs/gdk-pixbuf-0.11.0-r1
+ >=dev-libs/libxml-1.8.11
+ gtkhtml? ( >=gnome-extra/gtkhtml-0.14.0-r1 )"
+
+src_compile() {
+ local myconf
+
+ use nls || myconf=--disable-nls
+ use gtkhtml && myconf="$myconf --enable-html"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ $myconf || die
+
+ # Doesn't work with -j 4 (hallski)
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/usr sysconfdir=${D}/etc install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}