summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-18 06:15:14 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-18 06:15:14 +0000
commit626f2b66ab32903610492bebd80a45c63580ad99 (patch)
treea490149f6aba4e5d00b6863e75130aefe746b2c1 /net-p2p/bittornado
parentclean out older versions (Manifest recommit) (diff)
downloadgentoo-2-626f2b66ab32903610492bebd80a45c63580ad99.tar.gz
gentoo-2-626f2b66ab32903610492bebd80a45c63580ad99.tar.bz2
gentoo-2-626f2b66ab32903610492bebd80a45c63580ad99.zip
BitTornado was formerly bittorrent-theshadow, but the codebase is going in a different location than mainline bittorrent, so the name has changed, and it's becoming a separate package. Ebuild submitted by J.J.H.Hillen <neeneelaatmaar@gmx.net> in bug #44887.
Diffstat (limited to 'net-p2p/bittornado')
-rw-r--r--net-p2p/bittornado/ChangeLog13
-rw-r--r--net-p2p/bittornado/Manifest2
-rw-r--r--net-p2p/bittornado/bittornado-0.0.1.ebuild64
-rw-r--r--net-p2p/bittornado/files/digest-bittornado-0.0.11
-rw-r--r--net-p2p/bittornado/metadata.xml5
5 files changed, 85 insertions, 0 deletions
diff --git a/net-p2p/bittornado/ChangeLog b/net-p2p/bittornado/ChangeLog
new file mode 100644
index 000000000000..cce4592c7a52
--- /dev/null
+++ b/net-p2p/bittornado/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-p2p/bittornado
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.1 2004/03/18 06:15:14 eradicator Exp $
+
+*bittornado-0.0.1 (17 Mar 2004)
+
+ 17 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ bittornado-0.0.1.ebuild:
+ BitTornado was formerly bittorrent-theshadow, but the codebase is going in a
+ different location than mainline bittorrent, so the name has changed, and it's
+ becoming a separate package. Ebuild submitted by J.J.H.Hillen
+ <neeneelaatmaar@gmx.net> in bug #44887.
+
diff --git a/net-p2p/bittornado/Manifest b/net-p2p/bittornado/Manifest
new file mode 100644
index 000000000000..67c1d4df8bd2
--- /dev/null
+++ b/net-p2p/bittornado/Manifest
@@ -0,0 +1,2 @@
+MD5 ebd755dc98e6d1384b6d262c80a31f7f bittornado-0.0.1.ebuild 1908
+MD5 7e5f7bd9dad3e54d2c6a0a25947d28ca files/digest-bittornado-0.0.1 68
diff --git a/net-p2p/bittornado/bittornado-0.0.1.ebuild b/net-p2p/bittornado/bittornado-0.0.1.ebuild
new file mode 100644
index 000000000000..1d7e046acd26
--- /dev/null
+++ b/net-p2p/bittornado/bittornado-0.0.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.0.1.ebuild,v 1.1 2004/03/18 06:15:14 eradicator Exp $
+
+inherit distutils
+inherit eutils
+
+MY_PN="BitTornado"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="TheShad0w's experimental BitTorrent client"
+HOMEPAGE="http://bt.degreez.net/"
+SRC_URI="http://dl9.degreez.net/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.0
+ !virtual/bittorrent"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+
+PROVIDE="virtual/bittorrent"
+
+S="${WORKDIR}/${MY_PN}-CVS"
+PIXMAPLOC="/usr/share/pixmaps/bittorrent"
+
+src_unpack() {
+ unpack ${A}
+ sed -i "s:os.path.abspath(os.path.dirname(sys.argv\[0\])):\"${PIXMAPLOC}/\":" ${S}/btdownloadgui.py || die "sed failure 1"
+ sed -i "s:BitTorrent\.version:BitTornado.version:g" ${S}/setup.py || die "sed failure 2"
+ sed -i 's:packages = ["BitTornado"],:packages = ["BitTornado","BitTornado.BT1"]:g' ${S}/setup.py || die "sed failure 3"
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ dodir ${PIXMAPLOC}
+ insinto ${PIXMAPLOC}
+ doins *.ico *.gif
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ rm ${D}/usr/bin/*gui.py
+ fi
+}
diff --git a/net-p2p/bittornado/files/digest-bittornado-0.0.1 b/net-p2p/bittornado/files/digest-bittornado-0.0.1
new file mode 100644
index 000000000000..d6457163cd71
--- /dev/null
+++ b/net-p2p/bittornado/files/digest-bittornado-0.0.1
@@ -0,0 +1 @@
+MD5 6e0637a199d8d7d338d6b5dcdabc695e BitTornado-0.0.1.tar.gz 153602
diff --git a/net-p2p/bittornado/metadata.xml b/net-p2p/bittornado/metadata.xml
new file mode 100644
index 000000000000..aa0f3664825f
--- /dev/null
+++ b/net-p2p/bittornado/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+</pkgmetadata>